Subject: [VCARDDAV] [Technical Errata Reported] RFC6350 (3136)

From: RFC Errata System <[email-masked]>
Date: Sat, 25 Feb 2012 17:07:36 -0800 (PST)

The following errata report has been submitted for RFC6350,
"vCard Format Specification".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=6350&eid=3136

--------------------------------------
Type: Technical
Reported by: Kai Giebeler <[email-masked]>

Section: 3.3.

Original Text
-------------
   QSAFE-CHAR = WSP / "!" / %x23-7E / NON-ASCII
     ; Any character except CTLs, DQUOTE

   SAFE-CHAR = WSP / "!" / %x23-39 / %x3C-7E / NON-ASCII
     ; Any character except CTLs, DQUOTE, ";", ":"

   VALUE-CHAR = WSP / VCHAR / NON-ASCII
     ; Any textual character

Corrected Text
--------------
   QSAFE-CHAR = WSP / "!" / %x23-7E / NON-ASCII
     ; Any character except CTLs, DQUOTE but including HTAB

   SAFE-CHAR = WSP / "!" / %x23-39 / %x3C-7E / NON-ASCII
     ; Any character except CTLs, DQUOTE, ";", ":" but including HTAB

   VALUE-CHAR = WSP / VCHAR / NON-ASCII
     ; Any textual character including HTAB

Notes
-----
The ABNF is inconsistent with the textual decription regarding the HTAB character which is part of WSP and CTL

Alternatively HTAB could be excluded by replacing WSP by SP in at least QSAFE-CHAR and SAFE-CHAR.

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC6350 (draft-ietf-vcarddav-vcardrev-22)
--------------------------------------
Title               : vCard Format Specification
Publication Date    : August 2011
Author(s)           : S. Perreault
Category            : PROPOSED STANDARD
Source              : vCard and CardDAV
Area                : Applications
Stream              : IETF
Verifying Party     : IESG

---

From: Simon Perreault <[email-masked]>
Date: Mon, 27 Feb 2012 08:29:04 -0500

> Original Text

I don't understand the point of your change. "Any character" implicitly 
includes HTAB. Why does it need to be repeated? Do we also need to say 
"any character including A, B, C, D, ..."?

Simon
-- 
DTN made easy, lean, and smart --> http://postellation.viagenie.ca
NAT64/DNS64 open-source        --> http://ecdysis.viagenie.ca
STUN/TURN server               --> http://numb.viagenie.ca

---

From: Barry Leiba <[email-masked]>
Date: Mon, 27 Feb 2012 09:02:47 -0500

On Mon, Feb 27, 2012 at 08:29, Simon Perreault
<[email-masked]> wrote:
> includes HTAB. Why does it need to be repeated? Do we also need to say "any
> character including A, B, C, D, ..."?

His point for the first two is that HTAB is a CTL (according to RFC
5234), so the comment "any character except CTLs" excludes HTAB.  But
the grammar uses WSP, which *includes* HTAB (also RFC 5234).  So the
comment is not consistent with the grammar.  Either change WSP to SP
(thus excluding HTAB, as the comment says) or make the change he
suggests to the comment, so it's consistent with the grammar.

For the third item, VALUE-CHAR, I think the point is that it's not
clear whether HTAB is a "textual character", since that term isn't
formally defined.  By saying "including HTAB" in the comment (since
it's included by WSP), it's clearer.

I think this is a correct erratum.

Barry

---

From: Simon Perreault <[email-masked]>
Date: Mon, 27 Feb 2012 09:17:01 -0500

> suggests to the comment, so it's consistent with the grammar.

Got it, thanks.

> it's included by WSP), it's clearer.

Makes sense.

> I think this is a correct erratum.

Me too!

Thanks for the explanation,
Simon
-- 
DTN made easy, lean, and smart --> http://postellation.viagenie.ca
NAT64/DNS64 open-source        --> http://ecdysis.viagenie.ca
STUN/TURN server               --> http://numb.viagenie.ca

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 27 Feb 2012 11:02:20 -0700

>> I think this is a correct erratum.

I shall mark this as "Verified".

Peter

-- 
Peter Saint-Andre
https://stpeter.im/