Subject: [VCARDDAV] [Technical Errata Reported] RFC6350 (3138)

From: RFC Errata System <[email-masked]>
Date: Sat, 25 Feb 2012 17:40:50 -0800 (PST)

The following errata report has been submitted for RFC6350,
"vCard Format Specification".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=6350&eid=3138

--------------------------------------
Type: Technical
Reported by: Kai Giebeler <[email-masked]>

Section: 3.3.

Original Text
-------------
   param-value = *SAFE-CHAR / DQUOTE *QSAFE-CHAR DQUOTE

   SAFE-CHAR = WSP / "!" / %x23-39 / %x3C-7E / NON-ASCII
     ; Any character except CTLs, DQUOTE, ";", ":"

Corrected Text
--------------
   param-value = *SAFE-CHAR / DQUOTE *QSAFE-CHAR DQUOTE

   SAFE-CHAR = WSP / "!" / %x23-2B / %x2D-39 / %x3C-7E / NON-ASCII
     ; Any character except CTLs, DQUOTE, ",", ";", ":"

Notes
-----
"5. Property Parameters" states: "Property parameter value elements that contain the COLON (U+003A), SEMICOLON (U+003B), or COMMA (U+002C) character separators MUST be specified as quoted-string text values."

So COMMA cannot be part of a non-quoted parameter value which should be reflected by the SAFE-CHAR declaration.

Otherwise a value of
X-PARAM=tel,fax
could be ambiguously interpreted as
"tel","fax" (separated values)
and "tel,fax" (combined value containing a COMMA)

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC6350 (draft-ietf-vcarddav-vcardrev-22)
--------------------------------------
Title               : vCard Format Specification
Publication Date    : August 2011
Author(s)           : S. Perreault
Category            : PROPOSED STANDARD
Source              : vCard and CardDAV
Area                : Applications
Stream              : IETF
Verifying Party     : IESG

---

From: Simon Perreault <[email-masked]>
Date: Mon, 27 Feb 2012 08:33:25 -0500

> Original Text

This is correct, but then the ABNF wouldn't allow said X-PARAM=tel,fax.

There was a recent discussion about the ABNF inadequacies for parameter 
values. Both the text and ABNF need to be fixed, and there is no quick 
fix. So I suggest to set this errata to "held for document update".

Simon
-- 
DTN made easy, lean, and smart --> http://postellation.viagenie.ca
NAT64/DNS64 open-source        --> http://ecdysis.viagenie.ca
STUN/TURN server               --> http://numb.viagenie.ca

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 27 Feb 2012 11:07:49 -0700

On 2/27/12 6:33 AM, Simon Perreault wrote:
>> "5. Property Parameters" states: "Property parameter value elements
>> that contain the COLON (U+003A), SEMICOLON (U+003B), or COMMA (U+002C)
>> character separators MUST be specified as quoted-string text values."
>>
>> So COMMA cannot be part of a non-quoted parameter value which should
>> be reflected by the SAFE-CHAR declaration.
>>
>> Otherwise a value of
>> X-PARAM=tel,fax

So processed.

Peter

-- 
Peter Saint-Andre
https://stpeter.im/