Subject: [VCARDDAV] New drafts for review

From: Ciny Joy <[email-masked]>
Date: Wed, 27 Feb 2013 15:54:09 -0800

Hello,
 As mentioned in the attached email, during discussions on the new vCard resource draft we realized the need to re-use and sometimes enhance the currently defined KIND values to define schedulable resources. This lead to the idea of replicating the concept of Objectclass that LDAP offers. After further discussions the following drafts have been submitted. Any review and comments would be greatly appreciated.

	- Base vCard objectclass property definition - http://tools.ietf.org/html/draft-vcard-objectclass-00
	- Definition of the "schedulable" objectclass value used to define any schedulable entity - http://tools.ietf.org/html/draft-vcard-schedulable-00
	- Modified vCard representation of a schedulable resource that makes use of the schedulable objectclass - http://tools.ietf.org/html/draft-cal-resource-vcard-02

Thanks,
Ciny

---

From: Simon Perreault <[email-masked]>
Date: Thu, 28 Feb 2013 10:15:48 +0100

Le 2013-02-28 00:54, Ciny Joy a écrit :,
>   As mentioned in the attached email, during discussions on the new
> vCard resource draft we realized the need to re-use and sometimes
> enhance the currently defined KIND values to define schedulable
> resources. This lead to the idea of replicating the concept of
> Objectclass that LDAP offers. After further discussions the following
> drafts have been submitted. Any review and comments would be greatly
> appreciated.
>
> - Base vCard objectclass property definition -
> http://tools.ietf.org/html/draft-vcard-objectclass-00

I only read this one, and I have a high-level question: Why is it 
important to explicitly write the object class(es) in the vCard?

An analogy: In object-oriented programming, it is considered bad form to 
verify the type of an object. It is better to just try to use the object 
as if it had all the necessary stuff, and handle failure correctly.

For vCard, I would see code doing just that. Instead of verifying if a 
vCard has class "schedulable", just try to schedule it. Then handle 
failure gracefully if it doesn't have the required properties.

What am I missing?

Simon

---

From: Ciny Joy <[email-masked]>
Date: Thu, 28 Feb 2013 14:17:56 -0800

On Feb 28, 2013, at 1:15 AM, Simon Perreault wrote:

> I only read this one, and I have a high-level question: Why is it important to explicitly write the object class(es) in the vCard?
> 
> An analogy: In object-oriented programming, it is considered bad form to verify the type of an object. It is better to just try to use the object as if it had all the necessary stuff, and handle failure correctly.
> 
> For vCard, I would see code doing just that. Instead of verifying if a vCard has class "schedulable", just try to schedule it. Then handle failure gracefully if it doesn't have the required properties.
> 
> What am I missing?
Thanks for reviewing, Simon. Mike may be able to answer your question better. We were looking at this from the point of how would one search for a resource to schedule. In that case we need something to decide whether a particular vCard should be included in the search result or not.

Ciny
> 
> Simon
> _______________________________________________
> VCARDDAV mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/vcarddav