Subject: [VCARDDAV] Fwd: New vCard Ontology draft

From: Renato Iannella <[email-masked]>
Date: Fri, 3 May 2013 09:16:07 +1000

Hi all - the vCard Ontology has been published as a W3C Working Draft - all comments appreciated!

Renato

Begin forwarded message:

> Resent-From: [email-masked]
> From: Ivan Herman <[email-masked]>
> Subject: New vCard Ontology draft
> Date: 3 May 2013 00:56:07 AEST
> To: W3C Semantic Web IG <[email-masked]>
> 
> The Semantic Web Interest Group has published a new draft for the vCard-in-RDF Ontology[1], edited by Renato Iannella and James McKinney. The new draft updates the previous version[2] by aligning it with the latest IETF vCard specification, ie, RFC6350[3].
> 
> This is a draft; comments on the draft should be sent to the SWIG mailing list. The goal is to publish an Interest Group Note once there is a consensus in the community.
> 
> Sincerely
> 
> Ivan Herman
> 
> 
> [1] http://www.w3.org/TR/2013/WD-vcard-rdf-20130502/
> [2] http://www.w3.org/Submission/2010/SUBM-vcard-rdf-20100120/
> [3] http://tools.ietf.org/html/rfc6350
> 
> ----
> Ivan Herman, W3C Semantic Web Activity Lead
> Home: http://www.w3.org/People/Ivan/
> mobile: +31-641044153
> FOAF: http://www.ivan-herman.net/foaf.rdf
>

---

From: Michael Angstadt <[email-masked]>
Date: Fri, 3 May 2013 11:46:54 -0400

Hi Renato,

In the examples, the value that is used for the TEL property is
incorrect.  You need to put a "+" before the country code:

For example:

<vcard:telephone>tel:61755555555</vcard:telephone>

should be

<vcard:telephone>tel:+61755555555</vcard:telephone>

vCard 4 also allows telephone numbers to be encoded as plain text, as
was done in previous versions.  This is the default data type, so if a
URI is used, then the property must include a VALUE parameter.  For
example:

URI value:
TEL;VALUE=uri:tel:+61755555555

Text value:
TEL:61755555555

I'm not sure what impact this has on the vCard Ontology, if any.

Thanks,
Mike

On Thu, May 2, 2013 at 7:16 PM, Renato Iannella <[email-masked]> wrote:
> The Semantic Web Interest Group has published a new draft for the
> vCard-in-RDF Ontology[1], edited by Renato Iannella and James McKinney. The
> new draft updates the previous version[2] by aligning it with the latest
> IETF vCard specification, ie, RFC6350[3].
>
> This is a draft; comments on the draft should be sent to the SWIG mailing
> list. The goal is to publish an Interest Group Note once there is a
> consensus in the community.
>
> Sincerely
>
> Ivan Herman
>
>
> _______________________________________________
> VCARDDAV mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/vcarddav
>

---

From: Renato Iannella <[email-masked]>
Date: Mon, 6 May 2013 13:32:10 +1000

> incorrect.  You need to put a "+" before the country code:

Thanks, will fix

> URI is used, then the property must include a VALUE parameter.

Ok, we need to change the datatype for telephone to union of xsd:string and xsd:anyURI so both can appear

Cheers

Renato Iannella
http://renato.iannella.it