Subject: [VCARDDAV] VALUE param

From: Renato Iannella <[email-masked]>
Date: Tue, 10 Sep 2013 21:11:16 +1000

Hi, does anyone have an real-world example of the use of the VALUE property parameter [1] ?

Cheers

Renato Iannella
http://renato.iannella.it

[1] http://tools.ietf.org/html/rfc6350#section-5.2

---

From: Renato Iannella <[email-masked]>
Date: Wed, 11 Sep 2013 14:44:08 +1000

> Hi, does anyone have an real-world example of the use of the VALUE property parameter [1] ?

To answer my own question....VALUE is actually "datatype" in meaning (not the value of the property, but the datatype of the value of the property)

I was trying to find out if there was a parameter for the actual value of a property.

For example in:    TEL;VALUE=uri;TYPE="work,voice";PREF=1:tel:+1-418-656-9254;ext=102

There is no "SOMETHING=" for the last bit after the colon.

Cheers

Renato Iannella

---

From: Cyrus Daboo <[email-masked]>
Date: Wed, 11 Sep 2013 09:46:51 -0400

Hi Renato,

--On September 11, 2013 at 2:44:08 PM +1000 Renato Iannella 
<[email-masked]> wrote:

> To answer my own question....VALUE is actually "datatype" in meaning (not
> the value of the property, but the datatype of the value of the property)
>
> For example in:
> TEL;VALUE=uri;TYPE="work,voice";PREF=1:tel:+1-418-656-9254;ext=102
>

Sorry, I don't understand what you are after. Perhaps you can give a use 
case for how the "value of a property" is used? At a rough guess, though, 
isn't what you are after really the definition of the property itself? 
i.e., TEL means that its value is a telephone number, as specified by the 
property definition.

-- 
Cyrus Daboo

---

From: Renato Iannella <[email-masked]>
Date: Thu, 12 Sep 2013 13:10:05 +1000

On 11 Sep 2013, at 23:46, Cyrus Daboo <[email-masked]> wrote:

> Sorry, I don't understand what you are after. Perhaps you can give a use case for how the "value of a property" is used? At a rough guess, though, isn't what you are after really the definition of the property itself? i.e., TEL means that its value is a telephone number, as specified by the property definition.

We are working on the best way to model property parameters in the vCard Ontology [1].

In the default syntax there is no "attribute" that says and here is the value of the property.

In the XML syntax, the value of the property gets represented in another element, like:

     <email>
         <text>[email-masked]</text>
      </email>

Cheers

Renato Iannella

[1] http://www.w3.org/TR/vcard-rdf/