Subject: [VCARDDAV] Registration request for a new GENDER value "X" to indicate nonbinary

From: "Emily Love Mills (she/her)" <[email-masked]>
Date: Thu, 06 Jan 2022 20:27:01 +0000

Hi! Please find below my registration request for a new GENDER value "X" to indicate nonbinary.

Value:  X

Purpose:  Indicates that the entity the vCard represents has a nonbinary sex designation.

Conformance:  This value can be used with the sex component of the value on the "GENDER" property.

Example(s):

GENDER:X;Nonbinary

Emily Love Mills (she/her)
[email-masked]

---

From: Simon Perreault <[email-masked]>
Date: Thu, 6 Jan 2022 20:40:35 +0000

Similar reply as for PRONOUN: new vCard elements need to be published as an RFC. This could be part of the same RFC.

Simon

> On Jan 6, 2022, at 3:27 PM, Emily Love Mills (she/her) <[email-masked]> wrote:
> 
> _______________________________________________
> VCARDDAV mailing list
> [email-masked]
> https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/vcarddav__;!!OA8L0MA-!rgmtqbvhI8WJUoho07gzEik_qsm5lROXVy1-Loi92zncG1UvpAw8TNvl3vVAoITeV3LA$

---

From: "Bron Gondwana" <[email-masked]>
Date: Fri, 07 Jan 2022 08:08:29 +1100

Hi Emily,

There's discussion about exactly this happening over in the JMAP working group for how we handle gender and pronouns in the JSContact format.

Meanwhile, we're currently planning to re-charter the CALEXT working group to bring VCARD work into scope, since there isn't currently a working group for maintaining VCARD.  The plan is to move JSContact there so there's a single place.  Aligning this update to VCARD with the JSContact work so that it's easy to translate between the two would be ideal.

You're very welcome to join the discussion on the JMAP mailing list in the meanwhile - most recently this thread:

https://mailarchive.ietf.org/arch/msg/jmap/YzXaBSO55yWfATzmeTb1bcPydtE/

We'll keep working on JSContact in the JMAP working group until the charter change for CALEXT is done.

Cheers,

Bron (a working group co-chair for both those two working groups)

On Fri, Jan 7, 2022, at 07:27, Emily Love Mills (she/her) wrote:
> https://www.ietf.org/mailman/listinfo/vcarddav
> 

--
  Bron Gondwana, CEO, Fastmail Pty Ltd
  [email-masked]

---

From: "Emily Love Mills (she/her)" <[email-masked]>
Date: Thu, 06 Jan 2022 22:05:12 +0000

Thanks for that context! Didn't know this discussion was underway!

I see how the current proposal is insufficient for the grammaticalGender purposes. An idea I'd propose is giving the PRONOUN property the same structure as the GENDER property. Each PRONOUN value could consist of a structured component along with free-form text. The first component indicating the grammatical gender of the pronouns, with the second being the free-form text entry. The proposed list in JSContact of "animate", "female", "inanimate", "male", "neuter" looks reasonable for this purpose. As Darcy suggests in that thread, these classifications are more specifically related to pronouns than gender. I'm not confident it's possible to make an exhaustive language-agnostic structure to store every pronoun variation, but the grammaticalGender proposal seems like a good compromise to balance complexity between applications reading vCards and applications writing them.

Examples:

PRONOUN:M;he/him/his
PRONOUN:N;they/them
PRONOUN:F;
PRONOUN:;xe/xir

‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐