Subject: [VCARDDAV] [Editorial Errata Reported] RFC6350 (6812)

From: RFC Errata System <[email-masked]>
Date: Thu, 6 Jan 2022 12:27:46 -0800 (PST)

The following errata report has been submitted for RFC6350,
"vCard Format Specification".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6812

--------------------------------------
Type: Editorial
Reported by: Emily Love Mills (she/her) <[email-masked]>

Section: 6.2.7

Original Text
-------------
   Examples:

     GENDER:M
     GENDER:F
     GENDER:M;Fellow
     GENDER:F;grrrl
     GENDER:O;intersex
     GENDER:;it's complicated

Corrected Text
--------------
   Examples:

     GENDER:M
     GENDER:F
     GENDER:M;Transgender Man
     GENDER:F;Transfeminine
     GENDER:O;Intersex
     GENDER:;Agender

Notes
-----
This errata replaces the imaginary gender identities with examples of actual diverse gender identities.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC6350 (draft-ietf-vcarddav-vcardrev-22)
--------------------------------------
Title               : vCard Format Specification
Publication Date    : August 2011
Author(s)           : S. Perreault
Category            : PROPOSED STANDARD
Source              : vCard and CardDAV
Area                : Applications
Stream              : IETF
Verifying Party     : IESG

---

From: Simon Perreault <[email-masked]>
Date: Thu, 6 Jan 2022 20:51:29 +0000

I don’t think this errata is correct. Yes it can easily be argued that the provided examples are better than the ones contained in the RFC, but the ones in the RFC are actually correct per protocol. That is, there is no bug. So I believe this is something that should be part of an eventual RFC revision, not an errata.

Simon

> On Jan 6, 2022, at 3:27 PM, RFC Errata System <[email-masked]> wrote:
> 
> https://urldefense.com/v3/__https://www.rfc-editor.org/errata/eid6812__;!!OA8L0MA-!uwnqxs4ZSZC4YW4XVGznKVl9Q39EmxKJ3pity_7RydbiDbXhc45tSkIibJg7XUWHoEqs$ 
> 
> _______________________________________________
> VCARDDAV mailing list
> [email-masked]
> https://urldefense.com/v3/__https://www.ietf.org/mailman/listinfo/vcarddav__;!!OA8L0MA-!uwnqxs4ZSZC4YW4XVGznKVl9Q39EmxKJ3pity_7RydbiDbXhc45tSkIibJg7XZJbH1Sq$

---

From: "Emily Love Mills (she/her)" <[email-masked]>
Date: Thu, 06 Jan 2022 20:57:07 +0000

Agreed, this would be fine to include in the next RFC revision instead.

Emily Love Mills (she/her)
[email-masked]

‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐

On Thursday, January 6th, 2022 at 2:51 PM, Simon Perreault <Simon.Perreault=[email-masked]> wrote:

> > On Jan 6, 2022, at 3:27 PM, RFC Errata System [email-masked] wrote:
> >
> > https://urldefense.com/v3/https://www.rfc-editor.org/errata/eid6812;!!OA8L0MA-!uwnqxs4ZSZC4YW4XVGznKVl9Q39EmxKJ3pity_7RydbiDbXhc45tSkIibJg7XUWHoEqs$
> >
> > Type: Editorial
> >
> > Reported by: Emily Love Mills (she/her) [email-masked]
> >
> > Section: 6.2.7
> >
> > Original Text
> > -------------
> >
> > Examples:
> >
> >     GENDER:M
> >     GENDER:F
> >     GENDER:M;Fellow
> >     GENDER:F;grrrl
> >     GENDER:O;intersex
> >     GENDER:;it's complicated
> >
> >
> > Corrected Text
> > --------------
> >
> > Examples:
> >
> >     GENDER:M
> >     GENDER:F
> >     GENDER:M;Transgender Man
> >     GENDER:F;Transfeminine
> >     GENDER:O;Intersex
> >     GENDER:;Agender
> >
> >
> > Notes
> > -----
> >
> > -----------------------------------------
> >
> > https://urldefense.com/v3/https://www.ietf.org/mailman/listinfo/vcarddav;!!OA8L0MA-!uwnqxs4ZSZC4YW4XVGznKVl9Q39EmxKJ3pity_7RydbiDbXhc45tSkIibJg7XZJbH1Sq$
>
> VCARDDAV mailing list
>
> [email-masked]
>
> https://www.ietf.org/mailman/listinfo/vcarddav