Subject: Re: [VIPR] Draft: SIP Extensions for Blocking VoIP Spam

From: Marc Petit-Huguenin <[email-masked]>
Date: Fri, 22 Apr 2011 07:41:59 -0700

On 03/31/2011 07:22 AM, Khan, Sohel wrote:
> I have many questions on this draft.
> 
>  
> 
> First, in section 3.0 second paragraph:
> 
> “…This INVITE will contain a ticket in the X-Cisco-ViPR-Ticket header field value.”
> 
>  
> 
>  Should a proprietary header such as  “X-Cisco-ViPR-Ticket” be used?
> 

You are right, a new SIP header should be registered.

I searched if there was not an existing header with similar semantics that could
be reused, but I could not find one (but as I did not follow SIP for
the last few years, I could have missed it).

Because this header and its semantic could be reused by other distribution
mechanisms than VIPR, I propose to rename the SIP header as "Ticket".

I am also thinking that a Require option tag should also be defined so a SIP
INVITE with a Ticket header is not processed if the UAS does not understand the
Ticket header (in case the SIP request is misrouted).

- -- 
Marc Petit-Huguenin
Personal email: [email-masked]
Professional email: [email-masked]
Blog: http://blog.marc.petit-huguenin.org

---

From: Cullen Jennings <[email-masked]>
Date: Mon, 25 Apr 2011 22:10:32 -0600

I don't see why a require header would be needed. A UA that does not understand an unknown header will just ignore it. Seems like that would be fine. 

(oh, and agree with you and Sohel that the existing name needs to change. Insert rant about P- headers here. ).

On Apr 22, 2011, at 8:41 AM, Marc Petit-Huguenin wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.11 (GNU/Linux)
> 
> iEYEARECAAYFAk2xk7UACgkQ9RoMZyVa61eNsgCfSrdM/ywMYhRCbaFs5iCIpa3+
> vNIAoIHForDYdbMaWDyz1+GMa16zDfV4
> =sU1O
> -----END PGP SIGNATURE-----
> _______________________________________________
> VIPR mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/vipr

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Mon, 25 Apr 2011 22:30:33 -0700

>  I don't see why a require header would be needed. A UA that does not understand an unknown header will just ignore it. Seems like that would be fine. 

Well, it won't work anyway as a Require cannot be removed by a proxy.

>>>> &This INVITE will contain a ticket in the X-Cisco-ViPR-Ticket header field value.
>>>>
>>>>
>>>>
>>>> Should a proprietary header such as  X-Cisco-ViPR-Ticket be used?
>>>>
> 

- -- 
Marc Petit-Huguenin