Subject: Re: [vnfpool] Overlap with SFC?

From: Linda Dunbar <[email-masked]>
Date: Fri, 14 Feb 2014 23:37:34 +0000

Chidung,

Thanks for the examples. More questions are inserted below:

From: LAC Chidung [mailto:[email-masked]]
Sent: Tuesday, January 28, 2014 8:33 AM
To: Linda Dunbar
Cc: [email-masked]; [email-masked]
Subject: Re: [vnfpool] Overlap with SFC?

Well, one can imagine plenty of situations:
* In a residential/home gateway, there is a dedicated VP-VC for VoIP. If this channel is down, the VoIP service will use instead the Internet VP-VC: in this case, if the user is alone at home, it could be ok, but if someone else (at home) is uploading/downloading huge files, the quality of the conversation is badly degraded.
[Linda] is "VP-VC" a service function on a chain? It is more like two components: primary VP-VC and standby Internet VP-VC. There are many available tools to tackle this primary/standby switches. Do you consider this part of  the service chain or VNFpool domain?

* Case of a residential/home gateway which provides 2 wifi interfaces (e.g., 2.4 GHz and 5 GHz): if the 5 GHz interface is down, one can still use the 2.4 GHz interface for wifi connection, but it is slower.
* A smartphone connected to a service provider (SP) network is identified automatically, allowing the user to access to the SP (and its partners) services without additional identification. If the authentication module is down, the user wil need to provide the login/pwd (for instance) any time he/she wants to access to such services.

* Etc.
Best,
Chidung
Le 25/01/2014 00:05, Linda Dunbar a écrit :
Chidung,
Do you have an example of "A service chain needs X+Y service nodes while X is mandatory and Y being optional"?
Thanks,
Linda

From: vnfpool [mailto:[email-masked]] On Behalf Of LAC Chidung
Sent: Wednesday, January 22, 2014 5:26 AM
To: Qin Wu
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [vnfpool] Overlap with SFC?

Hi Qin,
"in service chain, when a service node is down, what SFC is doing is to bypass this service node": is the following interpretation ok ?
A service chain needs X+Y service nodes in order to provide the full service: the X service nodes are mandatory, while the Y service nodes are (kind of) optional, i.e., if one (or more) of these Y service nodes is (are) down, the service chain can still provide the service, but in a degraded mode. In this case, the bypassing can only happen for one of the Y service nodes, i.e., if one of the X service nodes is down, there is no service at all.
NB: in this example, we consider, of course, that there is no redundancy anywhere, i.e., if a service node is down, the only thing to do is to fix it, and while waiting for the reparation, we face a degraded service, or no service at all.
Best,
Chidung

Le 22/01/2014 06:05, Qin Wu a écrit :

My Understanding is

in service chain, when a service node is down, what SFC is doing is to bypass this service node while

What nfvpool is doing is to replace the failing one with the new service node which provide the same functionality.

Please correct me if I am wrong.

Regards!

-Qin

-----Original Message-----

From: vnfpool [mailto:[email-masked]] On Behalf Of Zongning

Sent: Wednesday, January 22, 2014 9:42 AM

To: Zongning; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>

Subject: Re: [vnfpool] Overlap with SFC?

Sorry, item 1) is obviously not finished. :-)

1) SFC targets on steering packets among service function nodes. vnfpool focuses on redundancy for service nodes, e.g., selecting standby nodes, handling nodes transition/failure cases, without caring about how to construct the data path.

Again, my fault.

-Ning

-----Original Message-----

From: Zongning

Sent: Wednesday, January 22, 2014 9:34 AM

To: [email-masked]<mailto:[email-masked]>'; [email-masked]<mailto:[email-masked]>

Subject: RE: [vnfpool] Overlap with SFC?

Hi, Adrian,

Thanks for raising this question. Actually vnfpool folks have been discussing this

question a lot since the very beginning of this work.

We believe vnfpool and SFC are independent and complementary mainly due to

the below reasons:

1) SFC targets on steering packets among service function nodes. vnfpool

focuses on redundancy for service nodes, e.g., selecting standby nodes,

handling nodes transition/failure cases, without caring how

2) vnfpool manager in our proposal could interact with SFC control entity to: 1)

advertise redundant service nodes; 2) notify status of redundant nodes when

required; 3) receive resiliency requirements from SFC control entity (if any); and

so on.

3) vnfpool is not only used in "chained service nodes", but applicable to other

cases where service nodes are not necessarily sequentially connected.

I appreciate any further feedback and advice from you or IESG, as I believe

these feedback will greatly improve the quality of our proposed charter.

Thanks.

-Ning

-----Original Message-----

From: vnfpool [mailto:[email-masked]] On Behalf Of Adrian Farrel

Sent: Wednesday, January 22, 2014 1:57 AM

To: [email-masked]<mailto:[email-masked]>

Subject: [vnfpool] Overlap with SFC?

Hi,

The IESG is looking at the BoF requests for London, and a question came upon the overlap between the proposal here and items 4 and 5 in the SFC Charter.

I think it would be valuable if you could discuss the overlap and the

interaction between the two efforts so that there is a clear view.

Thanks,

Adrian

_______________________________________________

vnfpool mailing list

[email-masked]<mailto:[email-masked]>

https://www.ietf.org/mailman/listinfo/vnfpool

---

From: LAC Chidung <[email-masked]>
Date: Mon, 17 Feb 2014 11:36:44 +0100

Hi Linda,
Sorry for not being more precise: VP-VC refer to Virtual Path and 
Virtual Channel in ATM. In normal operations, a dedicated VP-VC is 
allocated to VoIP (QoS guaranteed), while another (Internet) VP-VC is 
used for other feaures (e-mail, ..), based on the best effort mode.
If the service is defined as the one delivered by the home gateway, both 
VP-VCs are necessary (chain) for features such as: VoIP, browsing, 
e-mail, ... In this case, the 1st VP-VC is "optional" [I am referring to 
your original question of Jan 25th], while the 2nd one is "mandatory" 
because if the 1st one fails, VoIP is still ok, although its QoS is not 
guaranteed anymore (degraded mode).
Of course, if VoIP is defined as the service, it changes a little bit 
because one can consider in this case the 1st VP-VC as the primary path, 
and the 2nd one as the standby path ...
Best,
Chidung

Le 15/02/2014 00:37, Linda Dunbar a écrit :
> *From:*LAC Chidung [mailto:[email-masked]]
> *Sent:* Tuesday, January 28, 2014 8:33 AM
> *To:* Linda Dunbar
> *Cc:* [email-masked]; [email-masked]
> *Subject:* Re: [vnfpool] Overlap with SFC?
>
> * In a residential/home gateway, there is a dedicated VP-VC for VoIP. 
> If this channel is down, the VoIP service will use instead the 
> Internet VP-VC: in this case, if the user is alone at home, it could 
> be ok, but if someone else (at home) is uploading/downloading huge 
> files, the quality of the conversation is badly degraded.
>
> [Linda] is "VP-VC" a service function on a chain? It is more like two 
> components: primary VP-VC and standby Internet VP-VC. There are many 
> available tools to tackle this primary/standby switches. Do you 
> consider this part of  the service chain or VNFpool domain?
>
> * Case of a residential/home gateway which provides 2 wifi interfaces 
> (e.g., 2.4 GHz and 5 GHz): if the 5 GHz interface is down, one can 
> still use the 2.4 GHz interface for wifi connection, but it is slower.
>
> * A smartphone connected to a service provider (SP) network is 
> identified automatically, allowing the user to access to the SP (and 
> its partners) services without additional identification. If the 
> authentication module is down, the user wil need to provide the 
> login/pwd (for instance) any time he/she wants to access to such services.
> * Etc.
> Best,
> Chidung
>
>     Do you have an example of "A service chain needs X+Y service nodes
>     while X is mandatory and Y being optional"?
>
>     Thanks,
>
>     Linda
>
>     *From:*vnfpool [mailto:[email-masked]] *On Behalf Of
>     *LAC Chidung
>     *Sent:* Wednesday, January 22, 2014 5:26 AM
>     *To:* Qin Wu
>     *Cc:* [email-masked] <mailto:[email-masked]>;
>     [email-masked] <mailto:[email-masked]>
>     *Subject:* Re: [vnfpool] Overlap with SFC?
>
>     Hi Qin,
>     "/in service chain, when a service node is down, what SFC is doing
>     is to bypass this service node/": is the following interpretation ok ?
>     A service chain needs X+Y service nodes in order to provide the
>     *_full_* service: the X service nodes are mandatory, while the Y
>     service nodes are (kind of) optional, i.e., if one (or more) of
>     these Y service nodes is (are) down, the service chain can still
>     provide the service, but in a *_degraded mode_*. In this case,*the
>     bypassing can only happen* for one of the Y service nodes, i.e.,
>     if one of the X service nodes is down, there is *_no service at all_*.
>     _NB:_ in this example, we consider, of course, that there is no
>     redundancy anywhere, i.e., if a service node is down, the only
>     thing to do is to fix it, and while waiting for the reparation, we
>     face a degraded service, or no service at all.
>     Best,
>     Chidung
>
>         To: Zongning;[email-masked]  <mailto:[email-masked]>;[email-masked]  <mailto:[email-masked]>
>
>             To: [email-masked]  <mailto:[email-masked]>';[email-masked]  <mailto:[email-masked]>
>
>                 To:[email-masked]  <mailto:[email-masked]>
>