Subject: Re: [vnrg] FW: I-D Action:draft-shin-virtualization-meta-arch-01.txt

From: "Sangjin Jeong" <[email-masked]>
Date: Mon, 3 May 2010 14:35:13 +0900

Dear Pedro,
 
Thanks for your comments. 
See inline, please.
 
Regards,
Sangjin

> -----Original Message----- 
> From: "Pedro Andr?s Aranda Guti?rrez" <[email-masked]> 
> From Date: 2010-04-30 PM 2:27:16 
> To: "Sangjin Jeong" <[email-masked]>, "[email-masked]" <[email-masked]> 
> Cc: 
> Subject: Re: [vnrg] FW: I-D Action:draft-shin-virtualization-meta-arch-01.txt 
> 
> 

> Dear all, 
> 
> I'd first of alllike to thank all the writers of the draft. We now have 
> a document to work upon! 
> 
> My main comment is that the document is written as if current VPN 
> technologies didn't exist and, IMvHO, this was confusing to me. 
> This is very much so (I fear) in the last paragraph before [3]. 

Network virtualization has three typical characteristics, isolation, 
partitioning, and aggregation. Although the current virtual network 
technologies, for example VPNs support partitioning and isolation 
capabilities, the supported capabilities are not complete and 
may need more improvement. Similarly, there are other 
technologies that support some of network virtualization 
characteristics, but these technologies are not complete from 
the view point of network virtualization definition. The section 2 
describes the possible problems of network architecture.

> Another point is that there is a whole research topic which is 
> not touched upon: domains and interdomain problems. The document 
> very much follows the tradition of assuming planet-wide 'magic' 
> availability of virtualisation. But this will not be like this. 
> We will find providers making this happen and if we have to plan 
> for several of them interacting in some cooperative/competitive 
> environment. Rationalisation will finally show that sharing footprints 
> is better in some situations that complete green-field deployment. 
> This can only happen with a sound interdomain interface. 

I agree with you that considering intra-domain or inter-domain 
interaction is important problems to be investigated. However, federation 
seems not within the initial scope of RG, so we did not touch federation 
issues in the current document. If there is a consensus for investigating 
federation issues in this document, we will try to do it. 
However, IMHO, federation is a quite large research area and may need 
a separate document to work on.

> 
> I'd kindly ask to add this consideration to the I-D. 
> 
> Kind regards, /PA 
> 
> PS: I'm attaching a diff file with some language corrections, as well as 
> some marks of points I think need more discussion to find a more 
> accurate wording. 

We will reflect the diff file in the next version. I appreciate it. 

> 
> Sangjin Jeong escribi?: 
> > Hello folks, 
> >  
> > During the Anaheim meeting, it was agreed that "Network Virtualization Problem Statement" document was a good starting point, but more work needs to be done in order to cover various aspects. So, as a follow-up of the meeting. we would like to start discussion about the document. Please find the document in the link below. 
> >  
> > This document investigates problem spaces and requirements for supporting network virtualization. We have received several comments offline, but we are soliciting more comments. 
> >  
> > Any comments are appreciated. 
> >  
> > Regards, 
> > Sangjin 
> > 
> -----Original Message----- 
> From: "[email-masked]" <[email-masked]> 
> From Date: 2010-03-04 PM 11:45:01 
> To: "[email-masked]" <[email-masked]> 
> Cc: 
> Subject: I-D Action:draft-shin-virtualization-meta-arch-01.txt 
> 
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories. 
> 
>        Title           : Network Virtualization Problem Statement 
>        Author(s)       : S. Jeong, et al. 
>        Filename        : draft-shin-virtualization-meta-arch-01.txt 
>        Pages           : 9 
>        Date            : 2010-03-04 
> 
> This document analyzes and discusses the problem space of supporting 
> network virtualization in the networks.  Furthermore, some key 
> requirements for enabling network virtualization in the networks are 
> investigated and described. 
> 
> A URL for this Internet-Draft is: 
> http://www.ietf.org/internet-drafts/draft-shin-virtualization-meta-arch-01.txt 
> 
> Internet-Drafts are also available by anonymous FTP at: 
> ftp://ftp.ietf.org/internet-drafts/ 
> 
> Below is the data which will enable a MIME compliant mail reader 
> implementation to automatically retrieve the ASCII version of the 
> Internet-Draft. 
> 
> 
> 

-- 
Pedro A. Aranda Guti?rrez       Telef?nica I+D 
Technology Specialist           New Network Technologies 
mailto: [email-masked]             C/Emilio Vargas,6 
Tlf: +34-913 374 702            E-28043 Madrid 

"Fragen sind nicht da, um beantwortet zu werden. 
 Fragen sind da, um gestellt zu werden" Georg Kreisler 
http://www.mendeley.com/profiles/pedro-a-aranda-gutierrez

---

From: "Sangjin Jeong" <[email-masked]>
Date: Mon, 3 May 2010 16:38:01 +0900

Dear Paddy,
 
Thanks for comments.
Please see inline.
 
Regards,
Sangjin

> From: "PaddyNallur" <[email-masked]> 
> From Date: 2010-05-01 AM 3:43:43 
> To: "Sangjin Jeong" <[email-masked]> 
> Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]> 

> Hi, 
> 
> I have the following comments on the document: 
> 
> 
> Section 1, Introduction: 
> 
> In this section, the 'server virtualization' benefits are mentioned. Why not also mention the "storage virtualization" benefits ? May be we can bring some of the benefits like "data migration" into the network virtualization also e.g. "network migration" ?  Just a thought. 
> 

Storage virtualization is focusing on the provision of a logical, abstracted 
view of physical storage devices without being concerned with where 
(physically located) or how (managed). So, storage virtualization may not 
be directly related to network virtualization, but as you pointed out, some 
of the benefits of storage virtualization may also be applied to network 
virtualization. Migration features are touched in the second bullet as 
a relocation of servers.

> 
> 
> Section 3, first bullet item: 
> 
> The description starting from "Furthermore, a network application may ..." is a new capability that network virtualization would bring. My suggestion is to make this a separate bullet item. 
> 

Ok. I will add a new bullet.

> 
> 
> Section 4, applicability and use cases: 
> 
> In the complex physical networking infrastructure today (e.g., at the core of the network), it is very difficult to add or reserve exclusive physical resources within the physical network for certain application(s) or users. 
> With network virtualization, we should be able to add or reserve physical resources for a single or group of virtual networks, anywhere in the physical network (e.g., at bottleneck points). With this capability, the infrastructure providers can add/reserve (purchase) resources exclusively for certain customers anywhere in the physical network.  This use case is somewhat opposite of "aggregation" and would be worth mentioning in my opinion. 
> 

I think that the text above is better fitted for requirement. 
So, I will add it to the requirement section.

> 
> Thanks 
> Paddy Nallur 
> 
> 
> 
> ----- Original Message ----- 
> From: Sangjin Jeong <[email-masked]> 
> Date: Thursday, April 29, 2010 6:26 pm 
> Subject: [vnrg] FW: I-D Action:draft-shin-virtualization-meta-arch-01.txt 
> To: [email-masked] 
> 
> 
> > Hello folks, 
> >  
> > During the Anaheim meeting, it was agreed that "Network Virtualization 
> > Problem Statement" document was a good starting point, but more work 
> > needs to be done in order to cover various aspects. So, as a follow-up 
> > of the meeting. we would like to start discussion about the document. 
> > Please find the document in the link below. 
> >  
> > This document investigates problem spaces and requirements for 
> > supporting network virtualization. We have received several comments 
> > offline, but we are soliciting more comments. 
> >  
> > > _______________________________________________ 
> > > vnrg mailing list 
> > > [email-masked] 
> > > https://www.irtf.org/mailman/listinfo/vnrg