Subject: Re: [VoT] vot Digest, Vol 5, Issue 16

From: Peter Alterman <[email-masked]>
Date: Mon, 19 Jan 2015 15:19:29 -0500

​Well, friends, we seem to be at it again: the infamous Rat Hole of
identity vs. attribute.

I, for one, am getting tired of the same old rodomontade.

Right now and for the forseeable future there are attributes that by
general agreement are part of establishing identity and there are other
(extended) attributes that are part of establishing rights or privileges.
Note I said "by general agreement" but I seem to remember ANSI addressing
this issue a couple of years ago and ISO doing so currently.

None of the discussion I'm seeing on this thread suggests any useful reason
to dive back into the Rat Hole as it does nothing to address the core
algorithm, which is trust = 1/risk.

Peter

------------------------------------------------------------
Peter Alterman, Ph.D.
Chief Operating Officer
SAFE-BioPharma Association
cell: 301-943-7452

On Mon, Jan 19, 2015 at 3:03 PM, <[email-masked]> wrote:

> Send vot mailing list submissions to
>         [email-masked]
>
> To subscribe or unsubscribe via the World Wide Web, visit
>         https://www.ietf.org/mailman/listinfo/vot
> or, via email, send a message with subject or body 'help' to
>         [email-masked]
>
> You can reach the person managing the list at
>         [email-masked]
>
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of vot digest..."
>
> Today's Topics:
>
>    1. Re: A modest proposal to replace LOA (Cantor, Scott)
>
>
> ---------- Forwarded message ----------
> From: "Cantor, Scott" <[email-masked]>
> To: "Jones, Mark B" <[email-masked]>, Eric Goodman <
> [email-masked]>, "[email-masked]" <[email-masked]>
> Cc:
> Date: Mon, 19 Jan 2015 19:59:57 +0000
> Subject: Re: [VoT] A modest proposal to replace LOA
> > Communicating an identity (attributes) is not the goal of 800-63.  I
> think
> > it makes perfect sense to consider authentication and the communication
> of
> > attributes very separately.
>
> Then please explain how to communicate the identity of an authenticated
> subject to somebody else without an attribute (of some kind) to identify
> them.  That's why they're not separate. The point of the authentication is
> to communicate an attribute (or more than one) with some assurance behind
> it. Same as any other attribute use case. They boil down to the same end
> goal.
>
> > We just disagree here.  I concede that attributes are essential for
> > personalization and authorization decisions at the RP
>
> Those are secondary. The primary use case of attributes is to *identify*
> the authenticated subject in the first place.
>
> > But if an RP requests attributes that are to be used to make
> > authorization decisions, the RP should only request such attributes from
> > providers it trusts and considers to be authoritative.
>
> And why does that same logic not hold for the attributes that communicate
> the identity?
>
> >  It does not make any
> > sense for an attribute provider to offer the same attribute at varying
> > levels of assurance.
>
> Sure it does. If not, it makes no more sense for an identity provider to
> offer authentication at different levels.
>
> > The way I read this is that your definition of LOA is different than
> mine.
> > You seem to focus only on the communication of attributes (which is in
> line
> > with your stated view that "authentication means nothing to an app")
> where
> > I focus only on authentication.
>
> If you can tell me how the latter can be communicated without the former,
> I'll concede the point. If not, my argument is that one boils down to the
> other, so I don't see the point of treating it separately. What I'm arguing
> is that the "assurance" one has in identifiers and other
> "authentication-related" attributes is just a special case of assurance in
> any other attributes. Any given attribute has a set of risks associated
> with its promulgation and use. That's all I'm trying to say.
>
> >  But if you are concerned about risk
> > mitigation then I think that is an excellent place to start finding
> common
> > ground.  My question to you is, in what way does the communication of any
> > attribute address any of the threats itemized in 800-63?
>
> 800-63 is dealing with the threats to the accurate determination and
> communication of a specific set of unnamed attributes. That vagueness is
> why I have a problem with it.
>
> -- Scott
>
>
>
> _______________________________________________
> vot mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/vot
>
>

---

From: Ken Dagg <[email-masked]>
Date: Mon, 19 Jan 2015 18:09:17 -0500

Here here Peter - I agree wholeheartedly!!! KeN

On Monday, January 19, 2015, Peter Alterman <[email-masked]>
wrote:

> None of the discussion I'm seeing on this thread suggests any useful
> reason to dive back into the Rat Hole as it does nothing to address the
> core algorithm, which is trust = 1/risk.
>
> Peter
>
>
> On Mon, Jan 19, 2015 at 3:03 PM, <[email-masked]
> <javascript:_e(%7B%7D,'cvml',[email-masked]');>> wrote:
>
>>         [email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');>
>>
>> <javascript:_e(%7B%7D,'cvml',[email-masked]');>
>>
>> <javascript:_e(%7B%7D,'cvml',[email-masked]');>
>>
>> From: "Cantor, Scott" <[email-masked]
>> <javascript:_e(%7B%7D,'cvml',[email-masked]');>>
>> To: "Jones, Mark B" <[email-masked]
>> <javascript:_e(%7B%7D,'cvml',[email-masked]');>>, Eric
>> Goodman <[email-masked]
>> <javascript:_e(%7B%7D,'cvml',[email-masked]');>>, "[email-masked]
>> <javascript:_e(%7B%7D,'cvml',[email-masked]');>" <[email-masked]
>> <javascript:_e(%7B%7D,'cvml',[email-masked]');>>
>> Cc:
>> [email-masked] <javascript:_e(%7B%7D,'cvml',[email-masked]');>