Subject: RE: Multicast Address

From: "Rakers, Jason" <[email-masked]>
Date: Mon, 26 Feb 2001 12:43:47 -0500

A multicast address is essentially a broadcast address.  Routers by default
do not forward broadcasts (including multicasts).  In order for a broadcast
packet to traverse past your routers, you would need to enable broadcast
forwarding.
 
Hope this helps,
Jason

-----Original Message-----
From: Rajnish Madan [mailto:[email-masked]]
Sent: Saturday, February 24, 2001 1:05 AM
To: [email-masked]
Subject: Multicast Address

HI,
 
Section 5.2.2 of rfc 2338 says
"Routers must not forward a datagram with this destination address
(224.0.0.18) regardless
of its TTL"
 
Is the packets its talking about is the advertisement packets/or any packets
destined like ping 224.0.0.18.
 
In my implementation, if I ping to 224.0.0.18, then all the virtual routers
listening on the Multicast Address
replies. Is it all right.
 
How can i ensure that the router is not forwarding the packets ment for
224.0.0.18
 
Thanks in advance
Rajnish

---

From: "Danny J. Mitzel" <[email-masked]>
Date: Mon, 26 Feb 2001 13:08:11 -0800

>> A multicast address is essentially a broadcast address.  

no, multicast is multicast not broadcast.  broadcast is 1-to-all
while multicast is 1-to-many where the 'many' explicitly declare
their interest in receiving the packets.

>> Routers by default do not forward broadcasts (including multicasts).  
>> In order for a broadcast packet to traverse past your routers, you 
>> would need to enable broadcast forwarding.

forwarding/routing of broadcast and multicast are entirely different
concepts.  and the reason vrrp multicast packets are never forwarded,
independent of ttl or whether multicast routing is enabled, is that
the address is link-local scoped (224.0.0/24).