Subject: [VRRP] VRRP with NAT

From: "Rajendra Prasad" <[email-masked]>
Date: 18 Sep 2002 05:24:18 -0000

Hi,

   I am working with the following topology -

                     if1  ----  if2
                   ------| R1 |---------
                  |       ----          |
     ----         |                     |     ----
    | H1 |--------|                     |----| H2 |
     ----         |                     |     ----
                  |   if1 ----  if2     |
                   ------| R2 |---------
                          ----

R1 and R2 are the routers.

H1 is a host in private network
H2 is a host in public network

if1 and if2 are the interface numbers.

R1 and R2 are connected through both the interfaces.

VRRP is enabled on if1 of both the routers
Assume that R1 is master now.

And NAT is enabled on if2 of both the routers.

Assume that R1 is the MASTER. Hence, sessions from  H1 to H2 flow 
through R1.

Now, when R1 goes down, R2 becomes master and tries to continue
the sessions from H1 to H2.

Since R2 doesnot have the NAT session information, the sessions
are not restored.

How can this problem be solved?

Any suggestions/comments on such a configuration and topology.

Thanks.
B Rajendra Prasad

__________________________________________________________
Give your Company an email address like
ravi @ ravi-exports.com.  Sign up for Rediffmail Pro today!
Know more. http://www.rediffmailpro.com/signup/

_______________________________________________
vrrp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/vrrp

---

From: danny mitzel <[email-masked]>
Date: Wed, 18 Sep 2002 00:31:13 -0700 (PDT)

IMO vrrp could be used as an underlying election 
mechanism for creating and deploying simple hot 
standby type applications.  however more 
sophisticated load balancing and/or synchronization
of application state is well outside the charter and
extensibility of current protocol.

there have been some commercial products produced
that do various models of service clustering, load 
balancing, nat, firewall, ipsec state synchronization,

etc.  but I really haven't followed activities of any 
free / open source toolkits for these type
applications.
you might try searching various linux and bsd
camps for projects related to server and application
clustering.  there maybe be some useful bits 
out there.

sorry no real solution here.  good luck!  danny

>    I am working with the following topology -

__________________________________________________
Do you Yahoo!?
Yahoo! News - Today's headlines
http://news.yahoo.com
_______________________________________________
vrrp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/vrrp