Subject: [VRRP] VRRP RFC

From: "Lior Ronen" <[email-masked]>
Date: Mon, 4 Nov 2002 16:24:01 +0200

Hello,
 
Please help me understand the following issue:
 
In the VRRP RFC there is the following algorithm for backup state: 

    - If an ADVERTISEMENT is received, then: <?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

         If the Priority in the ADVERTISEMENT is Zero, then: 

          o Set the Master_Down_Timer to Skew_Time 

         else: 

            If Preempt_Mode is False, or If the Priority in the

            ADVERTISEMENT is greater than or equal to the local

            Priority, then: 

             o Reset the Master_Down_Timer to Master_Down_Interval 

            else: 

             o Discard the ADVERTISEMENT 

            endif

         endif

      endif

In the last if statement, in case Preempt_Mode is TRUE 
and the Priority in the ADVERTISEMENT is smaller than 
the local Priority, then:  
Why do we Discard the ADVERTISEMENT ?
Why not transition to MASTER and preempt the lower priority Master?
 
Thank you for your time,
Lior
______________________________________
Lior Ronen
RADLAN Computer Communications Ltd.
ATIDIM TECHNOLOGICAL PARK, 
BLDG #4, 
TEL-AVIV , ISRAEL.
TEL:  972-3-7658964
FAX: 972-3-6458544
EMAIL:  [email-masked]

---

From: Vikram Pendharkar <[email-masked]>
Date: Mon, 4 Nov 2002 06:35:38 -0800 (PST)

Lior,
If the advertisement is discarded the master down timer will not be reset. Thus eventually a master down event will be triggered and the backup will transition to master state. This is true whether or not pre-empt mode is set to true. 
Vikram 

----
NO sense being pessimistic. It wouldnt work anyway

---------------------------------
Do you Yahoo!?
HotJobs - Search new jobs daily now