Subject: Re: [VRRP] very minor tweak suggested to draft-ietf-vrrp-spec-v2-06.txt

From: "ashish thakur" <[email-masked]>
Date: 16 Jan 2003 04:36:06 -0000

Jeff , as per rfc we are not dropping a non ip address owner 
generated packet if the IP address(es) associated with the VRID 
are not valid.Only we SHOULD log the event and MAY indicate via 
network management about the misconfiguration.Also we should 
further continue processing of the packet.Only in the case of 
address owner we MUST drop the packet.
As far as what u have suggested , we should also drop the non ip 
address owner generated packets.
cheer,
ashish thakur

On Thu, 16 Jan 2003 Jeffrey Haas wrote :
>As I am reading through this specification as a new reader, the
>following stands out:
>
>: 7.1  Receiving VRRP Packets
>: [...]
>:       - MAY verify that "Count IP Addrs" and the list of IP 
>Address
>:         matches the IP_Addresses configured for the VRID
>:
>:    If the above check fails, the receiver SHOULD log the event 
>and MAY
>:    indicate via network management that a misconfiguration was 
>detected.
>:    If the packet was not generated by the address owner 
>(Priority does
>:    not equal 255 (decimal)), the receiver MUST drop the 
>packet,
>:    otherwise continue processing.
>
>I believe that the bottom sentence is mandatory.
>Since it is in the same paragraph, one might consider the "MAY" 
>and
>the "If the above check fails" to apply and thus you only MUST
>drop the packet if you are verifying the count and the list.
>
>I would suggest rewording the second sentence as a new 
>paragraph:
>
>If the packet was not generated by the address owner (Priority 
>does
>not equal 255 (decimal)), and either the "Count IP Addrs" or
>the list of IP Addresses fails to match the IP_Addresses 
>configured
>for the VRID, then the receive MUST drop the packet.
>
>
>--
>Jeff Haas
>NextHop Technologies
>_______________________________________________
>vrrp mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/vrrp

_______________________________________________
vrrp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/vrrp

---

From: Jeffrey Haas <[email-masked]>
Date: Thu, 16 Jan 2003 12:53:37 -0500

Ashish,

> address owner we MUST drop the packet.

This is opposite the way I read the spec.

As I read the spec (cited below), we MUST drop the packet
if the priority is not 255.  If it *does* equal 255, we may
continue processing.