Subject: Re: [VRRP] Routing table in VRRP

From: Radia Perlman <[email-masked]>
Date: Thu, 25 Sep 2003 13:41:31 -0700 (PDT)

Hmm. If I understand your question, I think the gist of it is...suppose
that router A is attached to a link with IP prefix 27*, and then its
link to 27* dies without A knowing about it. What happens? And the
answer I believe is, that if A does not know it can no longer reach
the LAN with that prefix, A will continue advertising that prefix,
and packets routed through A will die.

I don't think VRRP changes the situation.

Radia

	From: Mudhafar Hassan-Ali <[email-masked]>

	Hi,
	
	I have questions to the VRRP community that I would appreciate if some
	can help me with:
	In a VRRP group, how are the routing tables of these routers effected by
	VRRP?
	Obviously, these router are all share the same subnet that are connected
	to. Does not that sound like the network will see multiple routes
	through these routers to the same subnet?
	
	So imagine we have two routers A and B constituting a VRRP group
	connected to subnet X (see illusteration below). Both A and B are
	connected on the other side to the backbone network.
	
	Let's say A was the active side, and suddenly the link between router A
	and subnet X gets disconnected. The situation looks like this: A does
	not know is has lost connectivity to subnet X, B will time out due to
	the lack od the advertisement message from A, assuming that the link
	between B and subnet X is good. B will assume the responsibility for the
	VRRP group. But, how does the backbone know that it should start dealing
	(forwarding) packets to B instead? Is there any way that B will
	advertise to the backbone network that his route to subnet X is better
	so that its route becomes the next hop route form the backbone
	perspective?
	
	Thanks,
	Mudhafar
	
	--------------------------------
	|                                               |
	|        IP backbone                   |
	|                                               |
	--------------------------------
	        ^                    ^
	        |                      |
	        |                      |
	        v                    v
	    --------        --------
	    |    A    |        |    B    |
	    --------        --------
	        ^                    ^
	        |                      |
	        X(failure)         |
	        |                      |
	        v                    v
	----------------------------(subnet X)

	_______________________________________________
	vrrp mailing list
	[email-masked]
	https://www1.ietf.org/mailman/listinfo/vrrp

_______________________________________________
vrrp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/vrrp

---

From: Mudhafar Hassan-Ali <[email-masked]>
Date: Thu, 25 Sep 2003 14:03:45 -0700

Radia,

Thanks for the quick response!
The sentence in your reply "A will continue advertising that prefix, and packets
routed through A will die.", is there any way then to fix it? Some thing like B will
advertise the prefix with a better cost than the one advertised by A.

Regards,
Mudhafar