Subject: RE: [VRRP] MIB work

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Wed, 3 Sep 2003 12:22:56 +0200

Kalyan  

MMM... you seem to keep calling me Bret, while it is Bert.
I am not offended, just noticed.

Inline

Thanks,
Bert 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: woensdag 3 september 2003 4:01
> To: [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: RE: [VRRP] MIB work
> 
> 
> Hi Bret, 
> 	Thanks for the pointer. Browsing through the ID, it looks like they 
> 	are proposing two different MIBs too. I contacted the authors about
> 	their input on the pending one MIB vs two MIBs issue. 
> 	
I do not thing that they are proposing two MIB modules.
They say:
  -   Thus, changes will be required for this MIB to interoperate in an
      IPv6 environment.
  -   The problems have not been addressed and a new MIB should 
      be defined.

Maybe you conclude from that second bullet that they propose a 2nd MIB.
But I do not think that is the intention. A "new mib module" could
either be:
  - a complete replacement that includes both IPv4 and IPv6 support
  - a complete replacement that adds IPv6 support to current module
  - indeed a 2nd MIB module for IPv6 only.

It is up to the WG (with MIB dcotor help maybe) to decide what the
best path forward would be.

Bert
> Thanks
> kalyan
> 
> -----Original Message-----
> From: ext Wijnen, Bert (Bert) [mailto:[email-masked]]
> Sent: 01 September, 2003 06:53
> To: [email-masked]
> Cc: [email-masked]
> Subject: [VRRP] MIB work
> 
> 
> Pls take a look (and comment if needed) on
>   draft-ietf-v6ops-ipv4survey-ops-02.txt
> 
> A few snippets
> 
>   ... snip ..
> 
>   5.099 RFC 2787 Definitions of Managed Objects for the Virtual
>         Router Redundancy Protocol
> 
>     As stated in the Overview section:
> 
>     Since the VRRP protocol is intended for use with IPv4 
> routers only,
>     this MIB uses the SYNTAX for IP addresses which is 
> specific to IPv4.
>     Thus, changes will be required for this MIB to interoperate in an
>     IPv6 environment.
> 
>   ... snip ...
> 
>   7.3.27  VRRP MIB (RFC 2787)
> 
>   The problems have not been addressed and a new MIB should 
> be defined.
> 
>   .. snip ..
> 
> I have told them that you are working on it, but you may want to keep
> an eye on the survey doc as well.
> 
> Thanks,
> Bert 
> 
> _______________________________________________
> vrrp mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/vrrp
> 

_______________________________________________
vrrp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/vrrp

---

From: Pekka Savola <[email-masked]>
Date: Wed, 3 Sep 2003 22:03:36 +0300 (EEST)

> best path forward would be.

I totally agree with the last paragraph -- it may be that Kalyan read a 
bit too much in the words in the survey document :-).

The wording of the document is not always optimal. _We_ (as in, v6ops
folks) don't know what's best for VRRP; we just try to fumble with words
and say that there seems to be a problem with VRRP MIB.

Whichever path you (VRRP WG) choose to take is probably best.  Please 
send substitute text for the document when the path is chosen.

Thanks,

 Pekka
 as v6ops co-chair