Subject: RE: [VRRP] GARP in draft-ietf-vrrp-spec-v2-10.txt

From: "Renwei Li" <[email-masked]>
Date: Wed, 21 Apr 2004 17:17:34 -0700

> 
> first place. I beleive the virtual MAC is calculated from the 
> Virtual IP address, something similar to Multicast MAC 
> calculation form multicast address.
> 

Wrong.

The virtual MAC is calculated from the configured VRRP VRID.

Regards,

Renwei

_______________________________________________
vrrp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/vrrp

---

From: "William StanisLaus" <[email-masked]>
Date: Thu, 22 Apr 2004 12:19:32 +0530

Thanks for all :)

but this reponse puzzles me ;)

what if ??

 +-------+   +-------+         +-------+   +-------+
 | Rtr1  |   | Rtr2  |         | Rtr3  |   | Rtr4  |
 |(MR    |   |(BR    |         |(MR    |   |(BR    |
 |VRID=1)|   |VRID=1 |         |VRID=1)|   |VRID=1 |
 +-------+   +-------+         +-------+   +-------+
 ---->*        *<- IP B      IP C->*       *<- IP D
 IP A |        |                   |       |
      |        |(Subnet 1)         |       |(Subnet 2)
 -----+--------+---------+      ---+----+--+-----+--
      ^        ^         |              ^        ^
      |        |         |              |        |
    (IP A)   (IP A)      |            (IP C)   (IP C)
      |        |         |              |        |
   +--+--+  +--+--+      |          +--+--+  +--+--+
   |  H1 |  |  H2 |      +----------|  H3 |  |  H4 |
   +-----+  +-----+         (IP A)  +--+--+  +--+--+ 

This is case, i assume VMAC calculation from VRID also consider's VRIP or
physical IP address.

otherwise, H3 will have same MAC configuration for both IP A and IP C

Best Regards,
William.

> -----Original Message-----
> From: Renwei Li [mailto:[email-masked]]
> Sent: Thursday, April 22, 2004 5:48 AM
> To: [email-masked]; [email-masked]
> Subject: RE: [VRRP] GARP in draft-ietf-vrrp-spec-v2-10.txt
> 
> 
> 
> 
> >

---

From: danny mitzel <[email-masked]>
Date: Thu, 22 Apr 2004 10:52:53 -0700 (PDT)

--- William StanisLaus <[email-masked]> wrote:
<snip picture>
> This is case, i assume VMAC calculation from VRID
> also consider's VRIP or physical IP address.
> 

the VRRP VMAC is not required to identify a globally 
(world wide) unique piece of hardware.  for proper 
VRRP (and LAN) operation a MAC is only required to be
unique within a LAN/broadcast domain.  that's the
scoping of the VMAC.

you're right that H3 would have IP A and IP C that
both map to the same VMAC1.  in normal host and
ARP table operation this is a non-issue because the
ARP table lookup key is the IP address.  if there's a 
state table or MIB with MAC as the key this could
raise an issue.

the one scenario I've seen fairly common where 
this VMAC LAN scoping raises problems is with some
L2 VLAN switches.  L2 switches that partition 
station learning cache and other state per-VLAN
have no issues.  L2 switches that use a global
station learning cache across all VLAN don't like
this VRRP feature.  in those deployment the
administrator needs to assign a different VRID to
virtual routers across all VLANs.

		
__________________________________
Do you Yahoo!?
Yahoo! Photos: High-quality 4x6 digital prints for 25¢
http://photos.yahoo.com/ph/print_splash

---

From: "William StanisLaus" <[email-masked]>
Date: Fri, 23 Apr 2004 12:21:35 +0530

when you have L2 Switch inbetween, there is always a problem,
hence i thought it will be good idea to use VRIP for calculating VMAC.

Best Regards,
William.

> From: danny mitzel [mailto:[email-masked]]
> Sent: Thursday, April 22, 2004 11:23 PM
> Yahoo! Photos: High-quality 4x6 digital prints for 25"

---

From: danny mitzel <[email-masked]>
Date: Fri, 23 Apr 2004 10:32:32 -0700 (PDT)

--- William StanisLaus <[email-masked]> wrote:
> when you have L2 Switch inbetween, there is always a
> problem, hence i thought it will be good idea to use
> VRIP for calculating VMAC.

I'm not sure what you mean by 'there is always a
problem' when vrrp is deployed with L2 switch/bridge?

I did mention the one confirmed problem I've heard of 
related to L2 switch implementing multiple logical L2 
(VLANs) within a single switch.  but for the standard 
L2 switch/bridge implementing a single LAN across all 
ports there should be no significant issues and
correct protocol operation has been demonstrated in
many real deployments.  there is an
interaction with station learning cache on vrrp 
master failover if the routers are connected to
different ports.  but that update is covered by the 
vrrp protocol (via heartbeat using MAC.src=VMAC) and
I wouldn't classify it as a 'problem'.  

I've heard rumors of issues/interactions related to
mostly non-standardized vendor 'value added features'.

e.g. locking a port down to a specific MAC address for

security/access control.  some rumors about 
interactions with spanning tree loop detection when a 
MAC changes port. etc.  but I'm not sure if those
have been confirmed/documented?