Subject: [VRRP] GARP in draft-ietf-vrrp-spec-v2-10.txt

From: "William StanisLaus" <[email-masked]>
Date: Wed, 21 Apr 2004 17:51:48 +0530

Hi,
	I've a clarification with VRRP-GRAP usage.

When a VRRP Master comes up, Section 6.4.1 Initialize,
       o Broadcast a gratuitous ARP request containing the virtual
         router MAC address for each IP address associated with the
         virtual router.

Also Section 6.4.2 Backup
    - If the Master_Down_Timer fires, then:
       o Send an ADVERTISEMENT
       o Broadcast a gratuitous ARP request containing the virtual
         router MAC address for each IP address associated with the
         virtual router

- Is it the MAC braodcasted is Virtual MAC associated with the Virtual IP
address ?? or Physical MAC associated with Virtual IP physical interface .

If the Client host is holding Virtual MAC associated with the Virtual IP..
there is no need to send the GARP message in the first place. I beleive the
virtual MAC is calculated from the Virtual IP address, something similar to
Multicast MAC calculation form multicast address.

During ARP form the Client Host to the Router on virtual IP, ARP replies
with the virtual MAC for the virtual IP and not the physical MAC associated
with the virtual ip address.

In that case, we needn't bother about the GARP and any intermediate routers
between the VRRP router and client host. Because, some cases routers will
block boardcast packets to get propagated on other subnet, here GARP is a
broadcast packet.

Best Regards,
William StanisLaus.

_______________________________________________
vrrp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/vrrp

---

From: danny mitzel <[email-masked]>
Date: Wed, 21 Apr 2004 11:33:39 -0700 (PDT)

> address ?? or Physical MAC associated with Virtual

in the references above where it says 'virtual
router MAC address' it means VMAC.  I guess we
should have been more consistent in using the term
VMAC throughout the spec since that's well defined
and less ambiguous.

so ARP packet 'sender harware address' = VMAC and
'sender protocol address' = VIP.

> there is no need to send the GARP message in the
> first place. 

your interpretation is correct; within the vrrp
protocol there is absolutely no requirement /
reliance on ARP.  that was part of the [often
controversial] design decision to go with VMAC.
the whole gratuitous ARP thing is more related
to smoothing initial transition from non-VRRP
operation to VRRP.  if you've deployed your network
and have hosts with the default router physical 
IP+MAC mapping in place and then you switch on
VRRP operation the gratuitous ARP is to hopefully
speed the switchover of those hosts.  within the
VRRP spec it was just easier to say 'always send
gratuitous ARP when a Master comes up' than to
try and figure out some robust mechanism to detect
just the case of the first Master transition when
VRRP is first enabled on the LAN.

cheers,danny

		
__________________________________
Do you Yahoo!?
Yahoo! Photos: High-quality 4x6 digital prints for 25¢
http://photos.yahoo.com/ph/print_splash

---

From: "Don Provan" <[email-masked]>
Date: Wed, 21 Apr 2004 10:13:45 -0700

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_______________________________________________vrrp mailing [email-masked]://www1.ietf.org/mailman/listinfo/vrrp