Subject: [VRRP] Vrrp Implementation issue over LinuxIp

From: "venkateshs" <[email-masked]>
Date: Wed, 19 Oct 2005 15:39:24 +0530

Hi,

   We are planning to run VRRP over a Logical Interface created in Linux
IP.(similar to eth0)

   How we can I prevent that Linux Interface from sending arp reply when it
is in Backup State?

  Also,How can we to associate various virtual MacAddresses to that Linux
Interface?

  Please share your valuable suggestions.

Thanks in advance,
Venkatesan S.

***************************************************************************
This message is proprietary to Future Software Limited (FSL)
and is intended solely for the use of the individual to whom it
is addressed. It may contain  privileged or confidential information
and should not be circulated or used for any purpose other than for
what it is intended.

If you have received this message in error, please notify the
originator immediately. If you are not the intended recipient,
you are notified that you are strictly prohibited from using,
copying, altering, or disclosing the contents of this message.
FSL accepts no responsibility for loss or damage arising from
the use of the information transmitted by this email including
damage from virus.
***************************************************************************

_______________________________________________
vrrp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/vrrp

---

From: "Don Provan" <[email-masked]>
Date: Wed, 19 Oct 2005 10:17:28 -0700

Hope the list doesn't mind this Linux specific conversation....

>    We are planning to run VRRP over a Logical Interface 

I'm not sure what this means. I run VRRP over an ethernet
interface. Is what you're doing significantly different?
 
>    How we can I prevent that Linux Interface from sending arp 
> reply when it is in Backup State?

Well, I think you're asking the wrong question. The real
question is how to you make the interface send an ARP reply
when it's supposed to. I always find it fascinating that
there's really no good reason for the non-owner system to
know the VR IP address at all except for ARP, so you're
best off if you can avoid attaching it to an interface
to begin with instead of attaching it and trying to
suppress the results.

I manipulate the ARP table directly, although in
the 2.4 kernel I had to extend to kernel's ARP code to
allow setting an ARP entry with a specific MAC address.
(I don't know if 2.6 supports that out of the box.)

>   Also,How can we to associate various virtual MacAddresses 
> to that Linux Interface?

You just add them as if they were multicast MAC addresses
you want your hardware to accept for delivery
Remember, the kernel should always use the natural MAC
address for all packets it sends. Only the VRRP packets
that your VRRP app generates should have the VR MAC
address as the source.

-don