Subject: RE: [VRRP] draft-ietf-vrrp-unified-mib-06 - AdvInterval

From: "Fioramonti, Joseph" <[email-masked]>
Date: Tue, 27 Mar 2007 08:52:26 -0400

Kalyan,

If your intention is to support a resurrected version of
draft-ietf-vrrp-ipv4-timers-02 (VRRPv4), then I think that we need a little
more.  In that expired draft...

*         Advertisement interval granularity can be seconds, centiseconds,
or milliseconds.

*         Advertisement count is configurable.

*         VR Mode is a new field.

On the other hand, if the intention is to run something more like VRRPv3
over IPv4, then we might be OK.

Thanks,

--Joe.

  _____  

From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, March 26, 2007 7:38 PM
To: [email-masked]
Subject: RE: [VRRP] draft-ietf-vrrp-unified-mib-06 - AdvInterval

Hi,

It is my understanding that VRRP unified MIB should take into account the
possibility of supporting

centisecond (sub second) timers for VRRP over IPv4 at a future time. 

I am sending this to get a consensus on this as advised by MIB Drs. 

Thanks, 
Kalyan 

_______________________________________________
vrrp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/vrrp

---

From: <[email-masked]>
Date: Tue, 27 Mar 2007 16:57:40 -0500

Joe,
 
MIB Drs advised me to check the WG if it wants the MIB to support any
future changes to advInterval for VRRP over IPv4 or
support VRRPv2 and VRRPv3 as it is today.
 
If the consensus is to support future changes - Then, as you mentioned,
we need to know 
    - Should it support draft-ietf-vrrp-ipv4-timers-02 . (which
unified-mib-06  dose not as you mentioned) 
    and/or
    - should it support advInterval similar to VRRPv3 (which it dose
support) 
 
It would be good to know what the WG thinks will be the most likely
future direction on this 
 
Thanks, 
Kalyan 

________________________________

From: ext Fioramonti, Joseph [mailto:[email-masked]] 
Sent: Tuesday, March 27, 2007 5:52 AM
To: Tata Kalyan (Nokia-ES/MtView); [email-masked]
Subject: RE: [VRRP] draft-ietf-vrrp-unified-mib-06 - AdvInterval

Kalyan,

If your intention is to support a resurrected version of
draft-ietf-vrrp-ipv4-timers-02 (VRRPv4), then I think that we need a
little more.  In that expired draft...

*         Advertisement interval granularity can be seconds,
centiseconds, or milliseconds.

Thanks,

--Joe.

________________________________

Hi,

It is my understanding that VRRP unified MIB should take into account
the possibility of supporting

Thanks, 
Kalyan

---

From: <[email-masked]>
Date: Thu, 29 Mar 2007 14:11:04 -0500

Hi Mukesh and Radia,
 
    It is your call as to how we should proceed with advInterval for
VRRP over IPv4.
 
Anyone planning to revive draft-ietf-vrrp-ipv4-timers-02 ?

Thanks, 
Kalyan 

From: ext [email-masked] [mailto:[email-masked]] 
Sent: Tuesday, March 27, 2007 2:58 PM
To: [email-masked]; [email-masked]
Subject: RE: [VRRP] draft-ietf-vrrp-unified-mib-06 - AdvInterval

Joe,

 
 
Thanks, 
Kalyan 

Kalyan,

Thanks,

--Joe.

Hi,

Thanks, 
Kalyan

---

From: <[email-masked]>
Date: Thu, 29 Mar 2007 17:59:38 -0500

Thanks Don,
If we are going to revive the draft, the obvious answer to the MIB is to
support the 
New draft. Please let me know what will be the major changes to
draft-ietf-vrrp-ipv4-timers-02
So I can add them to the MIB.

Thanks,
Kalyan

-----Original Message-----
From: ext Don Provan [mailto:[email-masked]] 
Sent: Thursday, March 29, 2007 2:04 PM
To: Tata Kalyan (Nokia-ES/MtView); [email-masked];
[email-masked]

> Anyone planning to revive draft-ietf-vrrp-ipv4-timers-02 ?

As a matter of fact, I see this looming large in my future, so why don't
I step up now and offer to pick it up. I'll go dig up a copy and see
where we are.

Anyone that wants to give me advice or remind me of outstanding issues
can drop me a line.

-don provan

---

From: "Don Provan" <[email-masked]>
Date: Thu, 29 Mar 2007 14:03:57 -0700

> Anyone planning to revive draft-ietf-vrrp-ipv4-timers-02 ?

As a matter of fact, I see this looming large in my future, so
why don't I step up now and offer to pick it up. I'll go dig
up a copy and see where we are.

Anyone that wants to give me advice or remind me of outstanding
issues can drop me a line.

-don provan

---

From: "Don Provan" <[email-masked]>
Date: Thu, 29 Mar 2007 16:46:02 -0700

> Please let me know what will be the major changes 
> to draft-ietf-vrrp-ipv4-timers-02

Well, let's get an idea....

As I look over the draft, I remember why I lost interest
in it: it seems like extreme overkill for such a simple
change. So I'd like to float the following simplifications
and see if the list can agree on them after a year to
think about it:

1. Eliminate the requirement for interaction between slow
and fast VRRP implementations: an implementation that
supports fast timers MUST be configurable to run either
fast or slow, but all members of the VR must run in the
same mode. (I'm thinking the modes would be differentiated
on the wire via the proposed new packet type, so mismatched
routers would ignore (for slow) or complain about (for fast)
the other router's packets, and the VR would fall into VRRP's
standard "ships in the night" failure mode.)

2. Eliminate the requirement to support timeouts less
than 1 centisecond.

3. Eliminate the requirement to support timeouts greater
than 2.55 seconds in fast mode. Longer timeouts can be
supported by running in slow mode.

4. Eliminate the requirement that all VRs clocks tick
at the same rate: only the timeout time should be
carried in the protocol packet; the tick rate (i.e.,
the packet transmission rate) should be a configuration
option local to the implementation. (I don't see any
particular advantages for cooperating routers to use
different tick rates, I just see no reason for the
protocol to enforce a uniform rate.)

As I look back on the most recent e-mail on this from
last summer, it seems as if #4 was actually approaching
a consensus, but the others may be quite contentious.

-don provan