Subject: [VRRP] Router Advertisement in the VRRP environment

From: [email-masked]
Date: Tue, 10 Jul 2007 10:28:41 +0900 (JST)

Hello all,

I have the following two questions in regard to the interaction
of 'VRRP for IPv6' and 'Router Advertisement'.
I appreciate much if someone make these clear for me.

Q-1: May, or must not, a VRRP router keep sending Router Advertisement
     messages whose source MAC address is physical MAC address of the
     router's interface and whose source IPv6 address is link-local
     addres of the router's interface even in the VRRP environment?

>From draft-ietf-vrrp-ipv6-spec-08,
>|6.4.3   Master
(snip)
>|   While in this state, a VRRP router MUST do the following:
(snip)
>|    - MUST send ND Router Advertisements for the virtual router.

Q-2: Must the master router send Router Advertisement messages
     even when Router Advertisement isn't enabled on the link?

Best regards,
-- 
Tomohiko Kurahashi <[email-masked]>

_______________________________________________
vrrp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/vrrp

---

From: "John Cruz \(johcruz\)" <[email-masked]>
Date: Tue, 10 Jul 2007 11:46:43 -0700

Hi,

When one configures VRRP, the assumption is that you want
the end-hosts on the link to use the virtual address and
not the router's physical address. Router advertisements
need to be sent, but from the virtual router's point of
view.

When router advertisement is disabled on a link, then the
virtual router stops sending router advertisement on that
link.

Hope this helps.

John 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> Sent: Monday, July 09, 2007 6:29 PM
> To: [email-masked]
> Subject: [VRRP] Router Advertisement in the VRRP environment
> 
> Hello all,
>

---

From: [email-masked]
Date: Wed, 11 Jul 2007 18:42:33 +0900 (JST)

Hello John,

Thank you for your reply. It's a great help for me!

Best regards,

From: [email-masked]
Date: Wed Jul 11 2007 03:46:43 JST