Subject: [vwrap] SimianGrid protocols and VWRAP

From: Morgaine <[email-masked]>
Date: Sat, 12 Jun 2010 16:53:04 +0100

John, I know that you've been doing some very interesting work on the
SimianGrid project, and that some parts of it are related to the standards
effort in this Working Group.  Unfortunately your protocol work beyond LLSD
has never been described to us here.

The IETF standards process operates through the mailing lists of its Working
Groups, so if you want your work to have a direct bearing on our protocol
discussions, you need to describe your protocol elements here.  Actual
implementations are of course exceedingly important and non-optional, but
the analysis, discussion and refinement of code into an IETF standards
protocol happens here, not in individual project groups.

You've said before that more information is forthcoming.  I would very much
welcome that.  While your code seems to be progressing nicely, we need any
new protocol information described here to help the Working Group move along
on the standards process.

Morgaine.

======================================

On Sat, Jun 12, 2010 at 12:35 AM, Hurliman, John <[email-masked]>wrote:

> I cannot make it out to Maastricht. I would be interested in hearing from
> anyone who is still working on VWRAP though.
> John
>
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]] On Behalf
> > Of Joshua Bell
> > Sent: Friday, June 11, 2010 1:28 PM
> > To: [email-masked]
> > Subject: [vwrap] Meeting in Maastricht/IETF78 ?
> >
> > Quick poll:
> >
> > Are any VWRAP participants planning to attend IETF78 in Maastricht and,
> > if so, are there VWRAP issues you would like to have on the agenda for
> > a face-to-face meeting?
> >
> > The chairs are trying to gauge whether or not we should request a
> > session slot. You can reply to the list, or privately to me.
>
> _______________________________________________
> vwrap mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/vwrap
>

---

From: "Hurliman, John" <[email-masked]>
Date: Mon, 14 Jun 2010 16:08:12 -0600

I've recently been working closely with my team at Intel on systems scalability problems in virtual worlds and have not had as much time to focus on VWRAP implementation. I did finish up a bit of coding over the weekend though and added initial support for VWRAP launch documents[1] to SimianGrid[2]. A bit of background:

SimianGrid is a set of web services that provides critical backend components for a virtual world. These are the "grid services" in Second Life or OpenSim terminology, or Agent Domain in VWRAP terminology. The components include content storage and distribution (assets), user accounts/identity, user inventory, spatial mapping (region registration, map tiles), and a login service. This is enough to provide full support for the grid connector API in the upcoming release of OpenSim 0.7 (which will natively support SimianGrid), and is also compatible with the lightweight simulation platform we use for prototyping called Simian (which SimianGrid was named after). SimianGrid is written entirely in PHP, and also includes a web frontend named SimianGridFrontend using the CodeIgniter framework and a WebDAV inventory frontend named SimianGridWebDAV using the SabreDAV library.

A major hurdle that OpenSim-based virtual worlds have to overcome is the account creation, login process, and content import process for every world a user visits (and the myriad of issues surrounding each of those topics). While one of the ultimate goals of VWRAP is to solve all of those issues, VWRAP launch documents provide a solution for the login process and a stepping stone toward solving the account creation process. The plan is for SimianGrid to support two launch document methods: authenticated and unauthenticated. Either can optionally carry a starting location URI. Unauthenticated mode is as simple as telling the rich client where the login URL of the grid is. Authenticated mode carries identity information (agent name) and the login URL is actually a capability allowing direct login from web to world. This also functions as a successor to the GridInfo[3] protocol that OpenSim developed to inform viewers of various grid-specific URLs.

The original plan was for launch document support to go into Snowglobe, but with Snowglobe VWRAP development on hiatus I refitted my Cable Beach Launcher app into VWRAP Launcher that I will release in a few days. If a VWRAP teleport draft surfaces I can start on an implementation, but that won't get far without viewer support for it.

Meadhbh, I have a small number of refinement suggestions for the launch document spec (again) but I'll wait until we have a few experimental grids actually running the code before making any firm arguments.

[1] http://tools.ietf.org/html/draft-hamrick-vwrap-launch
[2] http://openmetaverse.googlecode.com/
[3] http://opensimulator.org/wiki/GridInfo

John

From: [email-masked] [mailto:[email-masked]] On Behalf Of Morgaine
Sent: Saturday, June 12, 2010 8:53 AM
To: [email-masked]
Subject: [vwrap] SimianGrid protocols and VWRAP

John, I know that you've been doing some very interesting work on the SimianGrid project, and that some parts of it are related to the standards effort in this Working Group.  Unfortunately your protocol work beyond LLSD has never been described to us here.

The IETF standards process operates through the mailing lists of its Working Groups, so if you want your work to have a direct bearing on our protocol discussions, you need to describe your protocol elements here.  Actual implementations are of course exceedingly important and non-optional, but the analysis, discussion and refinement of code into an IETF standards protocol happens here, not in individual project groups.

You've said before that more information is forthcoming.  I would very much welcome that.  While your code seems to be progressing nicely, we need any new protocol information described here to help the Working Group move along on the standards process.

Morgaine.

======================================
On Sat, Jun 12, 2010 at 12:35 AM, Hurliman, John <[email-masked]<mailto:[email-masked]>> wrote:
I cannot make it out to Maastricht. I would be interested in hearing from anyone who is still working on VWRAP though.
John

> From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf
> Of Joshua Bell
> To: [email-masked]<mailto:[email-masked]>
_______________________________________________
vwrap mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/vwrap

---

From: "Hurliman, John" <[email-masked]>
Date: Wed, 16 Jun 2010 22:50:32 -0600

I just released the first version of the VWRAP Launcher on <http://openmetaverse.googlecode.com>. Source code and a Windows installer are available (packaged binaries for other platforms will come when I have time or someone else volunteers). VWRAP launch document support in SimianGrid is still being worked on and not integrated into the web interface yet, but you can test out unauthenticated launches by visiting:

http://yoursimiangrid.com/GridFrontend/index.php/launch

Which should return a JSON LLSD document with an application/calm+json MIME type containing the login URL for that grid. The launcher app supports many more features in launch documents: starting location URIs, pre-authenticated logins, and various SL viewer helper URLs that should just start working when SimianGrid is updated with new launch code.

I also added a Google Maps world map interface to SimianGrid; we should be clicking from OpenSim maps straight in-world soon.

John

> Of Hurliman, John
> Sent: Monday, June 14, 2010 3:08 PM
> To: [email-masked]
> Subject: Re: [vwrap] SimianGrid protocols and VWRAP
> 
> I've recently been working closely with my team at Intel on systems
> scalability problems in virtual worlds and have not had as much time to
> focus on VWRAP implementation. I did finish up a bit of coding over the
> weekend though and added initial support for VWRAP launch documents[1]
> to SimianGrid[2]. A bit of background:
> 
> 
> 
> SimianGrid is a set of web services that provides critical backend
> components for a virtual world. These are the "grid services" in Second
> Life or OpenSim terminology, or Agent Domain in VWRAP terminology. The
> components include content storage and distribution (assets), user
> accounts/identity, user inventory, spatial mapping (region
> registration, map tiles), and a login service. This is enough to
> provide full support for the grid connector API in the upcoming release
> of OpenSim 0.7 (which will natively support SimianGrid), and is also
> compatible with the lightweight simulation platform we use for
> prototyping called Simian (which SimianGrid was named after).
> SimianGrid is written entirely in PHP, and also includes a web frontend
> named SimianGridFrontend using the CodeIgniter framework and a WebDAV
> inventory frontend named SimianGridWebDAV using the SabreDAV library.
> 
> 
> 
> A major hurdle that OpenSim-based virtual worlds have to overcome is
> the account creation, login process, and content import process for
> every world a user visits (and the myriad of issues surrounding each of
> those topics). While one of the ultimate goals of VWRAP is to solve all
> of those issues, VWRAP launch documents provide a solution for the
> login process and a stepping stone toward solving the account creation
> process. The plan is for SimianGrid to support two launch document
> methods: authenticated and unauthenticated. Either can optionally carry
> a starting location URI. Unauthenticated mode is as simple as telling
> the rich client where the login URL of the grid is. Authenticated mode
> carries identity information (agent name) and the login URL is actually
> a capability allowing direct login from web to world. This also
> functions as a successor to the GridInfo[3] protocol that OpenSim
> developed to inform viewers of various grid-specific URLs.
> 
> 
> 
> The original plan was for launch document support to go into Snowglobe,
> but with Snowglobe VWRAP development on hiatus I refitted my Cable
> Beach Launcher app into VWRAP Launcher that I will release in a few
> days. If a VWRAP teleport draft surfaces I can start on an
> implementation, but that won't get far without viewer support for it.
> 
> 
> 
> Meadhbh, I have a small number of refinement suggestions for the launch
> document spec (again) but I'll wait until we have a few experimental
> grids actually running the code before making any firm arguments.
> 
> 
> 
> Of Morgaine
> SimianGrid project, and that some parts of it are related to the
> standards effort in this Working Group.  Unfortunately your protocol
> work beyond LLSD has never been described to us here.
> 
> The IETF standards process operates through the mailing lists of its
> Working Groups, so if you want your work to have a direct bearing on
> our protocol discussions, you need to describe your protocol elements
> here.  Actual implementations are of course exceedingly important and
> non-optional, but the analysis, discussion and refinement of code into
> an IETF standards protocol happens here, not in individual project
> groups.
> 
> You've said before that more information is forthcoming.  I would very
> much welcome that.  While your code seems to be progressing nicely, we
> need any new protocol information described here to help the Working
> Group move along on the standards process.
> 
> 
> Morgaine.
> 
> 
> 
> 
> 
> 
> On Sat, Jun 12, 2010 at 12:35 AM, Hurliman, John
> <[email-masked]> wrote:
> 
> I cannot make it out to Maastricht. I would be interested in hearing
> from anyone who is still working on VWRAP though.
> John
> 
> 
> > Are any VWRAP participants planning to attend IETF78 in Maastricht
> > and, if so, are there VWRAP issues you would like to have on the
> > agenda for a face-to-face meeting?
> >