Subject: Re: [vwrap] Moving startup documents into the working group

From: Barry Leiba <[email-masked]>
Date: Thu, 17 Jun 2010 19:09:59 -0400

Quoting from my previous message:

> It's time to think about which pre-WG documents the working group is
> ready to adopt.  As I introduce this, I want to stress that adoption
> of documents does NOT mean that the group has consensus on the current
> content of those documents, that it collectively agrees with what they
> say, that the documents are in any sense "ready".  All it means is
> that the working group thinks they're headed in the right direction,
> and can be used as a starting point for further refinement.  Indeed,
> documents adopted as starting points by the working group might have a
> number of significant revisions before they are declared "ready" and
> are sent to the IESG.

We've had very little response to this, but the response that we've
had supports adopting these:

> * Introduction and Goals
> http://tools.ietf.org/html/draft-hamrick-vwrap-intro-01

> * Trust Model and User Authentication
> http://tools.ietf.org/html/draft-hamrick-vwrap-authentication-01

> * Abstract Type System for the Transmission of Dynamic Structured Data
> http://tools.ietf.org/html/draft-hamrick-vwrap-type-system-00

I am, therefore, approving the following document names:
 -  draft-ietf-vwrap-intro
 -  draft-ietf-vwrap-authentication
 -  draft-ietf-vwrap-type-system

Noting that these are all under Meadhbh's editorship: Meadhbh, will
you please post revisions of these documents before the IETF 79
deadline of 5 July at 17:00 PDT ?   Post them with the new names as
-00 versions, and they will become working-group documents.  Please
post whatever version you have of them by the deadline -- even if some
have not changed since the last individual-draft version.

Thanks.

Barry, as chair

---

From: "Hurliman, John" <[email-masked]>
Date: Thu, 17 Jun 2010 17:16:37 -0600

What happened to the launch document draft? Aside from the LLSD type system, it's the only document that we have a working implementation and deployment for.
John

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Barry Leiba
Sent: Thursday, June 17, 2010 4:10 PM
To: [email-masked]
Subject: Re: [vwrap] Moving startup documents into the working group

Noting that these are all under Meadhbh's editorship: Meadhbh, will you please post revisions of these documents before the IETF 79
deadline of 5 July at 17:00 PDT ?   Post them with the new names as
-00 versions, and they will become working-group documents.  Please post whatever version you have of them by the deadline -- even if some have not changed since the last individual-draft version.

Thanks.

Barry, as chair
_______________________________________________
vwrap mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/vwrap

---

From: Barry Leiba <[email-masked]>
Date: Thu, 17 Jun 2010 19:23:51 -0400

On Thu, Jun 17, 2010 at 7:16 PM, Hurliman, John <[email-masked]> wrote:
> What happened to the launch document draft? Aside from the LLSD type
> system, it's the only document that we have a working implementation and
> deployment for.

What happened is that we only got two votes on it, one for adopting it
(you) and one against (Morgaine).  That's not rough consensus, so
we're not adopting it yet.  See Morgaine's message:
   http://www.ietf.org/mail-archive/web/vwrap/current/msg00152.html
...for her comments about why she said no.

Barry

---

From: "Hurliman, John" <[email-masked]>
Date: Thu, 17 Jun 2010 17:27:26 -0600

Ok. I was counting Meadhbh's follow-up e-mail addressing the launch document (http://www.ietf.org/mail-archive/web/vwrap/current/msg00154.html) as a +1, although I guess it wasn't explicitly stated.

-----Original Message-----
From: Barry Leiba [mailto:[email-masked]] 
Sent: Thursday, June 17, 2010 4:24 PM
To: Hurliman, John
Cc: [email-masked]
Subject: Re: [vwrap] Moving startup documents into the working group

On Thu, Jun 17, 2010 at 7:16 PM, Hurliman, John <[email-masked]> wrote:
> system, it's the only document that we have a working implementation 
> and deployment for.

What happened is that we only got two votes on it, one for adopting it
(you) and one against (Morgaine).  That's not rough consensus, so we're not adopting it yet.  See Morgaine's message:
   http://www.ietf.org/mail-archive/web/vwrap/current/msg00152.html
...for her comments about why she said no.

Barry

---

From: "Dickson, Mike (ISS Software)" <[email-masked]>
Date: Fri, 18 Jun 2010 00:18:06 +0000

I'll add a +1 (and should have earlier) to move this onward.  I agree with Meadbh's comments on purpose and as John indicated there's some implementation experience with it as well.

Mike

-----Original Message-----
From: Barry Leiba [mailto:[email-masked]] 
Sent: Thursday, June 17, 2010 4:24 PM
To: Hurliman, John
Cc: [email-masked]
Subject: Re: [vwrap] Moving startup documents into the working group

Barry

---

From: Meadhbh Hamrick <[email-masked]>
Date: Thu, 17 Jun 2010 17:22:02 -0700

yeah. peeps should imply that i +1 any draft i author.

i'm sort of abstaining in an any official vote as i'm far from being a
disinterested party. also... i wanted to give people a bit of time to
discuss the drafts before weighing in too heavily. my response to
morgaine's response was not to discuss the technical merits of the
draft, but to provide additional context as to what the draft was
supposed to address.

-cheers
-meadhbh
--
meadhbh hamrick * it's pronounced "maeve"
@OhMeadhbh * http://meadhbh.org/ * [email-masked]

---

From: Morgaine <[email-masked]>
Date: Fri, 18 Jun 2010 02:45:54 +0100

Perhaps someone could explain using a different form of words how client
launching forms a natural part of a VW interop protocol?

I don't doubt at all that it's useful to launch a client application from a
web page, but I gave the document a "No" simply because I don't see how it's
in scope for us.

Should the SMTP standard include a document on how to launch a mail client?
Should the XMPP standard include a document on how to launch a Jabber
client?  Should the SNMP standard include a document on how to launch
snmpwalk?

I don't think it's actually *harmful*  to have an auxiliary document only
marginally related to VWs within our document set, so I could probably be
persuaded for the sake of unanimity.  But it does seem an oddball
specification within our protocol context.

Perhaps the best defense for it is that it promotes the cause of VW interop
by creating a Web standard in the area.  In that sense it's a useful
document despite client launching having little direct relevance to our
VWRAP client-server protocol.

Barry, I won't argue further against adding this document to our set so go
right ahead on that, given the general support.  Usefulness probably trumps
relevance and consistency in this case anyway. :-)

Morgaine.

==============================

On Fri, Jun 18, 2010 at 1:22 AM, Meadhbh Hamrick <[email-masked]>wrote:

> > Ok. I was counting Meadhbh's follow-up e-mail addressing the launch
> document (http://www.ietf.org/mail-archive/web/vwrap/current/msg00154.html)
> as a +1, although I guess it wasn't explicitly stated.
> >
> > (you) and one against (Morgaine).  That's not rough consensus, so we're
> not adopting it yet.  See Morgaine's message:

---

From: "Patnad Babii" <[email-masked]>
Date: Thu, 17 Jun 2010 22:19:03 -0400

I give also my vote to that document, its not like it is set in stone anyways and it can give a kick start to VW who try to implement the protocol. If at a later stage we find it has not its place in the WG, then it can be put aside. 

From: Morgaine 
Sent: Thursday, June 17, 2010 9:45 PM
To: [email-masked] 
Subject: Re: [vwrap] Moving startup documents into the working group

Perhaps someone could explain using a different form of words how client launching forms a natural part of a VW interop protocol?

I don't doubt at all that it's useful to launch a client application from a web page, but I gave the document a "No" simply because I don't see how it's in scope for us.

Should the SMTP standard include a document on how to launch a mail client?  Should the XMPP standard include a document on how to launch a Jabber client?  Should the SNMP standard include a document on how to launch snmpwalk?

I don't think it's actually harmful  to have an auxiliary document only marginally related to VWs within our document set, so I could probably be persuaded for the sake of unanimity.  But it does seem an oddball specification within our protocol context.

Perhaps the best defense for it is that it promotes the cause of VW interop by creating a Web standard in the area.  In that sense it's a useful document despite client launching having little direct relevance to our VWRAP client-server protocol.

Barry, I won't argue further against adding this document to our set so go right ahead on that, given the general support.  Usefulness probably trumps relevance and consistency in this case anyway. :-)

Morgaine.

On Fri, Jun 18, 2010 at 1:22 AM, Meadhbh Hamrick <[email-masked]> wrote:

  -cheers
  -meadhbh

--------------------------------------------------------------------------------

---

From: Morgaine <[email-masked]>
Date: Fri, 18 Jun 2010 03:48:00 +0100

On Fri, Jun 18, 2010 at 3:01 AM, Meadhbh Hamrick <[email-masked]>wrote:

>
> i think the idea here is that it's in scope because it establishes a
> session between a client and a virtual world. so it's part of
> "interop" because (in theory) you'll have different VWRAP clients
> getting descriptors of where to rez avatars from different web based
> systems (wikipedia, facebook, etc.) and trying to get them to talk to
> different server implementations (OpenSim, Simian, Beyon, etc.)
>

That's an excellent reason, Meadhbh!

Anything that promotes VW interop gets my vote, so you've converted me to +1
on this. :-)

Morgaine.

==================================

On Fri, Jun 18, 2010 at 3:01 AM, Meadhbh Hamrick <[email-masked]>wrote:

> hey morgaine...
>
> i think the idea here is that it's in scope because it establishes a
> session between a client and a virtual world. so it's part of
> "interop" because (in theory) you'll have different VWRAP clients
> getting descriptors of where to rez avatars from different web based
> systems (wikipedia, facebook, etc.) and trying to get them to talk to
> different server implementations (OpenSim, Simian, Beyon, etc.)
>
> also one of the reasons we wanted to write an internet draft for this
> is that beyond the issue of getting everyone to use similar launch
> messages, we wanted to use register a launch message mime type. one of
> they ways to register a mime type is to write an RFC describing how
> it's used.
>
> -cheers
> -meadhbh
> --
> On Thu, Jun 17, 2010 at 6:45 PM, Morgaine
> <[email-masked]> wrote:
> > I don't think it's actually harmful  to have an auxiliary document only
> >> On Thu, Jun 17, 2010 at 4:27 PM, Hurliman, John <
> [email-masked]>
> >> wrote:
> >> > document (
> http://www.ietf.org/mail-archive/web/vwrap/current/msg00154.html)
> we're

---

From: Barry Leiba <[email-masked]>
Date: Fri, 18 Jun 2010 16:44:20 -0400

Morgaine says...
> Anything that promotes VW interop gets my vote, so you've converted me to +1

Cool.

OK, so, Meadhbh, I've also approved "draft-ietf-vwrap-launch".  Please
add that to your list, to have an updated version by the IETF 79
deadline.

T'anks.

Barry, as chair

---

From: Meadhbh Hamrick <[email-masked]>
Date: Fri, 18 Jun 2010 15:42:03 -0700

Ossm. Will do. Thx everybody!

On Jun 18, 2010 1:44 PM, "Barry Leiba" <[email-masked]>
wrote:

Morgaine says...

Cool.

T'anks.

Barry, as chair