Subject: Re: Re-sched? Re: my pda sez... (W3C/IETF telcon)

From: Dan Connolly <[email-masked]>
Date: Wed, 10 Aug 2005 11:15:47 -0500

On Tue, 2005-07-26 at 18:17 -0400, Leslie Daigle wrote:
> Now back from vacation... IETF is next week,

Which is now last week. I'm soaking up reports from
various BOFs and meetings...

>  and (FWIW/FYI)
> I'm out of town/unavailable Aug 22-26.

OK, let's see if I can get this done before then.

Monday, 15 Aug at 2pm Chicago / 3pm Boston / 19:00:00 UTC?

Tuesday, 16 Aug at 2pm Chicago/ 3pm Boston / 19:00:00 UTC?

I *think* TimBL can make those times. If they're good for
a couple other people, I'll have Amy confirm.

I can any time between 10:30am and 6pm Chicago time on Monday.
For reference, here's Boston, Chicago, and UTC on Monday:
http://www.timeanddate.com/worldclock/meetingtime.html?month=8&day=15&year=2005&p1=0&p2=43&p3=64&p4=-1

I'm also free Friday afternoon Chicago time.

For reference, minutes from last time:
http://www.w3.org/2005/02/04-ietf-w3c-minutes.html

-- 
Dan Connolly, W3C http://www.w3.org/People/Connolly/
gpg D3C2 887B 0F92 6005 C541  0875 0F91 96DE 6E52 C29E
office: tel:+1-617-395-0241
mobile: tel:+1-816-616-6576
mobile: mailto:[email-masked]

---

From: "Scott Hollenbeck" <[email-masked]>
Date: Wed, 10 Aug 2005 12:32:11 -0400

The 15th or the 19th are better for me than the 16th.

-Scott-

> -----Original Message-----
> From: Dan Connolly [mailto:[email-masked]] 
> Sent: Wednesday, August 10, 2005 12:16 PM
> To: Leslie Daigle
> Cc: Philippe Le Hegaret; [email-masked]; Amy van der Hiel
> Subject: Re: Re-sched? Re: my pda sez... (W3C/IETF telcon)
>

---

From: Ted Hardie <[email-masked]>
Date: Wed, 10 Aug 2005 09:45:24 -0700

The 19th I have conflicts from 2:30 to 4:00 PDT.  I can make the 16th at
the times states, and I could probably make the 15th, though there may
be a day job interrupt.
			Ted

---

From: Leslie Daigle <[email-masked]>
Date: Wed, 10 Aug 2005 15:09:00 -0400

I can do any of those times.

Am I mis-reading, or does it look like the 19th is the best bet
so far (if we can do it as "early" as 3pm US-ET, which is still
"late" in Europe)?

Leslie.

---

From: Philippe Le Hegaret <[email-masked]>
Date: Wed, 10 Aug 2005 15:21:49 -0400

> so far (if we can do it as "early" as 3pm US-ET, which is still

I won't be able to make it on the 19, and would prefer the 15. I could
be around on the 16.

Philippe

---

From: John C Klensin <[email-masked]>
Date: Wed, 10 Aug 2005 15:50:40 -0400

> so far (if we can do it as "early" as 3pm US-ET, which is still

I'm not really important here, but I'll be somewhere over the
Pacific on the 19th.  Any of the times in the first half of the
week that have been suggested would work for me.

   john

---

From: Dan Connolly <[email-masked]>
Date: Fri, 12 Aug 2005 18:06:26 -0500

I detect a critical mass for:

Monday, 15 Aug at 2pm Chicago / 3pm Boston / 19:00:00 UTC

In particular, I gather the following are availble:
 Dan Connolly
 Scott Hollenbeck
 Ted Hardie
 Leslie Daigle
 Philippe Le Hegaret
 Tim Berners-Lee (* not 100% confirmed)

I'll be sure the bridge is available:

Zakim Bridge +1.617.761.6200, conference 4383 ("IETF")

and I'll be watching an IRC channel, along with
a teleconference bot and a logging bot.
 irc://irc.w3.org:6665/ietf-w3c
i.e.
   /server irc.w3.org 6665
   /join #ietf-w3c

I don't have an agenda together yet; expect one
Monday morning (Chicago time). I hope that's sufficiently
timely.

A volunteer to scribe would be most welcome.

---

From: Tim Berners-Lee <[email-masked]>
Date: Mon, 15 Aug 2005 11:30:08 -0400

>  Tim Berners-Lee (* not 100% confirmed)

Confirmed.  I will have to leave at about 16:20 ET
Tim

---

From: Dan Connolly <[email-masked]>
Date: Mon, 15 Aug 2005 11:31:05 -0500

1. Convene, take roll, recruit scribe, review agenda

   for 60 to 80 minutes

expected:
  Dan Connolly (chair)
  Philippe Le Hegaret
  Tim Berners-Lee
  Scott Hollenbeck
  Ted Hardie
  Leslie Daigle
  John Klensin?

scribe?

comments on the agenda? It's based on actions from last time
http://www.w3.org/2005/02/04-ietf-w3c-minutes.html
and recent traffic in 
 http://lists.w3.org/Archives/Public/public-ietf-w3c/
and [email-masked]

I don't know if all 9 of these are worth discussing.
And there may well be others to add.

2. Introducing Philippe Le Hegaret

http://www.w3.org/2001/11/StdLiaison#IETF

3. registration of mime types from standards (action ACTION: hardie to
confirm location of published IESG procedures...)

4. P3P header registry (ACTION MJDuerst: Get Massimo to contact Ted
Hardie)

5. file: URI scheme draft (ACTION: MJD to contact Paul H)

6. mailng list notices, archives in the W3C and IETF

[[
For [email-masked]', there was some concern that IETF business
was being conducted on a (joint) list that didn't include
the IETF "Note Well" disclaimer.

I suggest that lists that are both W3C and IETF lists
(joint working groups, and, in this case, [email-masked])
that the W3C notice and IETF notice be combined.
]]
 -- LMM 8 Aug
http://lists.w3.org/Archives/Public/public-ietf-w3c/2005Aug/0002.html

7. Remote UI BoF and Synchronized XML DOMs

FYI
http://lists.w3.org/Archives/Public/public-ietf-w3c/2005Aug/0006.html

8. WG Action: Calendaring and Scheduling Standards Simplification
(calsify)

FYI
http://lists.osafoundation.org/pipermail/ietf-calsify/2005-July/000689.html

Also:

Time Zone Registry
http://ietfreport.isoc.org/idref/draft-royer-timezone-registry/

and http://www.w3.org/2002/12/cal/#tzd

9. URI guidelines last call extended to 31 Aug 

http://ietfreport.isoc.org/idref/draft-hansen-2717bis-2718bis-uri-guidelines/

---

From: Ted Hardie <[email-masked]>
Date: Mon, 15 Aug 2005 12:18:15 -0700

http://www.ietf.org/internet-drafts/draft-marchiori-w3c-p3p-header-01.txt
is the document in question.
			Ted

---

From: Dan Connolly <[email-masked]>
Date: Wed, 17 Aug 2005 10:30:09 -0500

Attached find minutes for review.

Unless I hear otherwise within a week, I'll announce
these to [email-masked]

They're also available at...
  http://www.w3.org/2005/08/15-ietf-w3c-minutes

-- 
Dan Connolly, W3C http://www.w3.org/People/Connolly/
D3C2 887B 0F92 6005 C541  0875 0F91 96DE 6E52 C29E

---

From: Leslie Daigle <[email-masked]>
Date: Wed, 17 Aug 2005 11:35:21 -0400

Works for me.

Thanks,
Leslie.

Dan Connolly wrote:
> ------------------------------------------------------------------------
> 
> W3C <http://www.w3.org/>
> 
> 
>   W3C/IETF telcon
> 
> 
>     15 Aug 2005
> 
> 
>     Attendees
> 
> Present
>     Dan Connolly, Tim Berners-Lee, John C Klensin, Leslie Daigle, Ted
>     Hardie, Scott Hollenbeck, Philippe Le Hégaret
> Chair
>     Dan
> Scribe
>     Philippe
> 
> 
>     Contents
> 
>     * Topics <#agenda>
>          1. Convene, take roll, recruit scribe, review agenda <#item01>
>          2. introducing Philippe Le Hégaret <#item02>
>          3. registration of mime types from standards <#item03>
>          4. P3P header registry <#item04>
>          5. next meeting <#item05>
>          6. file: URI scheme draft <#item06>
>          7. mailng list notices, archives in the W3C and IETF <#item07>
>          8. Remote UI BoF and Synchronized XML DOMs <#item08>
>          9. Calendaring and Scheduling Standards Simplification
>             (calsify), time zone registry <#item09>
>         10. URI guidelines last call extended to 31 Aug <#item12>
>         11. syndication trends: RSS/Atom <#item13>
>         12. GEOPRIV, privacy and VoIP <#item14>
>     * Summary of Action Items <#ActionSummary>
> 
> See also: IRC log <http://www.w3.org/2005/08/15-ietf-w3c-irc>, minutes 
> from previous meeting <http://www.w3.org/2005/02/04-ietf-w3c-minutes.html>
> 
> ------------------------------------------------------------------------
> 
> 
>       Convene, take roll, recruit scribe, review agenda
> 
> [no addtion to the agenda]
> 
> 
>       introducing Philippe Le Hégaret
> 
> Dan: Martin left us after our last telecon. Philippe is replacing him
> 
> [presentations]
> 
> <Philippe> I'm w3c architecture domain lead, which means I'm responsible 
> for XML, Web Services, I18N, DOM, and URI activities.
> 
> 
>       registration of mime types from standards
> 
> ACTION: hardie to confirm location of published IESG procedures...
> 
> Ted: just finished the approval of the document. they are now in the RFC 
> editors hands.
> 
> PLH: I checked the changes in the latest draft; they don't seem to 
> impact W3C's process for registering media types 
> <http://www.w3.org/2002/06/registering-mediatype>.
> 
> Philippe: as far I understand, we're in sync. we're following the proper 
> process
> 
> 
>       P3P header registry
> 
> ACTION MJDuerst: Get Massimo to contact Ted Hardie
> 
> Dan: is it still relevant?
> 
> Ted: didn't get contacted. if you still want the header, you should keep 
> trying to register. If Philippe is interested, he can keep following on 
> this.
> 
> Philippe: could look into this
> 
> Ted: massimo-p3p-headers 
> <http://www.ietf.org/internet-drafts/draft-marchiori-w3c-p3p-header-01.txt> 
> from 2002
> 
> *ACTION:* Philippe to follow up on the p3p header registry [recorded in 
> http://www.w3.org/2005/08/15-ietf-w3c-irc]
> 
> Ted: I'll expect a new document coming up
> 
> 
>       next meeting
> 
> Dan: Leslie, can you chair?
> 
> Leslie: yes... before or after next IETF?
> 
> <DanC> November 6 - 11, 2005 64th IETF
> 
> <timbl_> ISWC week
> 
> Dan: before is my preference
> 
> <DanC> I'm generally available in Oct
> 
> Resolved: Monday, October 24, 3pm Boston time
> 
> Dan will book the bridge
> 
> *ACTION:* DanC to arrange bridge for Monday, October 24, 3pm [recorded 
> in http://www.w3.org/2005/08/15-ietf-w3c-irc]
> 
> 
>       file: URI scheme draft
> 
> ACTION: MJD to contact Paul H
> 
> Dan: I sent a mail to Martin asking about the status
> 
> Ted: Paul H. took the task of all uri in 1738. simple ones have been 
> done. the most difficult uri scheme to update in file:. Paul and Larry 
> Masinter agreed will jointly produce a document capturing the state of play.
> 
> *ACTION:* Philippe to check with Martin about the status of file: 
> [recorded in http://www.w3.org/2005/08/15-ietf-w3c-irc]
> 
> Ted: one thing for the TAG is to see if file: would be capable of 
> dealing IRIs, or to issue a new scheme
> 
> Tim: the confusion of creating two schemes would be even worth than the 
> current limitations?
> 
> Ted: possible not. [...] the right to do is to put together your 
> thoughts on it. going to native IRI at this stage would create surprises.
> 
> Dan: security issues that would help motive people to pay attention? a 
> combinaison of I18N and security issues.
> 
> John: since they're local, there is no significant issue.
> 
> Dan: my preference would be "file: is too weird. good luck" would make 
> lots of sense for the platform vendors to indicate how file: works on 
> their platforms.
> 
> Ted: it would be good if Philippe reviews the URI mailing list in May 
> this year ([email-masked] May 2005).
> 
> 
>       mailng list notices, archives in the W3C and IETF
> 
> Dan: they are some talks about cross mailing lists. automatic response 
> from W3C doesn't include IETF wordings. (noted by Larry)
> 
> Leslie: since it isn't currently an IETF activity, it may not be important.
> 
> Dan: I guess we can agree it's a good idea.
> 
> leslie: for IETF, it's kind of required. how useful is it to have cross 
> lists? W3C policy lacks the ability to confirm anytime I sent a message 
> to a list
> 
> Dan: I can send an enhancement request for that and see what happens
> 
> *ACTION:* DanC to ask for "ok to archive everything I send to list X" 
> enhancement to archive approval system [recorded in 
> http://www.w3.org/2005/08/15-ietf-w3c-irc]
> 
> Dan: we host webdav, correct?
> 
> Ted: yes. it would be useful if the mailing list response was including 
> the IETF wording but there is enough things going on that, if somebody 
> was behaving inappropriately, they would get a pointer. unlike uri. so 
> valuable for webdav, but not absoluty required.
> 
> *ACTION:* DanC to look into adding "note well..." notice to webdav, uri 
> lists [recorded in http://www.w3.org/2005/08/15-ietf-w3c-irc]
> 
> 
>       Remote UI BoF and Synchronized XML DOMs (FYI)
> 
>       notes from Raggett
>       <http://lists.w3.org/Archives/Public/public-ietf-w3c/2005Aug/0006.html>
> 
> Dan: Dave is doing cool stuff. He went to the IETF conf, and sent a 
> report of it.
> 
> Scott: right now, haven't gone anymore. questions around the scope: 
> narrowing it, better definition. before next IETF, new charter or new 
> BOF request. didn't hear anything since Paris.
> 
> Dan: what's the distance between RUI and VNC? VNC is bitmap.
> 
>     This working group will specify an open, platform-independent
>     method, the Widget Description Exchange Service, or WiDeX for use in
>     an IP-based network to convey initialisation
>     RUI/WIDEX Description and Charter
>     <http://www.softarmor.com/rui/description.html> (proposed)
> 
>     ...on what is appropriate for realising the DOM event capture/bubble
>     model in a distributed context, and what constraints are needed to
>     simplify protocol support for synchronizing DOM updates.
>     Dave's notes
>     <http://lists.w3.org/Archives/Public/public-ietf-w3c/2005Aug/0006.html>
> 
> Scott: important to distinguish between Dave's vision and Vlad's. Vlad's 
> vision is much simpler.
> 
> Dan: is there any deployment/implementation around this?
> 
> <timbl_> Is this designed to be collaborative editing (a la 
> subetheedit?, CSCW?)
> 
> Scott: yes, on the VNC side. dunno about WiDeX
> 
> Ted: the current draft is too empty so you can read anything into it.
> 
> [no action/resolution necessary]
> 
> 
>       Calendaring and Scheduling Standards Simplification (calsify)
>       (FYI), timezone registry
> 
>     * WG Action: Calendaring and Scheduling Standards Simplification
>       (calsify) (FYI)
>       <http://lists.osafoundation.org/pipermail/ietf-calsify/2005-July/000689.html>
> 
> Dan: calsify wg. possible timezones registry. individual submission Time 
> Zone Registry D. Royer 
> <http://ietfreport.isoc.org/idref/draft-royer-timezone-registry/>?
> 
> Ted: correct. it's not in the charter of the wg. too many layers of 
> politics to go into a charter.
> 
> Dan: Department of Energy is planning to change the daylight savings...
> 
> Ted: they may put it off an other year
> 
> Tim: having a timezone registry would be a good idea.
> 
> John: those timezones have political ramification. [book reference missed]
> 
> Tim: the other way to do it would be to have a vocabulary for publishing 
> the timezones. then countries or towns can publish their timezones at 
> well-known URIs.
> 
> <JcK> I didn't give a book ref, although I could look one up. The 10K 
> view is "mess" -- it can be done non-normatively, as Tim suggested, but 
> then you can't bind names to it
> 
> Ted: deeper problem is with repeating meeting, if timezone definition 
> changes in the middle of the iteration.
> 
> Tim: one idea would be to use a "latest version of the timezone" URI.
> 
> Ted: there is already one group of people documentating timezones. 
> moving it in the IETF wouldn't add anything trying to import the Olsen 
> database wouldn't useful enough.
> 
> Tim: then the question becomes how to liaise with them
> 
> [no action/resolution]
> 
> Tim: on calsify. does it mean that calsify is producing test data sets?
> 
> Ted: yes, if it goes on the formal track
> 
> <DanC> the word "test" doesn't occur in the calsify charter 
> Ted: did you guys were involved in the calconnect work?
> 
> Dan: yes, somehow
> 
> Ted: the basic idea is to extend the work done in calconnect
> 
> Tim: idea is to get the test data set to become as important as the spec
> 
> Dan: I was at the BOF and encouraged them to do test dvpt
> 
> <timbl_> http://www.calconnect.org/ioptesting.html
> 
> Dan: nobody in the wg is leading the dvpt of tests
> 
> 
>       URI guidelines last call extended to 31 Aug
> 
>     * draft-hansen-2717bis-2718bis-uri-guidelines
>       <http://ietfreport.isoc.org/idref/draft-hansen-2717bis-2718bis-uri-guidelines/>
> 
> Tim: would like to push the IESG on the value of the avaibility of tests 
> online
> 
> Dan: don't see any comment about the bad idea of creating new schemes
> 
> <DanC> DAV: in particular
> 
> Leslie: competing requirements? between not creating new schemes and 
> documenting what exists out there
> 
> Dan: we should bash vendors who create new schemes despite the 
> recommendation. I'm following up with Apple btw
> 
> <timbl_> daap:
> 
> *ACTION:* DanC to comment on URI guidelines about not doing DAV: again 
> [recorded in http://www.w3.org/2005/08/15-ietf-w3c-irc]
> 
> 
>       syndication trends: RSS/Atom
> 
>     * trends in syndication: Atom, media RSS, sitemaps, earth maps
>       <http://lists.w3.org/Archives/Public/public-ietf-w3c/2005Aug/0004.html>
> 
> 
> Scott: Atom 1.0 is still under IESG evaluation
> 
> Dan: Tim Bray meanwhile said to implement it.
> 
> Scott: that's safe at this stage
> 
> Dan: meanwhile Yahoo, Google, etc are announcing RSS extension for more 
> media
> 
> Dan: who is in charge of Atom pub?
> 
> Scott: me
> 
> 
>       GEOPRIV, privacy and VoIP
> 
> Dan: W3C has some privacy stuff (P3P). Last time I went to an IETF 
> meeting. geo stuff. impossible questions from technical perspective.
> 
> <DanC> "geo stuff" i.e. E911 and VoIP... if you hit 911 on your vonage 
> box, the emergency services folks need to know where you are in order to 
> send a medic. But exactly who else gets your location info?
> 
> Ted: geopriv has been slower than expected. it will be used in some 
> domains. for the 911 service, it's worked in ecrid?.
> 
> <DanC> (pdf-lo and such... I looked up all these acronyms while I was at 
> the MN IETF... I have notes somehwere...)
> 
> <DanC> geopriv notes 
> <http://swig.xmlhack.com/2005/03/09/2005-03-09.html#1110406874.932486>
> 
> [adjourned]
> 
> 
>     Summary of Action Items
> 
> *[NEW]* *ACTION:* DanC to arrange bridge for Monday, October 24, 3pm 
> [recorded in http://www.w3.org/2005/08/15-ietf-w3c-irc]
> *[NEW]* *ACTION:* DanC to ask for "ok to archive everything I send to 
> list X" enhancement to archive approval system [recorded in 
> http://www.w3.org/2005/08/15-ietf-w3c-irc]
> *[NEW]* *ACTION:* DanC to comment on URI guidelines about not doing DAV: 
> again [recorded in http://www.w3.org/2005/08/15-ietf-w3c-irc]
> *[NEW]* *ACTION:* DanC to look into adding "note well..." notice to 
> webdav, uri lists [recorded in http://www.w3.org/2005/08/15-ietf-w3c-irc]
> *[NEW]* *ACTION:* Philippe to check with Martin about the status of 
> file: [recorded in http://www.w3.org/2005/08/15-ietf-w3c-irc]
> *[NEW]* *ACTION:* Philippe to follow up on the p3p header registry 
> [recorded in http://www.w3.org/2005/08/15-ietf-w3c-irc]
>  
> [End of minutes]
> 
> ------------------------------------------------------------------------
> Minutes formatted by David Booth's scribe.perl 
> <http://dev.w3.org/cvsweb/~checkout~/2002/scribe/scribedoc.htm> version 
> 1.126 (CVS log <http://dev.w3.org/cvsweb/2002/scribe/>)
> $Date: 2005/08/17 15:26:17 $
>

---

From: Leslie Daigle <[email-masked]>
Date: Thu, 25 Aug 2005 16:10:37 -0400

BTW, when you/if you have post/ed these to that mailing
list, could you also send a copy here?

Thanks,
Leslie.

Leslie Daigle wrote:
>> from previous meeting 
>> <http://www.w3.org/2005/02/04-ietf-w3c-minutes.html>
>>
>> <Philippe> I'm w3c architecture domain lead, which means I'm 
>> responsible for XML, Web Services, I18N, DOM, and URI activities.
>>
>>
>> Ted: just finished the approval of the document. they are now in the 
>> RFC editors hands.
>>
>> Philippe: as far I understand, we're in sync. we're following the 
>> proper process
>>
>>
>>       P3P header registry
>>
>> Ted: didn't get contacted. if you still want the header, you should 
>> keep trying to register. If Philippe is interested, he can keep 
>> following on this.
>>
>> *ACTION:* Philippe to follow up on the p3p header registry [recorded 
>> Tim: the confusion of creating two schemes would be even worth than 
>> the current limitations?
>>
>> leslie: for IETF, it's kind of required. how useful is it to have 
>> cross lists? W3C policy lacks the ability to confirm anytime I sent a 
>> message to a list
>>
>> Ted: yes. it would be useful if the mailing list response was 
>> including the IETF wording but there is enough things going on that, 
>> if somebody was behaving inappropriately, they would get a pointer. 
>> unlike uri. so valuable for webdav, but not absoluty required.
>>
>> *ACTION:* DanC to look into adding "note well..." notice to webdav, 
>> uri lists [recorded in http://www.w3.org/2005/08/15-ietf-w3c-irc]
>>
>>
>> Scott: important to distinguish between Dave's vision and Vlad's. 
>> Vlad's vision is much simpler.
>>
>> Dan: calsify wg. possible timezones registry. individual submission 
>> Time Zone Registry D. Royer 
>> Tim: the other way to do it would be to have a vocabulary for 
>> publishing the timezones. then countries or towns can publish their 
>> timezones at well-known URIs.
>>
>> view is "mess" -- it can be done non-normatively, as Tim suggested, 
>> but then you can't bind names to it
>>
>> Tim: would like to push the IESG on the value of the avaibility of 
>> tests online
>>
>> Dan: meanwhile Yahoo, Google, etc are announcing RSS extension for 
>> more media
>>
>> box, the emergency services folks need to know where you are in order 
>> to send a medic. But exactly who else gets your location info?
>>
>> <DanC> (pdf-lo and such... I looked up all these acronyms while I was 
>> at the MN IETF... I have notes somehwere...)
>>
>> <DanC> geopriv notes 
>> *[NEW]* *ACTION:* DanC to comment on URI guidelines about not doing 
>> DAV: again [recorded in http://www.w3.org/2005/08/15-ietf-w3c-irc]
>> <http://dev.w3.org/cvsweb/~checkout~/2002/scribe/scribedoc.htm> 
>> version 1.126 (CVS log <http://dev.w3.org/cvsweb/2002/scribe/>)