Subject: FW: XML Patch and Xupdate?

From: "Scott Hollenbeck" <[email-masked]>
Date: Wed, 26 Oct 2005 06:26:13 -0400

Some info on the xmlpatch/xupdate question asked during this week's meeting,
sent by one of the people who has been working on the issue in the IETF.

-Scott-

> -----Original Message-----
> From: Jari Urpalainen [mailto:[email-masked]] 
> Sent: Wednesday, October 26, 2005 3:57 AM
> To: ext Scott Hollenbeck
> Cc: 'Ted Hardie'
> Subject: Re: XML Patch and Xupdate?
> 
> ext Scott Hollenbeck wrote:
> 
> >Jari,
> >
> >This came up yesterday during a call that I had with some W3C people:
> >
> >http://xmldb-org.sourceforge.net/xupdate
> >
> >They thought it might be useful with respect to the XML patch issue.
> >
> >-Scott-
> >
> >  
> >
> Hi Scott,
> Yes I am aware of it (and actually posted about it during the 
> initial phases of XCAP). There are a couple of "issues" with 
> it and my proposal is certainly partially overlapping with it 
> (so mine is yet another approach ;)). The number one 
> requirement for these patch operations was that it should 
> produce as short as possible payloads. Secondly, namespace 
> handling in element and attribute patching have to be 
> specified in the spec. Thirdly, it should be possible to 
> add/remove namespace nodes, because namespace usage in 
> current presence specs is horrible, imo. Why so ? Because 
> content model is based on W3C Schemas which has the infamous 
> UPA constraint, i.e. extension of presence is based on 
> "##other" namespace (instead of ##any which i should prefer 
> and ietf specs would reuse the existing namespace) (and yes 
> RELAX NG would be a much better tool to use in this case). 
> The fourth requirement was that these patch-operations should 
> be easily embedded onto any event package. The fifth one was 
> that i wanted a model that is as simple as possible (the less 
> the operations the better). Also preserving the canonical 
> format of the document was a primary issue. And also as not 
> to forget that I (still do although Jonathan may not) wanted 
> that this would be as compatible as possible with xcap-diff 
> (and used there too). 
> The overlapping of xcap-diff and partial pidf was the primary 
> reason for submitting the spec anyway. So maybe these issues 
> don't justify this i-d, but I am personally a strong promoter 
> of free stuff, that try to improve current situation.
> 
> Probably one comment still that one requirement was that it 
> should be easy to actually implement (which can be judged 
> based on the actual sources at sourceforge 
> <http://xmlpatch.sourceforge.net/>). In addition, I have made 
> up an online tool <http://validate.openlaboratory.net/patch/> 
> to illustrate the model. So there's still maybe some bugs, 
> but i am confident the model really works in practice.
> 
> Besides also a competive
> <*http://www.ietf.org/internet-drafts/draft-mouat-xml-patch-00.txt>
> *submission seems to have arrived. (there are also some 
> issues with it).
> 
> So is a chair still missing ? Personally I would like to 
> extend the discussions in the BoF to include also schema 
> validation issues (which is one clear problem).  So I am not 
> sure that we can have a reasonable discussion for the whole 
> hour for only this xml-patch issue (which can certainly be 
> solved with many ways, as of now i just want to finish 
> partial-pidf which seems to have lasted forever).
> 
>  thanks,
> Jari
>

---

From: Thomas Roessler <[email-masked]>
Date: Wed, 26 Oct 2005 12:32:25 +0200

Hi Scott,

thanks for this.

I'm forwarding your message to Dave Raggett so he can get directly
in touch with Jari.

Regards,
-- 
Thomas Roessler, W3C   <[email-masked]>

On 2005-10-26 06:26:13 -0400, Scott Hollenbeck wrote:
> From: Scott Hollenbeck <[email-masked]>
> To: [email-masked]
> Date: Wed, 26 Oct 2005 06:26:13 -0400
> Subject: FW: XML Patch and Xupdate?
> List-Id: Discussion of w3c-ietf policy issues <w3c-policy.apps.ietf.org>
> X-Spam-Level: 
>

---

From: Dave Raggett <[email-masked]>
Date: Thu, 27 Oct 2005 14:42:28 +0100 (BST)

> I'm forwarding your message to Dave Raggett so he can get directly

Thanks.

There is yet another related proposal by Robin Berjon who posted a 
draft spec to the W3C SVG working group on a means to serialize DOM 
Mutation operations to XML. I have pointed him at the Widex working 
group.

It looks like we will have an opportunity to flesh out the details 
for the requirements for update/mutation on the Widex mailing list.
Unfortunately, I won't be able to attend the Vancouver IETF, but
will do what I can via email.

- -- 
  Dave Raggett <[email-masked]>  W3C lead for multimodal interaction
  http://www.w3.org/People/Raggett +44 1225 866240 (or 867351)