Subject: Re: next W3C/IETF liaison meeting: Tue, 6 Jan

From: Dan Connolly <[email-masked]>
Date: Mon, 05 Jan 2009 14:51:55 -0600

The first looks like a technical issue; I'm happy to leave it to
other fora...

I'm adding the second one to our agenda.

On Sat, 2008-12-20 at 19:53 -0500, John C Klensin wrote:

> There are two separate topics associated with that work that
> might merit meeting time; I don't really have an opinion about
> whether we want to spend time on either right now or whether
> these calls are the best way to spend that time.
> 
> 	(1) One of the major changes between the older version
> 	of IDNA and this one is that the former supports
> 	extensive character mappings (effectively using Unicode
> 	NKFC and CaseFold, for those who are familiar with
> 	them).   The version in those drafts tries to work much
> 	closer to "the final form is the only form there is",
> 	with no mappings and complete symmetry between the
> 	internal "punycode" form of a label and the native
> 	character one.  We could discuss the transition issues,
> 	some of which have become controversial.

> 	(2) The other issue, only partially related to the
> 	mapping problem, is the "where are IRIs actually valid"
> 	discussion that affects HTTP and HTML5 as well as other
> 	things, possibly including email.   I did some writing
> 	on that several months ago, but then got distracted by
> 	various pressing issues and haven't gotten back to it.

> best wishes to all for the holidays and the new year.
> 
>  john
> 
> 
> 
-- 
Dan Connolly, W3C http://www.w3.org/People/Connolly/
gpg D3C2 887B 0F92 6005 C541  0875 0F91 96DE 6E52 C29E

---

From: Dan Connolly <[email-masked]>
Date: Mon, 05 Jan 2009 14:55:03 -0600

1. Convene, take roll, review agenda

Zakim telephone bridge
  code 4383 (IETF)
 tel:+1.617.761.6200
 tel:+33.4.89.06.34.99
 tel:+44.117.370.6152

irc://irc.w3.org:6665/ietf

Tue 6 Jan 16:00 Boston time. 60 to 90 minutes

expected:  Mark, tlr, Lisa D, Klensin, TimBL, Philippe, DanC,
  Noah Mendelsohn
invited: Mike Smith, Sam Ruby

scribe: tlr?
(reminder: minutes go public after a week of review
   by the participants )

2. Media Fragments [mnot]
 ACTION: Mark to contact the RAI Groups about the Media
    Fragment charter (from 10 Jun 2008 meeting; done?)

3. HTML5 work and review, esp. WebSockets [Lisa]
 note new co-chair, Sam Ruby
 http://lists.w3.org/Archives/Public/public-html/2008Dec/0145.html

 and a status update from Ian Hickson:
 http://www.whatwg.org/status-2008-12

4. "Origin Header for CSRF Mitigation" to IETF or W3C [DanC]

5. geolocation privacy [mnot]
  https://datatracker.ietf.org/liaison/486/

6. IDNAbis, where are IRIs actually valid? HTML, HTTP, ... [klensin]

-- 
Dan Connolly, W3C http://www.w3.org/People/Connolly/
gpg D3C2 887B 0F92 6005 C541  0875 0F91 96DE 6E52 C29E
office: tel:+1-617-395-0241
mobile: tel:+1-816-616-6576
mobile: mailto:[email-masked]

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 6 Jan 2009 10:45:15 -0500

>    Fragment charter (from 10 Jun 2008 meeting; done?)

Done.

--
Mark Nottingham     http://www.mnot.net/

---

From: Philippe Le Hegaret <[email-masked]>
Date: Tue, 06 Jan 2009 14:31:52 -0500

agenda+ New content coding for HTTP

 The EXI WG [1] would like to register a new content coding token for
HTTP. There is no known procedure for that.
 How should W3C proceed?

Philippe

[1] http://www.w3.org/XML/EXI/

---

From: Julian Reschke <[email-masked]>
Date: Tue, 06 Jan 2009 21:16:54 +0100

Hi Philippe,

right now there is no IANA registry for new content codings, thus no 
registration process.

I recommend following up on the HTTPbis WG's mailing list.

Best regards, Julian