Subject: Re: Requesting IESG Approval for the Media Type application/xslt+xml, application/xquery+xml, and application/xquery

From: Philippe Le Hegaret <[email-masked]>
Date: Tue, 09 Jun 2009 12:57:20 -0400

Hello Alexey,

I don't remember if I followed up on this so I'm sending the response to
your questions regarding XQuery media types.

On Mon, 2009-04-13 at 22:59 +0100, Alexey Melnikov wrote:
> After quickly checking registrations you've provided above, I have some 
> comments:
> 
> 1). application/xslt+xml registration looks fine to me.
> 2). application/xquery+xml seems fine to me. I think you have a cut & 
> paste error in section C.2.1 (XSLT should be XQueryX?)

Fixed in
 http://www.w3.org/TR/2009/PER-xqueryx-20090421/#xqueryx-mime-encoding

> 3). application/xquery is lacking the "Published specification" section. 

Fixed in

http://www.w3.org/TR/2009/PER-xquery-20090421/#id-published-specification

> Also "Intended usage" should have value "COMMON". Otherwise it looks Ok.

Fixed in
http://www.w3.org/TR/2009/PER-xquery-20090421/#id-intended-usage

On Mon, 2009-04-13 at 23:42 +0100, Alexey Melnikov wrote: 
> While you are doing this, can you also ask if application/xquery is 
> deliberately not allowing the optional 'charset' parameter?
> My understanding is that application/xquery is not XML, but I think it 
> can still benefit from the charset parameter

[From Liam Quin]
The choice of not having an optional charset parameter was deliberate.
application/xquery is indeed not XML. The cases were originally,
(1) the query does not specify an encoding => UTF-8
(2) the query specifies an encoding, and it's the same as
    a charset parameter => use it
(3) the query specifies an encoding, and the charset parameter
    gives a different one => error, or use the parameter
    in the document (the Working Group reached consensus on
    this after some careful analysis and discussion).

After doing this analysis we removed the charset parameter.
It's an application/* type, so a proxy must not rewrite it,
and we have demonstrated interoperability between e.g.
IBM systems running DB2 and PCs running Linux (and many
other systems), so we believe the status quo to be correct
for XQuery.

Philippe

---

From: Alexey Melnikov <[email-masked]>
Date: Wed, 17 Jun 2009 11:16:24 +0100

>Hello Alexey,
Hi Philippe,

>http://www.w3.org/TR/2009/PER-xquery-20090421/#id-intended-usage
These changes look fine. Thanks.

>    this after some careful analysis and discussion).
If the character encoding is fixed (e.g. always UTF-8), or can be 
algorithmically deducted from the payload, then I agree that the charset 
parameter is not needed.