Subject: Re: Requesting IESG Approval for the Media Type application/xslt+xml, application/xquery+xml, and application/xquery

From: Philippe Le Hegaret <[email-masked]>
Date: Thu, 10 Sep 2009 16:06:06 -0400

Hello Alexey,

I don't see the registration of those media types on the agenda of the
IESG:
 https://datatracker.ietf.org/iesg/agenda/

What is the next step to get those registered?

Thank you,

Philippe

On Wed, 2009-06-17 at 11:16 +0100, Alexey Melnikov wrote:
> Philippe Le Hegaret wrote:
> 
> >Hello Alexey,
> >
> Hi Philippe,
> 
> >I don't remember if I followed up on this so I'm sending the response to
> >your questions regarding XQuery media types.
> >
> >On Mon, 2009-04-13 at 22:59 +0100, Alexey Melnikov wrote:
> >  
> >
> >>After quickly checking registrations you've provided above, I have some 
> >>comments:
> >>
> >>1). application/xslt+xml registration looks fine to me.
> >>2). application/xquery+xml seems fine to me. I think you have a cut & 
> >>paste error in section C.2.1 (XSLT should be XQueryX?)
> >>    
> >>
> >Fixed in
> > http://www.w3.org/TR/2009/PER-xqueryx-20090421/#xqueryx-mime-encoding
> >  
> >
> >>3). application/xquery is lacking the "Published specification" section. 
> >>    
> >>
> >Fixed in
> >
> >http://www.w3.org/TR/2009/PER-xquery-20090421/#id-published-specification
> >  
> >
> >>Also "Intended usage" should have value "COMMON". Otherwise it looks Ok.
> >>    
> >>
> >Fixed in
> >http://www.w3.org/TR/2009/PER-xquery-20090421/#id-intended-usage
> >
> These changes look fine. Thanks.
> 
> >On Mon, 2009-04-13 at 23:42 +0100, Alexey Melnikov wrote: 
> >  
> >
> >>While you are doing this, can you also ask if application/xquery is 
> >>deliberately not allowing the optional 'charset' parameter?
> >>My understanding is that application/xquery is not XML, but I think it 
> >>can still benefit from the charset parameter
> >>    
> >>
> >[From Liam Quin]
> >The choice of not having an optional charset parameter was deliberate.
> >application/xquery is indeed not XML. The cases were originally,
> >(1) the query does not specify an encoding => UTF-8
> >(2) the query specifies an encoding, and it's the same as
> >    a charset parameter => use it
> >(3) the query specifies an encoding, and the charset parameter
> >    gives a different one => error, or use the parameter
> >    in the document (the Working Group reached consensus on
> >    this after some careful analysis and discussion).
> >
> If the character encoding is fixed (e.g. always UTF-8), or can be 
> algorithmically deducted from the payload, then I agree that the charset 
> parameter is not needed.
> 
> >After doing this analysis we removed the charset parameter.
> >It's an application/* type, so a proxy must not rewrite it,
> >and we have demonstrated interoperability between e.g.
> >IBM systems running DB2 and PCs running Linux (and many
> >other systems), so we believe the status quo to be correct
> >for XQuery.
> >  
> >
> 
>

---

From: Alexey Melnikov <[email-masked]>
Date: Thu, 10 Sep 2009 23:25:36 +0100

> https://datatracker.ietf.org/iesg/agenda/
Hi Philippe,
I didn't realize you wanted IESG to approve the updated registration.

>What is the next step to get those registered?
I can add this as a management item for the next IESG telechat. After 
the telechat I can tell you if there are any comments from IESG.

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 11 Sep 2009 09:48:48 +1000

Gentle reminder - this discussion should move to the public list.

Cheers,

--
Mark Nottingham     http://www.mnot.net/

---

From: Larry Masinter <[email-masked]>
Date: Wed, 16 Sep 2009 18:35:24 -0700

If you haven't seen it:

   http://lists.w3.org/Archives/Public/public-iri/2009Sep/0059.html

should have been cc'd to W3C/IETF liaison lists.

Larry
--
http://larry.masinter.net