Subject: DRAFT minutes

From: Mark Nottingham <[email-masked]>
Date: Wed, 3 Mar 2010 10:31:20 +1100

[ please correct at: <http://etherpad.com/YqDYKN0oHd>; I will publish to the public list in ~ 1 day ]

 W3C-IETF minutes, 2010-03-02

Attendees:

Peter Saint-Andre
Mark Nottingham
Salvatore Loreto
Alexey Melnikov
Lisa Dusseault
Thomas Roessler
Philippe Le Hegaret
Joe Hildebrand
Larry Masinter
Tim Berners-Lee
John Klensin

1. ISOC Donation
http://www.w3.org/2009/12/isocw3c-pr

plh: discussion has been going on for a while; ISOC is helping with organization structure discussion at W3C. Conversation with ISOC was also with their board; IETF chair was aware. Of course looking toward having stronger relationship with IETF as well.

2. Document license for specifications

Similar issues arose in the HyBi group. Significant issue at the W3 now.

2a. allowing content re-use / excerpting

2b can a spec be republished in whole, can derivatives be made?

Mark: suggest for this group the IETF trust's work in the space is most interesting
... we're at a point now where we allow excerpts and we allow limited
... re-use of portions of specs especially by other standards bodies
... believe we don't permit derivative works
... would be happy to be corrected
... commented that I'd like to see W3C's discussion harmonized with
... IETF trust work

plh: talking about that, too.
... opening license to permit re-use in code is something that has general consensus
... there'll of course be discussion about what license to adopt
... GPL compatible or something else
... but will also look at IETF trust

Mark: think core of the issue is -- external group starts work
... they bring it into std body
... std body becomes center of development
... some tensions
... has happened before
... that initial group trying to regain some control over spec

Larry: note RFC 1866 was in IETF

Joe Hildebrand: XMPP case
... Jabber community brought the protocol to the IETF
... but significant discussion about change control at the BOF
... though publish HTML versions, they have RFC number
... or I-D name on them, even though they're republished

3. hybi / websockets

Joe: situation seems more murky publicly than it is
... working with Ian, W3C folks in Hiroshima
... consensus-based approach within IETF for
... protocol work associated with websockets
... friction as the WG started
... OMG change control with IETF
... it's not a big problem as things turn out
... the IETF piece -- hybi -- is very straight-forward
... to get the interested parties from WhatWG involved
... work closely with them to make sure API work can
... track API work effectively
... want there to be clear understanding that full
... change control rests with hybi WG
... even though it's made up of WhatWG folks, W3C folks, 
... others, long-time IETFers

Joe: have req document
... draft-loreto-hybi-requirements (http://tools.ietf.org/html/draft-loreto-hybi-requirements)
... will change into draft-ietf-hybi-requirements... after Anaheim
... interesting and useful discussion on the mailing list
... what do we have to design around etc etc (http://www.ietf.org/id/draft-loreto-design-space-bidirectional-00.txt)
... that will be getting another editor  by the time it goes to draft-ietf
... protocol draft has Ian's name on it
... working through reqs before it becomes IETF draft
... intent is to have Ian as editor for that document for the time being

Peter: editor is appointed position; suggested candidates useful to have

joe: we were clear that editors' role is to write down WG consensus

plh: will people contribute text to IETF or WhatWG too?

joe: this draft will be an IETF document, contributions covered by Note Well
... IETF rules will apply
... no problem with republishing the same thing that's in the canonical location

4. IRI WG

Larry:
... first meeting scheduled in Anaheim on Friday, March 26
... has been interaction with W3 and Unicode people
... on target to make good progress
... had a good conversation with Martin Dürst
... major issue is avoiding security impact
... approach: reference controversial topics in separate documents
... main document: protocol and processing rules, to be referenced by other specs
... need to make sure all the best practices are understood and finished

Thomas: I would like to understand the scope of the work better

Larry: iri-bis document has a reasonable definition of the scope

Thomas: do you envision this group getting down to the level of individual character sets? note work on language-specific registration guidelines.

Larry: currently the document does go down to that level with regard to registration and processing -- goal is to take things currently in the IRI document that goes into details about that, to change those to pointers to other documents instead.... removing the dependencies and overlaps.

Thomas: suggest talking with Harald Alvestrand and Thomas Narten

Larry: goal is not to have another committee that is working in this space, but refer to work output of other groups

John: there is a lot of confusion about what is and is not valid in various scenarios (just an observation)

Larry: idea is to separate 'validity' and 'advisability' and make 'validity' match what people actually implement, and advisibility something that can evolve.

Coordination issue: whether HTML WG will accept change to point to IRI document hasn't been decided.

Alexey: we are looking for a W3 co-chair for the IRI WG

5. web security

Recent web-security list has been reasonably active.
http://lists.w3.org/Archives/Public/public-web-security/

Thomas:
... not much discussion about origin header since the beginning of the year

Mark:
... there has been discussion on the httpbis list
... Adam might not know that he might need to put more energy into the IETF work (?)
... some natural reluctance in httpbis to tackle the origin header topic

ACTION: thomas to ping Adam on Origin header

Thomas:
... some discussion about getting a security review on HTML5, but needs to be restarted

Mark:
... security policy -- any motion?

Thomas:
... not really, but a bit of implementation work

Thomas:
... good work and progress on cross-origin resource sharing
... http://www.w3.org/TR/cors/
... see also http://www.w3.org/TR/2010/WD-UMP-20100126/

Larry: The Geolocation/Geopriv question / wrt Device APIs and Privacy (DAP), was there closure on privacy issues? Should avoid a similar dustup as happened then.

Thomas: TAG feedback was that this wasn't necessarily a good approach
... summary of DAP work...
... security issues here are hard
... process / coordination issues might be challenging

Larry: perhaps asking for early reviews would be helpful

6. link header / registry

Mark:
... link draft has been through its second Last Call, in front of the IESG
... have also been working with HTML5 group so that they can use the same registry
... this will be good for consistency across technologies / applications
... Julian is the document shepherd

Peter: do we need an expert reviewer for registry submissions?

Lisa: Mark, I put in your name with the IANA :)

Mark: backup would be nice because turnaround times are fairly tight

https://datatracker.ietf.org/doc/draft-nottingham-http-link-header/

7. XML Signature 1.1 Last Call

Thomas:
... 1.1 adds more algorithms, upgrades some algos (e.g., SHA-1 to SHA-2*), etc
... Last Call was announced to SAAG list; this one lasts till 18 March
... it looks like there'll be another (short) one
... there will also be XML Encryption 1.1 along similar lines, will take a few more months
... btw, original document was 2001 and copyright ISOC & W3C
... should the new document be copyright IETF Trust & W3C?

http://www.w3.org/TR/xmldsig-core1/
http://www.w3.org/TR/xmlenc-core1/

John: yes, old documents were moved wholesale to the IETF Trust

ACTION: Mark to raise for review again

8. Calendar and Contact formats

Mark:
... there was a question regarding HTML5 and vCards

Thomas:
... device apis wg is specifying formats for contacts, calendars, etc.
... for contacts, wg was moving to defining a "common subset" of vCard and portable contacts
... for calendar, also have looked at subsetting
... is there a high-level approach to this kind of subsetting at W3 and IETF?

Alexey: possible to have a short presentation about this in Anaheim at the vcarddav WG?

datetime: vcarddav = WEDNESDAY, March 24, 2010 @ 0900-1015 Pacific Time

Larry http://lists.w3.org/Archives/Public/public-ietf-w3c/2010Jan/0001.html suggests technical approach focus on interoperability of APIs and protocols. 

Lisa: "subsetting happens"
Larry: subsetting by copy & chop has different coordination problems than subsetting by identifying profile.

http://www.w3.org/Submission/2010/SUBM-vcard-rdf-20100120/ "Representing vCard Objects in RDF"

ACTION: Thomas to see if DAP WG members could be available at IETF Anaheim
 IETF Vcarddav WG is meeting on WEDNESDAY, March 24, 2010 at 9:00am
ACTION: Mark to bring this up to relevant IETF WGs again

http://www.w3.org/2009/dap/ (Working Group home page)
http://www.w3.org/TR/contacts-api/ (WD)
http://dev.w3.org/2009/dap/calendar/ (Editor's draft)

Thomas:
... if a subset has stood the test of time and implementation, perhaps a better starting point

9. text/html MIME type registration

Larry: 
... this is a complicated issue
... one aspect: what are the requirements for re-registration?
... is it OK for the new registration to make old conforming implementations non-conformant?
... who can be "change controller"

Alexey:
... suggestion that new registration be owned by W3C and WHATWG, discussed in IESG and agreement that we need one owner

Mark: owner is currently W3C

10. protocol work bouncing back and forth between W3C and IETF (mime sniff, origin header, also hybi)

Larry: 
... I see documents without homes going back and forth
... maybe we should just bring these up on coordination calls
... current concern is the mime sniffing document -- how are we going to bring it to conclusion?  General category is "protocol work in W3C" or "W3C work which overlaps IETF work" being moved into internet drafts which then have no clear home.

Larry: for mimesniff, after talking to Lisa, i sent comments to apps-discuss.

ACTION: Mark to see if Adam is going to Anaheim, consider discussing mime-sniff

11. W3C registration of new URI schemes (widget: first case?)

Larry: 
... first W3C attempt to register a permanent URI scheme, no precedent here
... probably needs to be W3C advice on how to register URI schemes
This isn't a big deal, but some process clarity would be helpful, don't think this needs much work, but a little.

ACTION: PLH to follow up on URI scheme registration in W3C

12. Future meetings

Mark: perhaps have another meeting after IETF 77? Mid to late April?

PLH: Mid-April seems reasonable

--
Mark Nottingham     http://www.mnot.net/

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 02 Mar 2010 16:49:56 -0700

> [ please correct at: <http://etherpad.com/YqDYKN0oHd>; I will publish to the public list in ~ 1 day ]

I made some edits at etherpad through section 3. Out of time for now.

/psa

---

From: Peter Saint-Andre <[email-masked]>
Date: Thu, 04 Mar 2010 10:04:49 -0700

> [ please correct at: <http://etherpad.com/YqDYKN0oHd>; I will publish to the public list in ~ 1 day ]

Hi Mark, I made a few more edits at the etherpad page. I'm done now.

Peter

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 5 Mar 2010 10:01:47 +1100

Minutes were sent to the public list yesterday (my time), so a bit too late. Feel free to correct them there if necessary.

Regards,