Subject: Draft minutes: 21-04-2011 IETF/W3C Liaison Call

From: Mark Nottingham <[email-masked]>
Date: Thu, 21 Apr 2011 23:54:11 +1000

Joint W3C/IETF Conference Call -  2011-04-21

Mark Nottingham (IETF liaison)
Philippe Le Hegaret (W3C)
Alissa Cooper (IAB)
Peter Saint-Andre (Apps AD)
Pete Resnick (Apps AD)
Russ Housley (IETF chair)
John Klensin (usual suspect)
Sean Turner (Sec AD)
Stephen Farrell (Sec AD)
Gonzalo Camarillo (RAI AD)
Robert Sparks (RAI AD)
Thomas Roessler (W3C)
Hannes Tschofenig (IAB)
Alexey Melnikov

Regrets from TimBl

1) RTCWeb

Work is proceeding on chartering WGs in both the IETF and the W3C. Harald has indicated that he'll be chairing only one of the WGs; most likely the W3C, while still participating in the IETF effort.

2) Do Not Track

W3C has released a draft agenda; will be updating soon. Large number of attendees. Should be about 80 people. 

Alissa, Hannes, Peter Saint-Andre will be attending. W3C will have Thomas, Rigo, Jeff.

3) Web Security efforts

W3C is getting closer to chartering a WG.

4) HTTP Authentication

Low-level chatter is happening re: new auth schemes; Prague Bar BoF. Upcoming W3C workshop on Identity in the Browser.

Peter: Has been some discussion in the OAuth WG WRT HMAC. Discussion of using that as a generic HTTP authentication scheme. 

Thomas: Any news on the WOES work (side meeting)?

Sean: In the process of getting them to do something. 

Peter: May be a BoF in Quebec City.

5) HYBI / WebSockets

Discussion in Prague about alignment between I-D and API document.
Mark is concerned about coordination (protocol at IETF and API at W3C).
Not sure if cultural or other issues.
Philippe: In general, need to poke the WebApps WG to get input.
Mark: Want to avoid misaligment so need to 
Peter: Work going on currently; should be a new draft out tomorrow that closes issues. That version should be appropriate for use as a basis for additional coordination. 

Recently published WD of API: http://www.w3.org/TR/2011/WD-websockets-20110419/

6) IRI WG

Peter: We've had some discussions in Prague, that we need to finish to meet HTML5 deadlines. Going to have a call right after this to figure out a plan of action. I'll name another Co-Chair; we've reached out to browser vendors and some will be participating (e.g., from Mozilla, Microsoft, Chrome). Thomas has been helping. Now we need to work through the open issues and triage. Some issues are minor, some are philosophical, some are actual developer issues. 

Thomas: The other important thing is the distribution of concerns between draft-abarth-uri and draft-iri-bis. 

Peter: From the HTML5 perspective, will they be referencing both specs?

PLH: The WG is trying to freeze their first version of HTML5 for LC; don't expect significant changes between now and the end of May. After that, we have an issue related to IRIs, and if there's new information, the Chairs will be happy to reopen it. 

Thomas: I believe that draft-abarth is intended to be suitable as a reference that's capable of filling in the missing bits. 

John: Is the call in 25 minutes a design team call, a WG call, or a WG call disguised as a design team call to get around the rules?

Peter: Officially it's a design team call. Really, it's an organisational call to figure out who's willing to do work, what work needs to be done, etc.

7) about: URI scheme

Peter: We've had ongoing discussion about about: uris. There's a question about what the status of the document and who the contacts should be. If it's Proposed Standard, the change controller should be IESG. 

Mark: Who's driving this work?

Alexey: I'm now document shepherd. Original editors are from Opera. Also reviewed by Microsoft guys. 

ACTION: Mark to review about URI scheme I-D.

Alexey: Venue for discussion is apps-discuss, send FYI to URI list.

8) Registries

Mark: Discussions in Prague about making IANA registries more user-friendly.
Mark: Web communities starting to require more interaction with IANA, pushback from those folks that it's too hard or cumbersome or slow.

9) Heads up on rfc3536bis (internationalization terminology)

John: RFC3536bis by Paul Hoffman WRT i18n terminology; I'll send mail to the list when the draft name settles down; we'd like feedback.  Current working version is draft-hoffman-3536bis-01; successor may be draft-ietf-appsawg-3536bis-00.   Watch for email.

10) eG8 meeting

Thomas: Wondering if IAB, others have views / opinions about EG8 in Paris.

11) Next call

Thomas: May is busy; suggest June 9, or week of June 13 (but TimBL will be hard to get that week). 

ACTION: Mark to send doodle poll. 

--
Mark Nottingham   http://www.mnot.net/

---

From: Alexey Melnikov <[email-masked]>
Date: Thu, 21 Apr 2011 21:42:58 +0100

>Peter: We've had ongoing discussion about about: uris. There's a question about what the status of the document and who the contacts should be. If it's Proposed Standard, the change controller shoul…
I think this might need some clarification: there is a requirement in 
the URI registration RFC that URI registrations on Standards Track are 
"owned" by IESG. But even independently of this requirement, "Change 
Controller: IESG" guaranties that if the definition is updated, then it 
is also on Standards Track.