Subject: next W3C/IETF liaison call - call for agenda items

From: Thomas Roessler <[email-masked]>
Date: Wed, 23 Nov 2011 18:08:01 +0100

As the next IETF/W3C liaison call comes up…

Obvious items:

- webappsec has started successfully at W3C
- IRI/URL discussion at HTML5 WG meeting (Peter)
- change of W3C team contact on WebRTC (FYI)
- proposed document about mutual review expectations

Do we need to follow up on some of the recent apps-discuss and happiana conversations about font/* and related topics?

What else am I missing?  Any particular news from Taipei?
--
Thomas Roessler, W3C  <[email-masked]>  (@roessler)

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 23 Nov 2011 17:59:43 +0000

> What else am I missing?  Any particular news from Taipei?

crypto api in w3c?

S

> --
> Thomas Roessler, W3C<[email-masked]>   (@roessler)
>
>
>
>
>
>
>

---

From: Julian Reschke <[email-masked]>
Date: Sat, 26 Nov 2011 15:08:48 +0100

On 2011-11-23 18:08, Thomas Roessler wrote:
> ...

The topic raised by Björn H. in 
<http://lists.w3.org/Archives/Public/www-archive/2011Nov/0047.html> 
might qualify (a case where the specs require that the charset parameter 
be ignored in one case, but respected on other cases; this seems be an 
extremely dumb thing to do).

Best regards, Julian

---

From: Thomas Roessler <[email-masked]>
Date: Mon, 28 Nov 2011 12:10:43 +0100

> - proposed document about mutual review expectations

- geolocation level 2 FPWD and LC coming up: http://dev.w3.org/geo/api/spec-source-v2 

(Matt, is that published yet?)

---

From: John C Klensin <[email-masked]>
Date: Mon, 28 Nov 2011 12:35:47 -0500

--On Saturday, November 26, 2011 15:08 +0100 Julian Reschke
<[email-masked]> wrote:

> <http://lists.w3.org/Archives/Public/www-archive/2011Nov/0047.
> html> might qualify (a case where the specs require that the
> charset parameter be ignored in one case, but respected on
> other cases; this seems be an extremely dumb thing to do).

Agree with the "extremely dumb" part.  But isn't this part of
the general problem of erratic (and poor) support for Media Type
parameters in many browsers?  See the recent (and perhaps not
much less dumb) discussion of text/lp and alternatives on the
IETF list for another example.

Also, I don't know what to do about it or if a discussion on
this call would help, but it seems to me that the IRI effort is
heading for a train wreck.  Trying to avoid the actual technical
issues, the symptoms appear to be:

	-- Efforts to resolve disputes by splitting the work
	into multiple documents, possibly with forum-shopping
	between IETF and W3C.
	
	-- Confusion about whether IRIs are still a presentation
	form to be  encoded into URIs or are protocol forms
	themselves, either independent of the URI spec or an
	excuse to retroactively modify the URI spec.  And, if
	they are a presentation form, whether the presentation
	(and associated localization) issues are under control
	or whether important issues are being swept under the
	nearest rug.
	
	-- If IRIs are really a protocol form with their own
	rules, is the right solution to continue to pile
	epicycles and pixie dust on top of the extended
	historical (left to right and mostly ASCII) URL/URI
	model or should we be looking at. e.g., something with
	obvious and well-defined structure (rather than
	heuristics and per-Scheme variations).
	
	-- A bunch of rough edges around fields that require
	special treatment, notably strings that might be IDNs
	but whose resolution context is unknown.
	
And so on.

      john

---

From: Julian Reschke <[email-masked]>
Date: Mon, 28 Nov 2011 19:06:17 +0100

> IETF list for another example.

Well, browsers may be weak in handling parameters *other* then 
"charset", but *this* problem is about "charset".

Best regards, Julian