Subject: [Webtransport] Standards for protocol headers?

From: Scott Morgan <[email-masked]>
Date: Wed, 10 Jun 2020 19:14:49 -0500

Hi All,

   I have been working with JSON, XML and some protocol headers recently
and I am wondering...
Why are there no real standard text formats for protocol headers, or am I
missing something?

It seems to me that a slightly more streamlined/optimal binary/markup
standard could help protocols attain POCs and adoption much quicker and
help reduce some of the work defining protocols.

Any thoughts on this topic?

-- 
Regards,
Scott Morgan
President & CEO
Adligo Inc
http://www.adligo.com
https://www.linkedin.com/in/scott-morgan-21739415
A+ Better Business Bureau Rating
<https://www.bbb.org/chicago/business-reviews/computer-software-publishers-and-developers/adligo-inc-in-chicago-il-88381256>
https://github.com/adligo

By Appointment Only:
1-866-968-1893 Ex 101
[email-masked]
skype:adligo1?call
Send Me Files Securely:
*https://www.sendthisfile.com/f.jsp?id=ewOnyeFQM18IDRf7MMIdolfI
<https://www.sendthisfile.com/f.jsp?id=ewOnyeFQM18IDRf7MMIdolfI>*

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Thu, 11 Jun 2020 05:53:08 -0700

Hi,

> Any thoughts on this topic?

Can you please elaborate on what you mean by "protocol header"?  My understanding of that term is the fixed part at the beginning of a PDU, PDU that also contains a variable length part after it (as in UDP Header, TCP Header, RTP Header, HTTP, SIP, SMTP etc...), but that definition does not seem to apply to JSON or XML (as a whole).

-- 
Marc Petit-Huguenin
Email: [email-masked]
Blog: https://marc.petit-huguenin.org
Profile: https://www.linkedin.com/in/petithug

---

From: Scott Morgan <[email-masked]>
Date: Fri, 12 Jun 2020 09:25:26 -0500

Hi Marc,

   Thanks for responding!  I meant 'protocol header' in the broadest
sense.  I have implemented some protocols in the past (Web Socket v13, SMTP
etc) and work a lot with JSON and XML as I mentioned previously.  Here are
some general frustrations (i.e. problem statement) that I'm looking to
overcome;

1) JSON and XML generally lack support for binary data (there are some
workarounds but nothing is super great).
2) JSON and XML both now have the concept of a Schema
         Note I think the concept of a Schema is a good thing but also feel
that Schemas often don't cover all
     Metadata that needs to be covered.  Perhaps the concept of a Schema
needs to be enhanced by UsageMetadata information.
         Also note I am frustrated with JSON's inability to provide human
readable schemas (multi line text in the .json file (not /n)).
         I also have frustrations with XML schemas and XML (like everyone
else who now favors JSON over XML)
3) Protocol's often have Headers and other information which act in a
similar fashion to Schemas (i.e. they describe / specify data structures)

  I'm wondering if it's time for a new markup language that can support
binary data and assist in specifying protocol byte segments in addition to
more general purpose transport and storage data (like JSON & XML do).
  I'm thinking about calling it 'Classification Markup Notation'.

  I messaged this to the group just to throw the idea out there, to get
feedback and also to find collaborators.

On Thu, Jun 11, 2020 at 7:53 AM Marc Petit-Huguenin <[email-masked]>
wrote:

> Can you please elaborate on what you mean by "protocol header"?  My
> understanding of that term is the fixed part at the beginning of a PDU, PDU
> that also contains a variable length part after it (as in UDP Header, TCP
> Header, RTP Header, HTTP, SIP, SMTP etc...), but that definition does not
> seem to apply to JSON or XML (as a whole).
>
> --
> Marc Petit-Huguenin

By Appointment Only:
1-866-968-1893 Ex 101
[email-masked]
skype:adligo1?call
Send Me Files Securely:

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Fri, 12 Jun 2020 08:03:01 -0700

Hi Scott,

I still find your terminology confusing.  I am not sure if you are proposing to design a new PDU description language (ala ASN.1, ABNF, RBNF, CDDL, XML RELAX, etc..) or a new structured PDU format (ala DER, BER, XML, JSON, CBOR, etc...).  If it is the former, I would suggest to resend your email to [email-masked], where we discuss this kind of things.

Thanks.

---

From: Scott Morgan <[email-masked]>
Date: Fri, 12 Jun 2020 19:53:04 -0500

Hi Marc,

   Thanks, I'm not trying to be intentionally confusing :)  In an attempt
to clarify, I'm trying to create a new structured PDU format that could be
used to define PDU description languages (not a primary concern) as well as
larger data structures like files or bytes in datagrams.
https://en.wikipedia.org/wiki/Protocol_data_unit

Lets continue @ [email-masked] !

Cheers,
Scott

---------- Forwarded message ---------
From: Marc Petit-Huguenin <[email-masked]>
Date: Fri, Jun 12, 2020 at 10:03 AM
Subject: Re: [Webtransport] Standards for protocol headers?
To: Scott Morgan <[email-masked]>, <[email-masked]>

Hi Scott,

I still find your terminology confusing.  I am not sure if you are
proposing to design a new PDU description language (ala ASN.1, ABNF, RBNF,
CDDL, XML RELAX, etc..) or a new structured PDU format (ala DER, BER, XML,
JSON, CBOR, etc...).  If it is the former, I would suggest to resend your
email to [email-masked], where we discuss this kind of things.

Thanks.

By Appointment Only:
1-866-968-1893 Ex 101
[email-masked]
skype:adligo1?call
Send Me Files Securely:

---

From: Stephen McQuistin <[email-masked]>
Date: Sat, 13 Jun 2020 12:07:55 +0000

Hi Scott,

We have a draft (draft-mcquistin-augmented-ascii-diagrams) that is looking to add tooling (e.g., to generate parser code) around “traditional” packet header diagrams, by using a consistent format for both the diagram and the text that accompanies it.

In terms of other PDU description languages, the recent QUIC drafts have replaced packet diagrams with a bespoke description language: https://tools.ietf.org/html/draft-ietf-quic-transport-29#section-1.3.

These are both much simpler than the languages that Marc mentioned, and only deal with PDU description rather than data layout description more generally, but might be worth a look.

Thanks,

Stephen

On 13 Jun 2020, at 01:53, Scott Morgan <[email-masked]<mailto:[email-masked]>> wrote:

Hi Marc,

   Thanks, I'm not trying to be intentionally confusing :)  In an attempt to clarify, I'm trying to create a new structured PDU format that could be used to define PDU description languages (not a primary concern) as well as larger data structures like files or bytes in datagrams.
https://en.wikipedia.org/wiki/Protocol_data_unit

Lets continue @ [email-masked]<mailto:[email-masked]> !

Cheers,
Scott

---------- Forwarded message ---------
From: Marc Petit-Huguenin <[email-masked]<mailto:[email-masked]>>
Date: Fri, Jun 12, 2020 at 10:03 AM
Subject: Re: [Webtransport] Standards for protocol headers?
To: Scott Morgan <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>

Hi Scott,

I still find your terminology confusing.  I am not sure if you are proposing to design a new PDU description language (ala ASN.1, ABNF, RBNF, CDDL, XML RELAX, etc..) or a new structured PDU format (ala DER, BER, XML, JSON, CBOR, etc...).  If it is the former, I would suggest to resend your email to [email-masked]<mailto:[email-masked]>, where we discuss this kind of things.

Thanks.

On 6/12/20 7:25 AM, Scott Morgan wrote:
> On Thu, Jun 11, 2020 at 7:53 AM Marc Petit-Huguenin <[email-masked]<mailto:[email-masked]>>
> wrote:
>
>> Hi,
>>

--
Marc Petit-Huguenin
Email: [email-masked]<mailto:[email-masked]>
Blog: https://marc.petit-huguenin.org<https://marc.petit-huguenin.org/>
Profile: https://www.linkedin.com/in/petithug

--
Regards,
Scott Morgan
President & CEO
Adligo Inc
http://www.adligo.com<http://www.adligo.com/>
https://www.linkedin.com/in/scott-morgan-21739415
A+ Better Business Bureau Rating<https://www.bbb.org/chicago/business-reviews/computer-software-publishers-and-developers/adligo-inc-in-chicago-il-88381256>
https://github.com/adligo

By Appointment Only:
1-866-968-1893 Ex 101
[email-masked]<mailto:[email-masked]>
skype:adligo1?call
Send Me Files Securely:
https://www.sendthisfile.com/f.jsp?id=ewOnyeFQM18IDRf7MMIdolfI

<signature.asc>--
FDT mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/fdt

---

From: Patrick McManus <[email-masked]>
Date: Mon, 15 Jun 2020 14:53:45 -0400

you might be interested in structured field values for http
https://datatracker.ietf.org/doc/draft-ietf-httpbis-header-structure/

-P

On Sat, Jun 13, 2020 at 8:08 AM Stephen McQuistin <
[email-masked]> wrote:

> Hi Scott,
>
> We have a draft (draft-mcquistin-augmented-ascii-diagrams) that is looking
> to add tooling (e.g., to generate parser code) around “traditional” packet
> header diagrams, by using a consistent format for both the diagram and the
> text that accompanies it.
>
> In terms of other PDU description languages, the recent QUIC drafts have
> replaced packet diagrams with a bespoke description language:
> https://tools.ietf.org/html/draft-ietf-quic-transport-29#section-1.3.
>
> These are both much simpler than the languages that Marc mentioned, and
> only deal with PDU description rather than data layout description more
> generally, but might be worth a look.
>
> Thanks,
>
> Stephen
>
> On 13 Jun 2020, at 01:53, Scott Morgan <[email-masked]> wrote:
>
> Hi Marc,
>
> [email-masked]
> Webtransport mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/webtransport
>