Subject: [Webtransport] CDN support

From: Mark Nottingham <[email-masked]>
Date: Mon, 16 Nov 2020 20:46:52 +1100

[ Since meetecho seemed to be having problems (I can't get back into the meeting, and jabber seems to be perma-segmented), I'll say what I queued for here ]

I see that there are questions as to whether CDNs will support WebTransport.

It's important to understand that from a CDN's perspective, WebTransport is very similar to WebSockets. If by 'support' you mean 'proxy connections 1:1, and maybe do some access control and routing on them' -- yes, CDNs can support WebTransport (whether they will is of course a different question).

However, if you want something more sophisticated, like caching or fanout of messages, WebTransport doesn't provide anything for a CDN to "grab onto", in terms of message delimitation or semantics.

When WebSockets was created, the assumption was that a 'thousand flowers would bloom' and eventually the market would choose a few winners, and infrastructure could focus on optimising that. That hasn't happened in the intervening decade+. I have a few suspicions as to why, but that's probably a separate discussion.

So it would be very good if folks who are asking for CDN support to be super-specific about what they want, and also to be realistic about what they're likely to get. The bargain of WebTransport is that it's a protocol construction toolkit -- just like WebSockets -- where you build everything yourself. You can't have it both ways, unless someone does the work to build the semantic 'handles' on top of it in a way that infrastructure can use -- and once you start doing that, you might find yourself re-inventing HTTP.

Cheers,

--
Mark Nottingham   https://www.mnot.net/

---

From: Lucas Pardue <[email-masked]>
Date: Mon, 16 Nov 2020 10:05:53 +0000

+1

---

From: Luke Curley <[email-masked]>
Date: Mon, 16 Nov 2020 02:10:27 -0800

Yeah, there might be a misconception that HTTP == CDN support. All of the
WebTransport protocols are equally difficult for CDNs to support as they
are designed for 1:1 sessions and have no caching/fanout semantics like
HTTP.

On Mon, Nov 16, 2020 at 2:06 AM Lucas Pardue <[email-masked]>
wrote:

> +1
> --
> Webtransport mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/webtransport
>