Subject: Re: [Webtransport] Confirming Consensus on WebTransport protocols

From: David Schinazi <[email-masked]>
Date: Mon, 15 Feb 2021 13:34:43 -0800

Hi everyone,

In the last 2.5 weeks of the adoption call, the chairs received
multiple indications of support, and no objections. We therefore
declare consensus: draft-vvv-webtransport-http3 has now been
adopted by the WEBTRANS WG.

The chairs will work with the author to move the GitHub
repository under our WG organization.

Thanks,
David

On Wed, Jan 27, 2021 at 4:16 PM David Schinazi <[email-masked]>
wrote:

> Hi WebTransport enthusiasts,
>
> This consensus is now confirmed: for the foreseeable future,
> the WEBTRANS working group will focus on building a single
> UDP-based protocol for WebTransport, and that protocol will
> run atop HTTP/3.
>
> Our next step is to adopt a document that matches this
> description. The only matching proposal that has been
> discussed on this list so far is Victor's
> "WebTransport over HTTP/3" individual draft:
> https://tools.ietf.org/html/draft-vvv-webtransport-http3
>
> We are therefore placing this document in a call for adoption.
>
> Please reply to this email stating whether you support adoption
> of draft-vvv-webtransport-http3 by the WEBTRANS WG. Note
> that WG adoption does not indicate consensus on the contents
> of the document, only that it's a reasonable starting point for
> us to start working on. As such, please DO NOT send comments
> about the technical details of the draft on this email thread - please
> create a separate email thread on <[email-masked]> or open
> a GitHub issue at <https://github.com/vasilvv/webtransport/issues>.
>
> As usual, if you believe that we should not adopt this document,
> please state why. In our last meeting we've noted some concerns
> around pooling for example, and we plan on discussing those as
> a working group once the document is adopted.
>
> This adoption call will last for two weeks until 2021-02-10.
>
> Thanks,
> David
>
> On Tue, Jan 12, 2021 at 9:25 AM David Schinazi <[email-masked]>
> wrote:
>
>> Hi WebTransport enthusiasts,
>>
>> Today we had an interim of the IETF WEBTRANS WG,
>> where we reached consensus in the (virtual) room on
>> the following questions:
>>
>> Question 1: number of protocols
>>     Should the working group adopt only one UDP-based transport?
>>     1A: only one transport (QUIC or HTTP/3)
>>     1B: multiple transports (QUIC and HTTP/3)
>>
>> The consensus was option 1A.
>>
>> Additionally, we noted that this does not preclude us from
>> building a second protocol at a later date if new information
>> emerges.
>>
>> Question 2: UDP-based protocols
>>     Which UDP-based option should we adopt as a starting
>>     point for WebTransport protocol?
>>     2A: WebTransport over HTTP/3
>>     2B: WebTransport over QUIC directly (separate ALPN)
>>
>> The consensus was option 2A.
>>
>> Additionally, we discussed pooling and decided that we would
>> not allow pooling in WebTransport over HTTP/3 for now, due
>> to the complexities of pooling.
>>
>> We'd like to confirm this consensus on the list. If you disagree
>> with these points, please reply on the list. If you do so, please
>> state how strongly you feel - whether you are expressing a
>> preference, or an imperative. Please also provide as much
>> detail as possible to explain your position. Please also respond
>> if you support this consensus - a simple "I support this consensus"
>> email to the list would be helpful.
>>
>> We'll be running this consensus call for two weeks, please reply
>> before 2021-01-26, the chairs will determine consensus on that date.
>>
>> Thanks,
>> David
>>
>

---

From: David Schinazi <[email-masked]>
Date: Wed, 17 Feb 2021 15:23:22 -0800

Adoption is now complete. Victor has uploaded the WG document:
https://tools.ietf.org/html/draft-ietf-webtrans-http3-00
Please give it a read and file issues on the official WG GitHub repo:
https://github.com/ietf-wg-webtrans/draft-ietf-webtrans-http3/issues

Cheers,
David