Subject: [weirds] Fwd: I-D Action: draft-blanchet-weirds-bootstrap-autonomous-00.txt

From: Marc Blanchet <[email-masked]>
Date: Mon, 21 Oct 2013 11:55:19 -0400

Hello,
 based on our discussion on bootstrap in Berlin and the ideas suggested  to use a label under the TLD for the names and the NRO file for IP addresses and AS, I wrote this draft to capture the ideas. Hopefully, it is in line with the suggestions. It is not full baked but enough to discuss I think. When we will reach concensus on the method(DNS, IANA, this one), I'll update appropriately.

comments welcome.

Regards, Marc.

Début du message réexpédié :

> De : [email-masked]
> Objet : I-D Action: draft-blanchet-weirds-bootstrap-autonomous-00.txt
> Date : 21 octobre 2013 11:50:24 HAE
> À : [email-masked]
> Répondre à : [email-masked]
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 
> 	Title           : Finding the Authoritative Registration Data (RDAP) Server
> 	Author(s)       : Marc Blanchet
> 	Filename        : draft-blanchet-weirds-bootstrap-autonomous-00.txt
> 	Pages           : 6
> 	Date            : 2013-10-21
> 
> Abstract:
>   This document specifies a method to find which Registration Data
>   Access Protocol (RDAP) server is authoritative to answer queries for
>   a requested scope, such as domain names, IP addresses or Autonomous
>   System numbers.
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-blanchet-weirds-bootstrap-autonomous
> 
> There's also a htmlized version available at:
> http://tools.ietf.org/html/draft-blanchet-weirds-bootstrap-autonomous-00
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: "John Levine" <[email-masked]>
Date: 21 Oct 2013 20:39:32 -0000

In article <[email-masked]> you write:
>-=-=-=-=-=-
>-=-=-=-=-=-
>
>Hello,
> based on our discussion on bootstrap in Berlin and the ideas suggested  to use
>a label under the TLD for the names and the NRO file for IP addresses and AS, I
>wrote this draft to capture the ideas. Hopefully, it is in line with the
>suggestions. It is not full baked but enough to discuss I think. When we will
>reach concensus on the method(DNS, IANA, this one), I'll update appropriately.
>
>comments welcome.

It looks basically OK -- most of the alternatives have been ruled out
so these are what's left.  A and AAAA in the TLDs are no good unless
we want to invent a new reserved name and check to make sure that
nobody has used it yet.

For the numbers bootstraps, assuming the RIRs are agreeable, I'd like
to say that the much smaller IANA allocation list is an acceptable
substitute for the NRO list.  I expect some people will find a 300,000
line bootstrap file a bit rich for their setups.  The differences
between the IANA and NRO files should all be known to the relevant
RIRs, who can issue redirects, no?

R's de Montréal,
John

---

From: Marc Blanchet <[email-masked]>
Date: Mon, 21 Oct 2013 20:58:29 -0400

> It looks basically OK -- most of the alternatives have been ruled out

I'm not sure they are ruled out yet. I think each method has its pros and cons. And I've heard support for some of the presented ones in Berlin. 
But at least, with this, we have the full (yet?) set on the table to discuss.

Marc.

> R's de Montr�al,