Subject: [weirds] synchronize search query and response specs and examples

From: Ernie Dainow <[email-masked]>
Date: Thu, 24 Oct 2013 15:28:16 -0400

Domain search is specified as /domains?name=XXXX
Response is specified as
     "handle" : "1-XXXX",
     "ldhName" : "1.example.com",
Since the search can be for either ldh or unicode names, "ldhName" may 
not be correct.
Also, to avoid confusion with the query draft, the response example 
should not use "XXXX", or else spell out what the actual query was for 
this example.

In general, if a search is made for parameter "searchfor", the result 
should include a field with "searchfor" so the client can determine 
which returned field corresponds to the search request. This will allow 
the client to choose how to manage and display the results, e.g. 
alphabetic order of the search request.

So, the response for an entity search by name /entities?fn=Joe*
should have a response like
     "handle" : "A12345",
     "fn" : "Joe User",

-Ernie

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Tue, 29 Oct 2013 11:45:33 +0000

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Ernie Dainow
> Sent: Thursday, October 24, 2013 3:28 PM
> To: [email-masked]
> Subject: [weirds] synchronize search query and response specs and
> examples
> 

I'll talk to Andy about this. Consistency could indeed make things easier to understand.

Scott