Subject: [weirds] I-D Action: draft-ietf-weirds-rdap-query-07.txt

From: [email-masked]
Date: Tue, 01 Oct 2013 11:25:07 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Web Extensible Internet Registration Data Service Working Group of the IETF.

	Title           : Registration Data Access Protocol Query Format
	Author(s)       : Andrew Lee Newton
                          Scott Hollenbeck
	Filename        : draft-ietf-weirds-rdap-query-07.txt
	Pages           : 15
	Date            : 2013-10-01

Abstract:
   This document describes uniform patterns to construct HTTP URLs that
   may be used to retrieve registration information from registries
   (including both Regional Internet Registries (RIRs) and Domain Name
   Registries (DNRs)) using "RESTful" web access patterns.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-weirds-rdap-query

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-weirds-rdap-query-07

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-weirds-rdap-query-07

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Tue, 1 Oct 2013 18:32:57 +0000

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of [email-masked]
> Sent: Tuesday, October 01, 2013 2:25 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [weirds] I-D Action: draft-ietf-weirds-rdap-query-07.txt
> 
> 

>From the change log:

"Fixed query parameter typo by replacing "/?" with "?".  Changed "asplain" to "AS Plain".  Added entity search by handle. Corrected section references. Updated IDN search text."

There are still some open questions about IDN search processing:

1. Normalization? Yes or no. If yes, which form?

2. Unicode partial matching. Refer to RFC 5892 and I-D.ietf-precis-nickname or RFC 5891?

Scott

---

From: Marc Blanchet <[email-masked]>
Date: Tue, 1 Oct 2013 15:03:54 -0400

> 2. Unicode partial matching. Refer to RFC 5892 and I-D.ietf-precis-nickname or RFC 5891?

I think this (idn searching) warrants a good meeting time discussion in Vancouver...

Marc.

> Scott
> _______________________________________________
> weirds mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/weirds

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Tue, 1 Oct 2013 19:06:14 +0000

> From: Marc Blanchet [mailto:[email-masked]]
> Sent: Tuesday, October 01, 2013 3:04 PM
> To: Hollenbeck, Scott
> Cc: [email-masked]
> Subject: Re: [weirds] I-D Action: draft-ietf-weirds-rdap-query-07.txt
> 
> >> This draft is a work item of the Web Extensible Internet
> Registration
> >> Data Service Working Group of the IETF.
> >>
> > "Fixed query parameter typo by replacing "/?" with "?".  Changed
> "asplain" to "AS Plain".  Added entity search by handle. Corrected
> section references. Updated IDN search text."
> >

I agree, and that's precisely why I already requested time to talk about it. Are we confirmed, Murray?

Scott

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Tue, 1 Oct 2013 12:38:41 -0700

We haven't started crafting an agenda yet, but I'd say it's a safe bet that
this will be on there.

I'll try to get a rough agenda out in the next few days.  It's due in a
couple of weeks.

-MSK

On Tue, Oct 1, 2013 at 12:06 PM, Hollenbeck, Scott <[email-masked]
> wrote: