Subject: Re: [weirds] comments on draft-ietf-weirds-rdap-query-10

From: Maarten Bosteels <[email-masked]>
Date: Wed, 23 Jul 2014 17:49:04 +0000

Hello,

First of all, apologies for replying to such an old thread.

On Mon, Dec 2, 2013 at 3:40 PM, Hollenbeck, Scott <[email-masked]<mailto:[email-masked]>> wrote:
> -----Original Message-----
> From: weirds [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Andrew
> Sullivan
> Sent: Wednesday, November 27, 2013 2:41 PM
> To: [email-masked]<mailto:[email-masked]>
> Subject: [weirds] comments on draft-ietf-weirds-rdap-query-08
>
> Later, "IDN labels SHOULD NOT be represented as a mixture of A-labels
> and U-labels."  I think this probably means "If XXXX contains any IDN
> label, then every IDN label in XXXX SHOULD be either A-labels or
> U-labels, and not a mixture."  Perhaps shorter and still as clear is,
> "IDNs SHOULD NOT be represented as a mixture of A-labels and U-labels;
> that is, any IDN SHOULD use only A-labels or only U-labels."  The
> reason I'm having trouble with this is that "xn--jxalpdlp.com<http://xn--jxalpdlp.com/>"
> contains an A-label and an NR-LDH label, so we can't just say "no
> mixing".  If nobody else finds the existing text possibly misleading,
> I don't feel too strongly about it.

I'll use your text - thanks.

I find the text in draft-ietf-weirds-rdap-query-10<http://tools.ietf.org/html/draft-ietf-weirds-rdap-query-10>  still misleading:  the last part could still be interpreted as if NR-LDH labels are not allowed. The suggested text below is verbose but in my opinion more precise:

OLD:

IDNs SHOULD NOT be represented as a mixture of A-labels and U-labels; that is, any IDN SHOULD use only A-labels or only U-labels.

NEW:

If XXXX contains any IDN label, then either all IDN labels in XXXX SHOULD be represented as A-labels or all IDN labels in XXXX should be represented as U-labels.

Does that make sense ?

Maarten

---

From: Andy Newton <[email-masked]>
Date: Wed, 23 Jul 2014 21:37:03 +0000

On Jul 23, 2014, at 1:49 PM, Maarten Bosteels <[email-masked]<mailto:[email-masked]>> wrote:
I find the text in draft-ietf-weirds-rdap-query-10<http://tools.ietf.org/html/draft-ietf-weirds-rdap-query-10>  still misleading:  the last part could still be interpreted as if NR-LDH labels are not allowed. The suggested text below is verbose but in my opinion more precise:

OLD:

NEW:

Does that make sense ?

I think so.

-andy