Subject: [weirds] Bootstrap and RDAP-Query Changes

From: "Hollenbeck, Scott" <[email-masked]>
Date: Mon, 14 Jul 2014 12:04:45 +0000

I just finished reading through bootstrap-04 with an eye towards figuring out changes (replacing text for .well-known) required for rdap-query. Do I have this right? Registry entries are specified for domains, IP addresses, and AS numbers. Queries for these values will be constructed by retrieving the appropriate base URL from the registry and appending a path segment specified in rdap-query. This method should work for both lookups and searches. If this is true I understand what needs to be changed and how I can change it.

Registry entries are unspecified for entity and help queries. Entity bootstrap (or the lack thereof) is described in Section 6.

For entities: Retrieve a base URL for the service (domain, address, etc.) associated with a given entity. The query URL is constructed by concatenating the base URL to the entity path segment specified in rdap-query.

For help: Retrieve a base URL for any service (domain, address, etc.) for which additional information is required. The query URL is constructed by concatenating the base URL to the help path segment specified in rdap-query.

Does this sound reasonable?

Scott

---

From: "John Levine" <[email-masked]>
Date: 14 Jul 2014 13:44:18 -0000

>Does this sound reasonable?

That's how I read it.

R's,
John