Subject: [weirds] Required data in responses

From: Ernie Dainow <[email-masked]>
Date: Fri, 08 Aug 2014 15:44:59 -0400

It is not clear throughout draft-ietf-weirds-json-response-07 whether 
members defined for an object are required or not. Each object class 
generally has a statement like "This object has the following members: ..."

Does this mean a server must return all the members defined in the list 
when returning that object? I did not interpret the spec this way, but 
the inter-op test cases did, resulting in many "FAILS" on the test.

If this is not the intention, then the spec should be clarified by 
saying something like "This object has one or more of the following 
members: ..."

-Ernie

---

From: Andy Newton <[email-masked]>
Date: Fri, 8 Aug 2014 20:02:28 +0000

On Aug 8, 2014, at 3:44 PM, Ernie Dainow <[email-masked]<mailto:[email-masked]>> wrote:

It is not clear throughout draft-ietf-weirds-json-response-07 whether members defined for an object are required or not. Each object class generally has a statement like "This object has the following members: ..."

Does this mean a server must return all the members defined in the list when returning that object? I did not interpret the spec this way, but the inter-op test cases did, resulting in many "FAILS" on the test.

If this is not the intention, then the spec should be clarified by saying something like "This object has one or more of the following members: ..."

>From section 3:

   Clients processing JSON responses MUST be prepared for values
   specified in this document to be absent from a response as no JSON
   value listed is required to appear in a response.  In other words,
   servers MAY remove values as is needed by the policies of the server
   operator.

-andy