Subject: Re: [weirds] Sean Turner's Discuss on draft-ietf-weirds-rdap-sec-04: (with DISCUSS)

From: Andy Newton <[email-masked]>
Date: Fri, 22 Aug 2014 20:46:38 +0000

On Jul 23, 2014, at 9:39 AM, Hollenbeck, Scott <[email-masked]> wrote:

>> What
>> I'm curious about here is whether there should be a SRV-ID or URI-ID is
>> needed for RDAP and isn't some kind of reference to RFC 6125 warranted
>> here?
> 
> I'm open to suggestions. Whatever is appropriate for a web server would be appropriate for RDAP.

URI-ID is most appropriate if we need to do this. I’m not sure what problem RFC 6125 solves (would be nice if it stated that).

I do note that it marks URI-ID as “direct”, meaning they are given to applications by users. That is not always the case. URIs can be given to applications via DHCP, via U-NAPTR, and in our case, via file bootstrap.

-andy

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Wed, 27 Aug 2014 19:07:05 +0000

> -----Original Message-----
> From: Andy Newton [mailto:[email-masked]]
> Sent: Friday, August 22, 2014 4:47 PM
> To: Hollenbeck, Scott
> Cc: [email-masked]
> Subject: Re: [weirds] Sean Turner's Discuss on draft-ietf-weirds-rdap-
> sec-04: (with DISCUSS)
> 
> 
> URI-ID is most appropriate if we need to do this. I'm not sure what
> problem RFC 6125 solves (would be nice if it stated that).
> 
> I do note that it marks URI-ID as "direct", meaning they are given to
> applications by users. That is not always the case. URIs can be given
> to applications via DHCP, via U-NAPTR, and in our case, via file
> bootstrap.

...and as such, I'm not sure if there's anything here for us to do. Feedback from Sean would have been helpful.

Scott