Subject: [weirds] Comments on draft-ietf-weirds-bootstrap-04

From: Naoki Kambe <[email-masked]>
Date: Fri, 22 Aug 2014 20:13:45 +0900 (JST)

Hello,

Here are my random questions and comments about a bootstrap file for
domain names other than regarding IANA consideration which is under
discussion.

  - Generally we cannot write a comment on a JSON document by using
    "/* .. */" or "// ..".  So I'd like to suggest a bootstrap file
    can have a "description" element under the "rdap.bootstrap", which
    might be helpful for users' understanding. For example,

       { "rdap.bootstrap": {
         ...
       	 "description": [
       	   "This is an IANA Domain Name Space RDAP Bootstrap Service.",
       	   "For details, see ..."
         ]
         ...

  - In case where the domain name is an IDN, should its correct
    representation in the bootstrap be U-label or A-label or both? I
    think only A-label should be used for avoiding the confusion.

  - Should all the alphabets in domain names be represented with lower
    cases?  Otherwise can a mixed usage with upper and lower cases be
    allowed? I think it would be better that lower cases are uniformly
    used.

  - Should some HTTP headers like "Content-type" and
    "Access-Control-Allow-Origin" be considered even in case of
    distribution by the IANA registry? I believe a reference to
    draft-ietf-weirds-using-http will be put somewhere.

  - Should each URL of RDAP server name in a bootstrap file always end
    with a slash "/"?  Otherwise do the user need to check whether it
    ends with "/", and append it if not? I think this might be burden
    for some users.

  - In some programing languages, a variable in JSON can be referred
    to without using literals. For example, json={"foo":"bar":1} can
    be accessed with "json.foo.bar".  But the top level name
    "rdap.bootstrap" of the bootstrap file contains a dot ".".  Then
    it is accessed using a literal like json["rdap.bootstrap"].  Some
    people might feel this is annoying. So can this name be changed to
    a dot-less name like "rdapBootstrap"?

Sorry for the duplication if these are already discussed.

Regards,

Naoki Kambe

From: Guillaume Leclanche <[email-masked]>
Subject: [weirds] Bootstrap: draft-ietf-weirds-bootstrap-04
Date: Fri, 04 Jul 2014 16:09:09 -0400

> Hello,
> 
> We have submitted a new version of the bootstrap draft, which includes and compiels all the comments done since
> version -02.
> 
> draft: http://tools.ietf.org/html/draft-ietf-weirds-bootstrap-04
> diff with v2: http://tools.ietf.org/rfcdiff?url1=draft-ietf-weirds-bootstrap-02.txt&url2=
> draft-ietf-weirds-bootstrap-04.txt
> 
> In details:
> - Remove {resource}: The "resource" (i.e., the segment from the query draft) will always be placed at the end, so it's
> redundant to put {resource} in the registry.
> - No longer using objects with arrays as keys. Everything is an array.
> - Removed "Should try in order" the different URL proposed for a segment, as the registry will more likely want to do
> a round robin, or the client may want to select one scheme in particular (https over http). However it's likely that
> some implementations will anyway implement this as "try first URL first"
> - JSON validates json-lint
> 
> Guillaume
> 
> -------- Message original --------
> Sujet: New Version Notification for draft-ietf-weirds-bootstrap-04.txt                                   
> Date : Fri, 04 Jul 2014 12:39:56 -0700                                                                   
>   De : [email-masked]                                                                          
> Pour : Guillaume Leclanche <[email-masked]>, "Marc Blanchet" <[email-masked]>
> 
> A new version of I-D, draft-ietf-weirds-bootstrap-04.txt
> has been successfully submitted by Guillaume Leclanche and posted to the
> IETF repository.
> 
> Name:           draft-ietf-weirds-bootstrap
> Revision:       04
> Title:          Finding the Authoritative Registration Data (RDAP) Service
> Document date:  2014-07-03
> Group:          weirds
> Pages:          13
> URL:            http://www.ietf.org/internet-drafts/draft-ietf-weirds-bootstrap-04.txt
> Status:         https://datatracker.ietf.org/doc/draft-ietf-weirds-bootstrap/
> Htmlized:       http://tools.ietf.org/html/draft-ietf-weirds-bootstrap-04
> Diff:           http://www.ietf.org/rfcdiff?url2=draft-ietf-weirds-bootstrap-04
> 
> Abstract:
>    This document specifies a method to find which Registration Data
>    Access Protocol (RDAP) server is authoritative to answer queries for
>    a requested scope, such as domain names, IP addresses or Autonomous
>    System numbers.
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
>

---

From: Andy Newton <[email-masked]>
Date: Fri, 22 Aug 2014 17:10:03 +0000

>    think only A-label should be used for avoiding the confusion.

I agree with this.

>    a dot-less name like "rdapBootstrap"?

Good point. It should probably follow the rules laid out in section 6 of using-http along with text stating that clients should ignore JSON names they do not understand for extensibility purposes.

-andy

---

From: Naoki Kambe <[email-masked]>
Date: Mon, 25 Aug 2014 17:54:15 +0900 (JST)

From: Andy Newton <[email-masked]>
Date: Fri, 22 Aug 2014 17:10:03 +0000
> >    think only A-label should be used for avoiding the confusion.

I think this restriction would be put into an "Internationalization
Considerations" section or a section like this.

> Good point. It should probably follow the rules laid out in section 6 of using-http along with text stating that clients should ignore JSON names they do not understand for extensibility purposes.

http://tools.ietf.org/html/draft-ietf-weirds-using-http-10#section-6

Yes, this is exactly what I'd like to say. I think all JSON names via
RDAP should follow this convention.

Regards,

Naoki Kambe