Subject: [weirds] Sean Turner's Discuss on draft-ietf-weirds-using-http

From: Andy Newton <[email-masked]>
Date: Fri, 22 Aug 2014 19:57:35 +0000

Below you will find the text of Sean Turner’s Discuss on draft-ietf-weirds-using-http. It deals with .well-known.

-andy

———————————————
updated ...

On .well-known point raised by Stephen ....  when EST came through the authors
were told  by the appsdir reviewer that:

IETF standards should not define URIs or patterns of URIs, because servers may
wish to provide other services (implying the possibility of collision), or
deploy resources in an alternate way, for implementation or operational reasons.

This is a fundamental concept in the Web architecture; see
<http://www.w3.org/TR/webarch/>.

Possible remedies include:

1) Specifying a "home document" format that links (in the RFC5988 sense) to the
various resources as appropriate. 2) Specifying a well-known URI to root the
interaction. Note that this is suboptimal; while it avoids collisions, it does
not allow alternate deployments, or multiple deployments on the same host.

Why doesn't the same recommendation apply here?

---

From: "John Levine" <[email-masked]>
Date: 23 Aug 2014 05:42:27 -0000

>Below you will find the text of Sean Turner’s Discuss on draft-ietf-weirds-using-http. It deals with .well-known.

Perpaps he hasn't followed the bootstrap discussion.

RDAP providers can put any prefix they want in the bootstrap, which
avoids the collision problem.  If for some reason you want to run
several RDAP servers on the same host with different prefixes, that's
easy to do.

Is there a polite way to suggest that the horse has been dead for a long time?

R's,
John

>_______________________________________________
>weirds mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/weirds
>

---

From: Andy Newton <[email-masked]>
Date: Tue, 26 Aug 2014 18:03:18 +0000

On Aug 23, 2014, at 1:42 AM, John Levine <[email-masked]<mailto:[email-masked]>> wrote:

In article <[email-masked]<mailto:[email-masked]>> you write:
Below you will find the text of Sean Turner�s Discuss on draft-ietf-weirds-using-http. It deals with .well-known.

Given he was not our AD, I would think he hasn’t followed it. Given that he is no longer an AD, I doubt it even more. :)

That is true only for clients using the bootstrap. For a client directly querying a server (think of the -H option you find on many Whois clients today), we are imposing a pattern.

Also, bootstrap only covers these lookups:
1. domain
2. ip network
3. autnum

These lookups are not covered by bootstrap:
1. entity
2. nameserver

Additionally, these searches are not covered by bootstrap:
1. domain
2. name server
3. entity

-andy

---

From: "John R Levine" <[email-masked]>
Date: 26 Aug 2014 15:07:41 -0400

> That is true only for clients using the bootstrap. For a client directly 
> querying a server (think of the -H option you find on many Whois clients 
> today), we are imposing a pattern.

Well, if you don't use the bootstrap, you're not following the protocol.

If you're saying that many clients are likely to ignore the bootstrap and 
use something like rdap-servers.net to find a host name and use the 
obvious URL syntax from rdap-query, and that will work just fine in a 
world where $30 routers run full versions of Apache and http virtual 
domains are universally available and cost nothing, I wouldn't disagree.

But we're not allowed to say that, so shhh.

Regards,
John Levine, [email-masked], Taughannock Networks, Trumansburg NY
Please consider the environment before reading this e-mail.