Subject: [weirds] Alissa Cooper's Abstain on draft-ietf-weirds-object-inventory-06: (with COMMENT)

From: "Alissa Cooper" <[email-masked]>
Date: Wed, 29 Oct 2014 16:29:10 -0700

Alissa Cooper has entered the following ballot position for
draft-ietf-weirds-object-inventory-06: Abstain

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to http://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
http://datatracker.ietf.org/doc/draft-ietf-weirds-object-inventory/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

I'm with Barry -- this seems like it would have made more sense if
published on a wiki, as a research paper, or in a slide deck. If the
choices made in the protocol documents actually linked back to these
findings for justification, I might see it differently, but at present
there does not seem to be much connection between these findings and some
of the design decisions made in the protocol. The data formats in the
protocol don't seem to support every field that was discovered in this
study, nor does there seem to be any consistent metric that was used for
deciding whether to include a particular field based on its prevalence in
these findings.

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Wed, 29 Oct 2014 23:50:09 -0700

> deciding whether to include a particular field based on its prevalence in

We discussed this a few times in the WG when deciding whether to adopt and
ultimately publish this document.  In the end the WG reached consensus that
it was worth publishing because the research described in it led directly
to the fields registered by the json-response draft.

The detail you described in that last sentence are probably things we
should consider adding either to this document or to json-response.

-MSK

---

From: Alissa Cooper <[email-masked]>
Date: Thu, 30 Oct 2014 07:16:41 -0700

On Oct 29, 2014, at 11:50 PM, Murray S. Kucherawy <[email-masked]> wrote:

> We discussed this a few times in the WG when deciding whether to adopt and ultimately publish this document.  In the end the WG reached consensus that it was worth publishing because the research described in it led directly to the fields registered by the json-response draft.
> 
> The detail you described in that last sentence are probably things we should consider adding either to this document or to json-response.

It would make more sense to me to publish this document as an RFC if json-response provided explanations for why particular fields are supported and cited this document as a reference.

Alissa

---

From: Andy Newton <[email-masked]>
Date: Thu, 30 Oct 2014 14:24:59 +0000

On Oct 30, 2014, at 10:16 AM, Alissa Cooper <[email-masked]<mailto:[email-masked]>> wrote:

We can add that to json-response. Scott and I did go through this information when formulating json-response (and rdap-query).

-andy