Subject: [wellknown-uri-review] Request for well-known URI: host-meta

From: Eran Hammer-Lahav <[email-masked]>
Date: Fri, 7 May 2010 16:21:18 -0700

http://tools.ietf.org/html/draft-hammer-hostmeta

The draft has been submitted for Last-Call. As specified in RFC 5785, the well-known prefix requires Designated Expert review. Since I'm the DE, Mark Nottingham will perform the review.

   URI suffix:  host-meta
   Change controller:  IETF
   Specification document(s):  http://tools.ietf.org/html/draft-hammer-hostmeta
   Related information:  None

EHL

---

From: Sandro Hawke <[email-masked]>
Date: Fri, 07 May 2010 22:18:58 -0400

> The draft has been submitted for Last-Call. As specified in RFC 5785, the wel
> l-known prefix requires Designated Expert review. Since I'm the DE, Mark Nott
> ingham will perform the review.
> 
>    URI suffix:  host-meta
>    Change controller:  IETF

I'll go ahead with the obvious question: when we have the companion spec
which uses RDF instead of XRD, should it use the same well-known name
(host-meta) and rely on content-negotiation, or should it use a
different name (eg site-meta)?  And how will this decision be made?
(Also, is anyone working on that spec yet?)

Also, can you explain/motivate the last paragraph of section 4?  Aren't
there cases where there is useful information about part of the site but
not about the host itself?

      -- Sandro

---

From: Eran Hammer-Lahav <[email-masked]>
Date: Fri, 7 May 2010 19:48:13 -0700

Hi Sandro,

> -----Original Message-----
> From: Sandro Hawke [mailto:[email-masked]]
> Sent: Friday, May 07, 2010 7:19 PM
> To: Eran Hammer-Lahav
> Cc: [email-masked]
> Subject: Re: [wellknown-uri-review] Request for well-known URI: host-meta
> 
> 
> > The draft has been submitted for Last-Call. As specified in RFC 5785,
> > the wel l-known prefix requires Designated Expert review. Since I'm
> > the DE, Mark Nott ingham will perform the review.
> >
> >    URI suffix:  host-meta
> >    Change controller:  IETF
> (host-meta) and rely on content-negotiation, or should it use a different
> name (eg site-meta)?

First, it is not clear to me that an RDF alternative is needed. If you can transform an XRD document into an RDF, just do that using the same document. If you can't, you are dealing with something that is semantically different and should probably use a different name. If you can express an XRD document in RDF, content negotiation is a good option, and I am not sure you need a spec to say a client is allowed to try that. You might need a spec for converting XRD to RDF.

>  And how will this decision be made?

Like anything else in the IETF...

Once host-meta is registered and an RFC is published, the name is reserved. To change how the host-meta name is used you need to submit a new draft and it should probably update the original host-meta RFC. Normal IETF rules apply. When you submit a new registration request, the Designated Expert (currently me) gets to review the request, but it is rarely made alone - we usually discuss requests on an open list and come to a consensus. If you disagree with the DE, you can reach out to the IESG, etc.

But the bottom line is that if you want a new or changed registration you need to write a draft and get it reviewed. If you are trying to modify an entry, you must comply with the change controller. In this case, you change the host-meta registration after it is approved you need to write a new RFC and get it published.

> (Also, is anyone working on that spec yet?)

Not that's I'm aware of. It seems like a waste of time to me. A more interesting idea would be to propose a POWDER flavor, but I'm not aware of any use case for which XRD isn't enough. But the same process applies.

> Also, can you explain/motivate the last paragraph of section 4?  Aren't there
> cases where there is useful information about part of the site but not about
> the host itself?

Sure. But that's not what host-meta is for. It is intentionally limited.

EHL

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 19 May 2010 21:26:33 +1000

I couldn't find the last call announcement; could you send a reference?

Also, my preference would be to wait until IESG evaluation (NOT until RFC publication), since this is Informational; it could be that they knock it back.

Regards,

On 08/05/2010, at 9:21 AM, Eran Hammer-Lahav wrote:

> _______________________________________________
> wellknown-uri-review mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/wellknown-uri-review

--
Mark Nottingham     http://www.mnot.net/

---

From: Eran Hammer-Lahav <[email-masked]>
Date: Wed, 19 May 2010 07:16:43 -0700

No last-call yet (was requested).

EHL

> From: Mark Nottingham [mailto:[email-masked]]
> Sent: Wednesday, May 19, 2010 4:27 AM
> To: Eran Hammer-Lahav
> Also, my preference would be to wait until IESG evaluation (NOT until RFC
> publication), since this is Informational; it could be that they knock it back.
> 
> Regards,
> 
> 
> 
> > The draft has been submitted for Last-Call. As specified in RFC 5785, the
> well-known prefix requires Designated Expert review. Since I'm the DE, Mark
> Nottingham will perform the review.
> >
> >   URI suffix:  host-meta
> >   Change controller:  IETF