Subject: [wellknown-uri-review] RDF instead of XRD, for "host-meta"

From: Sandro Hawke <[email-masked]>
Date: Wed, 19 Jan 2011 11:26:41 -0500

Eran, continuing my thread from last year [1]: perhaps my approach was
unclear.  Put more simply, I want host metadata to be published and
consumed in RDF, not XRD.  I'm confident I'm not the only one who wants
that.  If some folks want to use XRD in parallel, I can live with that,
but if there's to be any kind of single standard format for host
metadata, I believe it should be RDF not XRD.  

I understand you want it to use XRD, not RDF. What I don't know is how
to proceed at the IETF in the face of that disagreement.

One compromise would be to make the "host-meta" path be format-neutral,
with people using HTTP content negotation to get XRD, RDF,
application/json, etc, as they like.  This approach, standardizing the
data channel but not the data format, fails to completely address most
use cases, but at least it's a step in the right direction.
Standardizing on XRD, as in [2] would be a significant step in the
wrong direction.

    -- Sandro

[1]
http://www.ietf.org/mail-archive/web/wellknown-uri-review/current/msg00004.html
[2] http://tools.ietf.org/html/draft-hammer-hostmeta-13

---

From: Eran Hammer-Lahav <[email-masked]>
Date: Wed, 19 Jan 2011 10:03:42 -0700

Host-meta's canonical representation is XRD. Other formats can be made available through conneg or different well-known endpoints (or even via a link from host-meta). Using XRD for host-meta is already deployed by all the major providers and is not going to change, especially not to RDF.

I need to find time to finish some minor open issues with the specification and submit it to the IESG, but other than that, there is not much that is going to happen with this specification. If it doesn't provide you with what you need, define a new one. If you will be using the same well-known endpoint, it will need to be clear that XRD is still the default and canonical representation. I would suggest you use something else.

EHL

> -----Original Message-----
> From: Sandro Hawke [mailto:[email-masked]]
> Sent: Wednesday, January 19, 2011 8:27 AM
> To: Eran Hammer-Lahav
> Cc: IETF wellknown-uri Review List
> Subject: RDF instead of XRD, for "host-meta"
> 
> that.  If some folks want to use XRD in parallel, I can live with that, but if
> there's to be any kind of single standard format for host metadata, I believe
> it should be RDF not XRD.
> 
> I understand you want it to use XRD, not RDF. What I don't know is how to
> proceed at the IETF in the face of that disagreement.
> 
> with people using HTTP content negotation to get XRD, RDF, application/json,
> etc, as they like.  This approach, standardizing the data channel but not the
> data format, fails to completely address most use cases, but at least it's a
> step in the right direction.
> Standardizing on XRD, as in [2] would be a significant step in the wrong
> direction.
> 
>     -- Sandro
> 
> [1]

---

From: Peter Saint-Andre <[email-masked]>
Date: Wed, 19 Jan 2011 10:14:13 -0700

On 1/19/11 10:03 AM, Eran Hammer-Lahav wrote:
> Host-meta's canonical representation is XRD. Other formats can be
> made available through conneg or different well-known endpoints (or
> even via a link from host-meta). 

Heh, yes.

> Using XRD for host-meta is already
> deployed by all the major providers and is not going to change,
> especially not to RDF.
> 
> I need to find time to finish some minor open issues with the
> specification and submit it to the IESG, but other than that, there
> is not much that is going to happen with this specification. 

Yeah, let's finish that one off. :)

> If it
> doesn't provide you with what you need, define a new one. If you will
> be using the same well-known endpoint, it will need to be clear that
> XRD is still the default and canonical representation. I would
> suggest you use something else.

+1

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Sandro Hawke <[email-masked]>
Date: Wed, 19 Jan 2011 12:43:42 -0500

On Wed, 2011-01-19 at 10:03 -0700, Eran Hammer-Lahav wrote:
>  Using XRD for host-meta is already deployed by all the major providers and is not going to change,

Providers of what?    Who are they?   

Forgive my ignorance of IETF procedures, if there's a well-known
location for this information.

     -- Sandro

---

From: Eran Hammer-Lahav <[email-masked]>
Date: Wed, 19 Jan 2011 10:44:25 -0700

Web providers (Yahoo!, Google, AOL, etc.).

EHL

> Sent: Wednesday, January 19, 2011 9:44 AM
> To: Eran Hammer-Lahav
> Subject: RE: RDF instead of XRD, for "host-meta"
> 
> Forgive my ignorance of IETF procedures, if there's a well-known location for
> this information.
> 
>      -- Sandro
> 
>

---

From: Sandro Hawke <[email-masked]>
Date: Wed, 19 Jan 2011 13:26:16 -0500

> Web providers (Yahoo!, Google, AOL, etc.).

http://www.google.com/.well-known/host-meta is 404.

I still have no idea what a "web provider" is.  Do you mean content
providers?   hosting services?   companies with user accounts?

A quick survey (pulling hostnames off the top of my head and then alexa)
of facebook, microsoft, ibm, oracle, ebay, paypal, linkedin, flickr,
apple, adobe, myspace, expedia, amazon, youtube, live, baidu, blogger,
wikipedia, and twitter, shows only twitter (plus yahoo and AOL, as you
mentioned) has implemented host-meta.   Maybe I tested incorrectly; my
script is below.

With that in mind, can you clarify your answer?  I'm not saying no one
has implemented this, I just want to understand roughly who has
implemented it (and why).

    -- Sandro

======================
quick little test script (bash):

for site in yahoo.com aol.com facebook.com microsoft.com ibm.com oracle.com ebay.com paypal.com linkedin.com flickr.com apple.com adobe.com myspace.com expedia.com amazon.com youtube.com live.com baidu.com blogger.com en.wikipedia.org twitter.com; do
   for prefix in "" "www."; do
      host=$prefix$site
          echo $host
          curl --output "sitemeta-$host" --header 'Accept: application/xrd+xml' http://$host/.well-known/host-meta
   done
done
grep xrd sitemeta-*

==========================

---

From: Eran Hammer-Lahav <[email-masked]>
Date: Wed, 19 Jan 2011 11:40:49 -0700

I don't have a list but either way it doesn't matter. The community behind host-meta took that name. You can either find a way to work with it as-is, extend it while maintaining XRD as the canonical, or define a new one. This is not a popularity contest and it's not up for a vote what format host-meta is going to use. It is XRD and it’s a done deal. If it doesn't work for you, create another.

EHL

> Sent: Wednesday, January 19, 2011 10:26 AM
> To: Eran Hammer-Lahav
> A quick survey (pulling hostnames off the top of my head and then alexa) of
> facebook, microsoft, ibm, oracle, ebay, paypal, linkedin, flickr, apple, adobe,
> myspace, expedia, amazon, youtube, live, baidu, blogger, wikipedia, and
> twitter, shows only twitter (plus yahoo and AOL, as you
> With that in mind, can you clarify your answer?  I'm not saying no one has
> implemented this, I just want to understand roughly who has implemented it
> (and why).
> 
>     -- Sandro
> 
> ======================
> for site in yahoo.com aol.com facebook.com microsoft.com ibm.com
> oracle.com ebay.com paypal.com linkedin.com flickr.com apple.com
> adobe.com myspace.com expedia.com amazon.com youtube.com live.com
> baidu.com blogger.com en.wikipedia.org twitter.com; do

---

From: Sandro Hawke <[email-masked]>
Date: Wed, 19 Jan 2011 14:20:10 -0500

> I don't have a list but either way it doesn't matter. The community behind host-meta took that name. You can either find a way to work with it as-is, extend it while maintaining XRD as the canonica…

I see.   

Do you see any obstacle to me making a modified version of your draft,
replacing the XRD bits with RDF bits, changing the name to, eg
"site-meta", and registering that?

Also, what is a reasonable level of deployment to promote prior to
registration?

     -- Sandro

---

From: Eran Hammer-Lahav <[email-masked]>
Date: Wed, 19 Jan 2011 12:28:48 -0700

I'm not a fan. 'site-meta' was rejected in the past (look up www-talk list archive). If the only difference is just the format and the internal data is the same, I don't see the point.

The burden is on you to show how using RDF provides functionality not possible with host-meta, beyond just not wanting to parse XRD.

EHL

> Sent: Wednesday, January 19, 2011 11:20 AM
> To: Eran Hammer-Lahav
> > I don't have a list but either way it doesn't matter. The community behind
> host-meta took that name. You can either find a way to work with it as-is,
> extend it while maintaining XRD as the canonical, or define a new one. This is
> not a popularity contest and it's not up for a vote what format host-meta is
> going to use. It is XRD and it’s a done deal. If it doesn't work for you, create
> another.
> 
> I see.
> 
> replacing the XRD bits with RDF bits, changing the name to, eg "site-meta",
> and registering that?
> 
> > > A quick survey (pulling hostnames off the top of my head and then
> > > alexa) of facebook, microsoft, ibm, oracle, ebay, paypal, linkedin,
> > > flickr, apple, adobe, myspace, expedia, amazon, youtube, live,
> > > baidu, blogger, wikipedia, and twitter, shows only twitter (plus yahoo and
> AOL, as you
> > > With that in mind, can you clarify your answer?  I'm not saying no
> > > one has implemented this, I just want to understand roughly who has
> > >           curl --output "sitemeta-$host" --header 'Accept:
> application/xrd+xml'
> > > http://$host/.well-known/host-meta
> > >    done
> > > done
> > > grep xrd sitemeta-*
> > >

---

From: Sandro Hawke <[email-masked]>
Date: Wed, 19 Jan 2011 15:10:57 -0500

> The burden is on you to show how using RDF provides functionality not possible with host-meta, beyond just not wanting to parse XRD.

I thought these IANA registries had moved away from needing engineering
judgment to decide what got listed.  I thought the idea was that any
application following the appropriate steps and not obviously broken
would be approved.   This was motivated, as I recall, by the fact that
otherwise it's much easier to just route around the IETF and use a name
without registering it (as happened with many media types).

I don't see how you, personally, can judge how much of a burden it will
be to my application to make every system generate and parse XRD, not to
mention how it will affect adoption to force the sysadmins to learn XRD.
It seems to me this kind of judgment can only be made by the market or
by a proper Working Group, with full industry participation.

I was being facetious in proposing "site-meta", but I don't really see
how you can claim I need to prove utility above-and-beyond host-meta,
assuming a more suitable name were picked.

     -- Sandro

---

From: Eran Hammer-Lahav <[email-masked]>
Date: Wed, 19 Jan 2011 13:23:17 -0700

I didn't imply you needed to convince me, just that this is how proper standards are created. As for the registration require, this particular registry has its own guidelines:

   Well-known URIs are registered on the advice of one or more
   Designated Experts (appointed by the IESG or their delegate), with a
   Specification Required (using terminology from [RFC5226]).  However,
   to allow for the allocation of values prior to publication, the
   Designated Expert(s) may approve registration once they are satisfied
   that such a specification will be published.

This means you must publish a specification in accordance with 5226. Once that is done, you can ask for the registration. The decision to register a value before full publication of the specification is allowed but left to the discretion of the designated expert.

This list is not a suitable venue for discussion your proposal. Once you have a specification ready, send a request to the list and I will review it as directed by RFC 5785.

EHL

> Sent: Wednesday, January 19, 2011 12:11 PM
> To: Eran Hammer-Lahav
> > The burden is on you to show how using RDF provides functionality not
> possible with host-meta, beyond just not wanting to parse XRD.
> 
> I don't see how you, personally, can judge how much of a burden it will be to
> my application to make every system generate and parse XRD, not to
> It seems to me this kind of judgment can only be made by the market or by a
> proper Working Group, with full industry participation.
> 
> I was being facetious in proposing "site-meta", but I don't really see how you
> can claim I need to prove utility above-and-beyond host-meta, assuming a
> more suitable name were picked.
> 
>      -- Sandro
> 
> > EHL
> >
> > > host-meta took that name. You can either find a way to work with it
> > > as-is, extend it while maintaining XRD as the canonical, or define a
> > > new one. This is not a popularity contest and it's not up for a vote
> > > what format host-meta is going to use. It is XRD and it’s a done
> > > deal. If it doesn't work for you, create another.
> > >
> > > I see.
> > >
> > > Do you see any obstacle to me making a modified version of your
> > > draft, replacing the XRD bits with RDF bits, changing the name to,
> > > eg "site-meta", and registering that?
> > >
> > > > > alexa) of facebook, microsoft, ibm, oracle, ebay, paypal,
> > > > > linkedin, flickr, apple, adobe, myspace, expedia, amazon,
> > > > > youtube, live, baidu, blogger, wikipedia, and twitter, shows
> > > > > only twitter (plus yahoo and
> > > AOL, as you
> > > > > mentioned) has implemented host-meta.   Maybe I tested
> incorrectly;
> > > my
> > > > > script is below.
> > > > >
> > > > > With that in mind, can you clarify your answer?  I'm not saying
> > > > > no one has implemented this, I just want to understand roughly
> > > > > who has implemented it (and why).
> > > > >
> > > > >     -- Sandro
> > > > >
> > > > > ======================
> > > > > > > >  Using XRD for host-meta is already deployed by all the
> > > > > > > > major providers and is not going to change,
> > > > > > >
> > > > > > > Forgive my ignorance of IETF procedures, if there's a
> > > > > > > well-known location for this information.
> > > > > > >
> > > > > > >      -- Sandro
> > > > > > >
> > > > > > >
> > > > > >
> > > > >
> > > >
> > >
> >
>