Subject: Re: [wellknown-uri-review] A .well-known registration for review

From: Mark Nottingham <[email-masked]>
Date: Wed, 2 May 2012 09:41:31 +1000

My .02 - 

I suspect there are several better ways to do this, that don't do such bad things to the Web architecture. Well-known URIs are an escape valve, not permission :)

OTOH the role of a registry is to register, not to be a gatekeeper for quality. 

Regarding Eran's concern, I tend to agree, EXCEPT that 5785 also says:

>    It MAY also contain additional information, such as the syntax of
>    additional path components, query strings and/or fragment identifiers
>    to be appended to the well-known URI, or protocol-specific details
>    (e.g., HTTP [RFC2616] method handling).

So, strictly speaking, there's an argument for both sides here.

Anyway, I'd rather see these issues debated on the apps-discuss list than here. Although, apps-discuss is getting mighty busy these days...

On 01/05/2012, at 1:59 AM, Stephen Farrell wrote:

> 
> Hi,
> 
> We have a draft [1] that requests a registration of
> a .well-known URI.
> 
> The core WG are likely to want to use these we think
> and possibly decade, but they're intended to be generally
> useful as well.
> 
> Barry Leiba is planning to AD sponsor this and Alexey
> Melnikov will be shepherding so if you can cc them as
> well as the authors on any questions or comments that'd
> be good.
> 
> I hope the plan is to IETF LC this soon, once this
> review and the uri registrations review are done.
> 
> Thanks,
> Stephen.
> 
> [1] http://tools.ietf.org/html/draft-farrell-decade-ni-05
> _______________________________________________
> wellknown-uri-review mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/wellknown-uri-review

--
Mark Nottingham
http://www.mnot.net/

---

From: Stephen Farrell <[email-masked]>
Date: Wed, 02 May 2012 09:38:40 +0100

> So, strictly speaking, there's an argument for both sides here.

Crap, so now I need to go re-read 5785 properly;-)

> Anyway, I'd rather see these issues debated on the apps-discuss list than here. Although, apps-discuss is getting mighty busy these days...

We've asked for review of this on apps-discuss already so there's
a thread on which you can respond, e.g. [1] relates to comments
from James Manger. More comments are welcome!

S.

[1] http://www.ietf.org/mail-archive/web/apps-discuss/current/msg05483.html