Subject: Re: [wellknown-uri-review] Request for well-known URI: genid

From: Sandro Hawke <[email-masked]>
Date: Fri, 09 Nov 2012 16:45:01 -0500

On 09/04/2011 06:32 PM, Eran Hammer-Lahav wrote:
> I would prefer waiting until it is considered stable (both document and definition). I am happy to perform an early review if you submit the complete template.

14 months later, I think it's safe to say the spec is quite stable on 
this matter, and we'd like the next revision of the spec to be able to 
say the suffix is registered, so let's go ahead.    Here's the info:

    URI suffix: genid

    Change controller: W3C

    Specification document(s):

        RDF 1.1 Concepts and Abstract Syntax

        Richard Cyganiak and David Wood, Editors

        http://www.w3.org/TR/rdf11-concepts/

    Related information:  None

Thanks for handling this.

-- Sandro Hawke, W3C Staff Contact for the (W3C) RDF Working Group

> EHL
>
>> -----Original Message-----
>> From: [email-masked] [mailto:wellknown-uri-
>> [email-masked]] On Behalf Of Sandro Hawke
>> Sent: Wednesday, August 31, 2011 8:49 AM
>> To: IETF wellknown-uri Review List
>> Subject: [wellknown-uri-review] Request for well-known URI: genid
>>
>> The W3C RDF Working Group is producing a specification for how RDF blank
>> nodes can be safely and usefully mapped (Skolemized) into IRIs, through the
>> use of well-known URIs.  The latest Working Draft of "RDF 1.1 Concepts and
>> Abstract Syntax" includes such a spec as section 6.6.1.
>>
>> The permanent URL for this latest version of this text is:
>>          http://www.w3.org/TR/2011/WD-rdf11-concepts-20110830/#section-
>> skolemization
>>
>> I don't know whether this should be registered now, or if we should wait
>> until the document is farther along the W3C standards track.  The Working
>> Group has consensus on the current design and the string "genid" [1], but
>> there has not yet been wide public review, and the document is still a
>> Working Draft. The current schedule [2] has the document completing its
>> public review phase and becoming a Candidate Recommendation in August
>> 2012; perhaps we should wait until then, as long as no one else is going to use
>> the string in the meantime.
>>
>> Also, should the registration template go in an email like this one, or be an
>> appendix to the spec?
>>
>> Thanks for your help,
>>
>>     -- Sandro   (W3C staff contact, RDF Working Group)
>>
>> [1] http://www.w3.org/2011/rdf-wg/meeting/2011-05-25#resolution_2
>> [2] http://www.w3.org/2011/01/rdf-wg-charter#deliverables
>>
>> _______________________________________________
>> wellknown-uri-review mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/wellknown-uri-review

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 15 Nov 2012 12:26:19 +1100

Dear IANA,

Th registration template below is approved for inclusion in the well-known URI registry <http://www.iana.org/assignments/well-known-uris/well-known-uris.xml> .

  URI suffix: genid
  Change controller: W3C
  Related information:

Regards,

--
Mark Nottingham   http://www.mnot.net/