Subject: Request for well-known URI: public.pem

From: Julian Cain <[email-masked]>
Date: Fri, 22 Mar 2013 02:43:47 -0400

Hi,
My service requires a public certificate before performing an action. I am formally requesting /.well-known/public.pem.

Thanks in advance,
Julian

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 25 Mar 2013 20:25:13 +1100

Hi Julian,

To register a well-known URI, its specification needs to be published in a stable place. One way to do that is to submit it as an Internet-Draft, and then request that the RFC Editor publish it on the independent submission track as Informational; see <http://www.rfc-editor.org/indsubs.html>.

However, the specification you've supplied only mentions the public.pem resource tangentially; it needs to be specified more clearly (e.g., what format(s) it should return, as identified by media types, etc.).

Beyond that, there isn't any explanation in the specification you've supplied as to why a well-known URI is needed; please see RFC5785. 

Regards,

--
Mark Nottingham   http://www.mnot.net/