Subject: Review requested for the webfinger well-known URI

From: "Paul E. Jones" <[email-masked]>
Date: Mon, 4 Mar 2013 23:29:38 -0500

Experts,

Could you please review the WebFinger draft that proposes the introduction
of a new well-known URI?

The text can be found here:

http://tools.ietf.org/html/draft-ietf-appsawg-webfinger

Your comments would be appreciated.

Paul

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 14 Mar 2013 09:04:09 -0400

Hi Paul,

Just a suggestion - it might be worth noting in 'related information' that the well-known URI can take a query parameter, with a reference to section 4.1. 

Regardless, request approved.

Cheers,

On 04/03/2013, at 11:29 PM, Paul E. Jones <[email-masked]> wrote:

> Experts,
>  
> Could you please review the WebFinger draft that proposes the introduction of a new well-known URI?
>  
> _______________________________________________
> wellknown-uri-review mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/wellknown-uri-review

--
Mark Nottingham   http://www.mnot.net/

---

From: "Paul E. Jones" <[email-masked]>
Date: Wed, 20 Mar 2013 20:45:32 -0400

Mark,

Sure.  I have to be careful with use of "parameters" as folks get onto me
for using the phrase "query parameter".

How about this:
"The query to the WebFinger resource will include one or more parameters in
the query string.  The representation returned by a WebFinger resource will
be a JSON Resource Descriptor (JRD) as described in Section 4.4 of RFC
XXXX."

Paul

> -----Original Message-----
> From: Mark Nottingham [mailto:[email-masked]]
> Sent: Thursday, March 14, 2013 9:04 AM
> To: Paul E. Jones
> Cc: [email-masked]; IANA
> Subject: Re: Review requested for the webfinger well-known URI
> 
> Hi Paul,
> 
> Just a suggestion - it might be worth noting in 'related information'
> that the well-known URI can take a query parameter, with a reference to
> section 4.1.
>

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 21 Mar 2013 11:56:54 +1100

> be a JSON Resource Descriptor (JRD) as described in Section 4.4 of RFC

I'd do it like this:

"The query to the WebFinger resource will include one or more parameters in the query string; see Section 4.1 of RFCXXXX. Resources at this location are able to return a JSON Resource Descriptor (JRD) as described in Section 4.4 of RFCXXXX."

... because in theory, you could conneg for a different format down the road. 

YMMV.

Cheers,

---

From: "Paul E. Jones" <[email-masked]>
Date: Wed, 20 Mar 2013 21:08:08 -0400

Sounds good.  I'll make that change and present it to the group.

Paul

> Sent: Wednesday, March 20, 2013 8:57 PM
> To: Paul E. Jones
> Cc: 'IANA'; [email-masked]
> > Sure.  I have to be careful with use of "parameters" as folks get onto
> > me for using the phrase "query parameter".
> >
> > How about this:
> > "The query to the WebFinger resource will include one or more
> > parameters in the query string.  The representation returned by a
> > WebFinger resource will be a JSON Resource Descriptor (JRD) as
> > described in Section 4.4 of RFC XXXX."
> 
> I'd do it like this:
> 
> "The query to the WebFinger resource will include one or more parameters
> in the query string; see Section 4.1 of RFCXXXX. Resources at this
> location are able to return a JSON Resource Descriptor (JRD) as
> described in Section 4.4 of RFCXXXX."
> 
> >> that the well-known URI can take a query parameter, with a reference
> >> to section 4.1.
> >>