Subject: Re: Request for well-known URI: est

From: Peter Saint-Andre <[email-masked]>
Date: Fri, 16 Aug 2013 17:01:52 -0600

On 8/15/13 9:29 PM, Dan Harkins wrote:
> 
> 
> On 8/15/13 3:17 PM, "Peter Saint-Andre" <[email-masked]> wrote:
> 
>> On 8/15/13 3:30 PM, Dan Harkins wrote:
>>>
>>>   Is EST the guinea pig for this .well-known stuff? Seems
>>> like it.
>>
>> No, other folks have registered things before:
>>
>> http://www.iana.org/assignments/well-known-uris/
>>
>>>   I have heard nothing but complaints from implementers about
>>> this-- "that's stupid", "why on earth would you require that?",
>>> "nobody does this", etc.-- and would not mind getting a
>>> dispensation from the Canon Law here.
>>
>> I'm not sure that the well-known-uri-review list is really the right
>> place for a long discussion about the philosophy of /.well-known/ :-)
> 
>   Yes, of course. I feel like this is from the movie Brazil.
> 
>   "We only process the 587 stroke 3 forms here, if you want to
> complain about it you must file a 552 stroke 6 with the Bureau
> of Redressing Forms over at the Institute of Assignment." Where
> I will, no doubt, get maced.

:-)

I'd be happy to raise this issue on the apps-discuss list, unless the
application area directors tell me that's not the right place.

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Barry Leiba <[email-masked]>
Date: Fri, 16 Aug 2013 22:31:47 -0400

> application area directors tell me that's not the right place.

I'm not at all sure what the issue is.

Is it, "We don't like .well-known [and/or we don't know why we should
be using it" ?  Or is there something else here?

Barry

---

From: Peter Saint-Andre <[email-masked]>
Date: Fri, 16 Aug 2013 20:34:35 -0600

> be using it" ?  Or is there something else here?

Previously described:

http://www.ietf.org/mail-archive/web/wellknown-uri-review/current/msg00087.html

(Sean seems to have cc'd [email-masked] instead of
[email-masked] on the original thread, so perhaps you missed
that message.)

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Barry Leiba <[email-masked]>
Date: Fri, 16 Aug 2013 22:39:35 -0400

> http://www.ietf.org/mail-archive/web/wellknown-uri-review/current/msg00087.html

Ah.

No, I hadn't seen that.  I agree with Mark on the interpretation, and
that's the advice I had given to Sean.

apps-discuss would be a fine place to chat about that.

b

---

From: Peter Saint-Andre <[email-masked]>
Date: Fri, 16 Aug 2013 20:50:40 -0600

> that's the advice I had given to Sean.

The IANA Considerations section of the EST spec says:

   IANA is to update the well-known URI registry with the following
   filled-in template from [RFC5785].

      URI suffix: est

      Change controller: IETF

That doesn't cover what it needs to cover, i.e., the kind of information
mentioned in RFC 5785:

   Typically, a registration will reference a specification that defines
   the format and associated media type to be obtained by dereferencing
   the well-known URI.

   It MAY also contain additional information, such as the syntax of
   additional path components, query strings and/or fragment identifiers
   to be appended to the well-known URI, or protocol-specific details
   (e.g., HTTP [RFC2616] method handling).

None of that "additional information" is in the registration request, so
it's not clear to me that IANA will have the information it needs to
properly process this registration.

> apps-discuss would be a fine place to chat about that.

I'll raise the more general issue there.

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: SM <[email-masked]>
Date: Fri, 16 Aug 2013 20:13:57 -0700

Hi Sean,
>properly process this registration.

IANA, in its review of the draft, mentioned that it needs the 
following information:

   URI suffix: est
   Change controller: IETF
   Reference: [ RFC-to-be ]
   Related Information:
   Date Registered: [ TBD-at-registration ]
   Date Modified:

Could you please suggest to the authors of draft-ietf-pkix-est to add:

   Reference: [this document]

to the request for the well-known URI in Section 6?

Regards,
-sm

---

From: Peter Saint-Andre <[email-masked]>
Date: Fri, 16 Aug 2013 21:22:48 -0600

On 8/16/13 9:13 PM, SM wrote:
> IANA, in its review of the draft, mentioned that it needs the following
> information:
> 
>   URI suffix: est
>   Change controller: IETF
>   Reference: [ RFC-to-be ]
>   Related Information:

I don't think that really helps matters, because it's still unclear
whether each of the well-known URIs (cacerts, simpleenroll, etc.) needs
to be added to the registry, whether IANA needs to deny future requests
that start with "est" (e.g., "/.well-known/estimation") since "the
syntax of additional path components" (RFC 5785) is not specified, etc.
If the EST spec is reserving any path component after "est" (as in
"/.well-known/est/cacerts", "/.well-known/est/arbitraryLabel1/cacerts",
etc.) then IMHO that needs to be defined in the EST spec. I don't think
the EST spec is trying to reserve *any* well-known URI that starts with
"est" but that too isn't clear. I think we all have a sense of what the
EST spec and RFC 5785 are trying to do in such cases, but it's not
specified very well in this case or in general.

But maybe I'm making a mountain out of a mole hill...

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: SM <[email-masked]>
Date: Fri, 16 Aug 2013 20:58:28 -0700

Hi Peter,
>But maybe I'm making a mountain out of a mole hill...

I don't think that you are making a mountain out of a mole hill.  I 
commented on the template to try and get the clerical issue out of the way.

I read RFC 5785.  Whether each of the well-known URIs needs to be 
added is subject to interpretation.  I don't think that it is 
possible to fix that, if a fix is needed, quickly.  The workaround 
would be to use the "related information" field to specify the syntax 
of additional path components.

Regards,
-sm

---

From: Sean Turner <[email-masked]>
Date: Mon, 19 Aug 2013 18:25:51 -0400

Yep - I can make sure they do that.

spt

---

From: Mark Nottingham <[email-masked]>
Date: Fri, 23 Aug 2013 13:10:45 +1000

> specified very well in this case or in general.

5785 requires the registered value to "conform to the segment-nz production" defined in the URI specification. It also allows a registration's spec to "contain additional information, such as the syntax of additional path components, query strings and/or fragment identifiers to be appended to the well-known URI".

This means that the registration for "est" controls the path "/.well-known/est/foo" but not ".well-known/estimation".  

I think it'd be a stretch to read it any other way. Could it be more clear? Perhaps, but this is one of the reasons we have expert review.

Cheers,

--
Mark Nottingham   http://www.mnot.net/