Subject: Re: Request for well-known URI: associations.json

From: Patrick Stahlberg <[email-masked]>
Date: Thu, 14 May 2015 11:06:42 -0400

Hi again,

our project has evolved a bit.  We would still like to store information
about the relationship between online assets, but the information is going
to be encoded in the form of "statements".  Therefore, we think a more
fitting name would now be:

  .well-known/statements.json

Do we still have your preliminary approval for this new name?

Thanks,
Patrick

On Tue, Mar 31, 2015 at 9:08 PM, Patrick Stahlberg <[email-masked]>
wrote:

> Hi Mark,
>
> Thanks!  We will let you know.
>
> --
> Patrick
>  On Mar 31, 2015 8:52 PM, "Mark Nottingham" <[email-masked]> wrote:
>
>> Hi Patrick,
>>
>> Sure. Best thing to do is to ping this list once your spec becomes public
>> (even in draft form), and we’ll do the registration.
>>
>> Cheers,
>>
>>
>> > On 1 Apr 2015, at 5:20 am, Patrick Stahlberg <[email-masked]>
>> wrote:
>> >
>> > Hi,
>> >
>> > I am writing on behalf of a team at Google working on new ways to
>> surface associations between web sites and other online "assets".  For a
>> planned launch, we would like to register the well-known URI
>> "associations.json" as requested in RFC 5785.
>> >
>> > We would like to ask web site owners to publish a file at this location
>> that follows a simple JSON format and that includes information about other
>> assets that are related to the site on which the associations.json is
>> published.  We plan for the format to be open and usable by anyone.  We
>> would like to publish a full specification of the format once we have
>> enough confidence internally in its design.
>> >
>> >
>> > Thanks,
>> > Patrick
>> > _______________________________________________
>> > wellknown-uri-review mailing list
>> > [email-masked]
>> > https://www.ietf.org/mailman/listinfo/wellknown-uri-review
>>
>> --
>> Mark Nottingham   https://www.mnot.net/
>>
>>

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 19 May 2015 14:41:12 +1000

Hi Patrick,

Again, having the spec is the next necessary step. I can't really comment on the name until I've seen it — although "statements" is *extremely* generic.

Cheers,

> On 15 May 2015, at 1:06 am, Patrick Stahlberg <[email-masked]> wrote:
> 
> Hi again,
> 
> our project has evolved a bit.  We would still like to store information about the relationship between online assets, but the information is going to be encoded in the form of "statements".  Therefore, we think a more fitting name would now be:
> 
> On Tue, Mar 31, 2015 at 9:08 PM, Patrick Stahlberg <[email-masked]> wrote:
> Hi Mark,
> 
> Sure. Best thing to do is to ping this list once your spec becomes public (even in draft form), and we’ll do the registration.
> 
> Cheers,
> 
> 
> > On 1 Apr 2015, at 5:20 am, Patrick Stahlberg <[email-masked]> wrote:
> >
> > Hi,
> >
> > I am writing on behalf of a team at Google working on new ways to surface associations between web sites and other online "assets".  For a planned launch, we would like to register the well-known URI "associations.json" as requested in RFC 5785.
> >
> > We would like to ask web site owners to publish a file at this location that follows a simple JSON format and that includes information about other assets that are related to the site on which the associations.json is published.  We plan for the format to be open and usable by anyone.  We would like to publish a full specification of the format once we have enough confidence internally in its design.
> >
> >
> > Thanks,
> > Patrick

---

From: Patrick Stahlberg <[email-masked]>
Date: Wed, 20 May 2015 06:38:15 -0400

Hi Mark,

apologies -- I had read your earlier email as "you're good to go; just send
us the spec when your product launches".  That's entirely my fault.

We've prepared a spec and it's attached as a PDF file.  It's still in a
somewhat rough shape, but should have all the important pieces.

Thanks,
Patrick

On Tue, May 19, 2015 at 12:41 AM, Mark Nottingham <[email-masked]> wrote:

> Hi Patrick,
>
> Again, having the spec is the next necessary step. I can't really comment
> on the name until I've seen it — although "statements" is *extremely*
> generic.
>
> Cheers,
>
>
>
> > Sure. Best thing to do is to ping this list once your spec becomes
> public (even in draft form), and we’ll do the registration.
> >
> > Cheers,
> >
> >
> > > We would like to ask web site owners to publish a file at this
> location that follows a simple JSON format and that includes information
> about other assets that are related to the site on which the
> associations.json is published.  We plan for the format to be open and
> usable by anyone.  We would like to publish a full specification of the
> format once we have enough confidence internally in its design.
> > >
> > >
> > > Thanks,
> > > Patrick

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 21 May 2015 15:05:32 +1000

Thanks.

"statements.json" does indeed seem very generic; is there a reason you're not using something like "asset_statements.json"?

Cheers,

> On 20 May 2015, at 8:38 pm, Patrick Stahlberg <[email-masked]> wrote:
> 
> Hi Mark,
> 
> apologies -- I had read your earlier email as "you're good to go; just send us the spec when your product launches".  That's entirely my fault.
> 
> We've prepared a spec and it's attached as a PDF file.  It's still in a somewhat rough shape, but should have all the important pieces.
> 
> 
> Thanks,
> Patrick
> 
> 
> <AssetLinksWell-KnownURISpec.pdf>_______________________________________________

---

From: Patrick Stahlberg <[email-masked]>
Date: Thu, 21 May 2015 07:00:16 -0400

We wanted something short, but we absolutely see your point about it being
generic. asset_statements.json doesn't sound too bad, but it's quite long
and we worry that people will get confused about whether there is a dash or
an underscore in the name. Does "assetlinks.json" or even simply
"assetlinks" sound acceptable to you?

Thanks,
Patrick
 On May 21, 2015 1:05 AM, "Mark Nottingham" <[email-masked]> wrote:

> Thanks.
>
> "statements.json" does indeed seem very generic; is there a reason you're
> not using something like "asset_statements.json"?
>
> Cheers,
>
>
>
> > apologies -- I had read your earlier email as "you're good to go; just
> send us the spec when your product launches".  That's entirely my fault.
> >
> > Again, having the spec is the next necessary step. I can't really
> comment on the name until I've seen it — although "statements" is
> *extremely* generic.
> >
> > Cheers,
> >
> >
> >
> > > our project has evolved a bit.  We would still like to store
> information about the relationship between online assets, but the
> information is going to be encoded in the form of "statements".  Therefore,
> we think a more fitting name would now be:
> > >

---

From: Patrick Stahlberg <[email-masked]>
Date: Thu, 21 May 2015 11:23:41 -0400

Hi Mark,

after conferring with the team, we would like to request
"assetlinks.json".  Thanks for bearing with us while we make up our minds.

-- 
Patrick

---

From: Patrick Stahlberg <[email-masked]>
Date: Wed, 27 May 2015 21:29:48 -0400

Hi Mark,

friendly ping :)  -- how does assetlinks.json sound?

-- 
Patrick

On Thu, May 21, 2015 at 11:23 AM, Patrick Stahlberg <[email-masked]>
wrote:

>> We wanted something short, but we absolutely see your point about it
>> being generic. asset_statements.json doesn't sound too bad, but it's quite
>> long and we worry that people will get confused about whether there is a
>> dash or an underscore in the name. Does "assetlinks.json" or even simply
>>> "statements.json" does indeed seem very generic; is there a reason
>>> you're not using something like "asset_statements.json"?
>>>
>>> Cheers,
>>>
>>>
>>>
>>> > We've prepared a spec and it's attached as a PDF file.  It's still in
>>> a somewhat rough shape, but should have all the important pieces.
>>> >
>>> >
>>> > Thanks,
>>> > Patrick
>>> >
>>> >