Subject: Request for well-known URI: dnt-policy.txt

From: Alan Toner <[email-masked]>
Date: Wed, 12 Aug 2015 01:52:06 +0200

This is a request on behalf of the Electronic Frontier Foundation for
the registration of the well-known uri: dnt-policy.txt

Websites are asked to post such a file to indicate compliance with EFF's
Do Not Track policy.

Uri: dnt-policy.txt

Change controller: Electronic Frontier Foundation, 815 Eddy Street
San Francisco, CA 94109-7701

Specification document(s): https://www.eff.org/dnt-policy

There is currently no separate specification document, just the policy
itself and a list of previous acceptable versions. Am I correct in
believing that a specification will have to be posted in order for this
application to be approved?

Thanks,

Alan

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 17 Aug 2015 15:56:11 +1000

IANA,

The registration below is approved; please enter it into the registry of Well Known URIs <https://www.iana.org/assignments/well-known-uris/well-known-uris.xml>.

Regards,

> Begin forwarded message:
> 
> From: Alan Toner <[email-masked]>
> Subject: Request for well-known URI: dnt-policy.txt
> Date: 12 August 2015 9:52:06 am AEST
> To: [email-masked]
> Archived-At: <http://mailarchive.ietf.org/arch/msg/wellknown-uri-review/l-6B-xfh-MKOAJ4I-0dlS5oCd-E>
> 

--
Mark Nottingham   https://www.mnot.net/

---

From: "Roy T. Fielding" <[email-masked]>
Date: Mon, 17 Aug 2015 10:55:39 -0700

I have to say that this is extremely poor behavior on the part of EFF.

The well-known URI dnt has been agreed to by the W3C working group, including
the EFF, for more than three years.  The purpose for which they are using this
new, confusing, and incredibly inefficient "dnt-policy.txt" resource is identical
to a dnt representation of {tracking="N", compliance=["https://www.eff.org/dnt-policy"]}.

IOW, the private EFF registration is non-standard, redundant, and far less
efficient than the existing specification for DNT requires.  That should be
noted in their registration.

....Roy

> On Aug 16, 2015, at 10:56 PM, Mark Nottingham <[email-masked]> wrote:
> 
> IANA,
> 
> _______________________________________________
> wellknown-uri-review mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/wellknown-uri-review

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 19 Aug 2015 12:00:41 +1000

Hey Roy,

> On 18 Aug 2015, at 3:55 am, Roy T. Fielding <[email-masked]> wrote:
> 

I don't think it's appropriate to say that in the registration; we don't judge the quality of registration entries beyond what's required by the well-known RFC, and I think that the material there (and in DNT's entry) is sufficient to disambiguate them.

Cheers,