Subject: Well known URI registration: "time"

From: Poul-Henning Kamp <[email-masked]>
Date: Wed, 02 Dec 2015 12:24:50 +0000

Hi,

We are working on a stop-gap protocol for authenticating timekeeping
via HTTPS web-servers for rapid deployment until efforts like NTS
etc can get rolled out in the coming years.

Since this idea piggybacks on HTTPS the server side is already
available, all that is needed is client side software and
specifications for use.

First cut of a specification is here, while it is being worked on
by the NTP-hackers community:

	http://phk.freebsd.dk/time/20151129.html

Once we have filed on it, a IETF draft will be pushed.

I kindly ask that IANA allocate a well-known URI for this purpose.

It really doesn't matter what it is named, "well-known/time"
seems rather obvious, but we'll take anything we can get.

Thanks in advance,

Poul-Henning Kamp

-- 
Poul-Henning Kamp       | UNIX since Zilog Zeus 3.20
[email-masked]         | TCP/IP since RFC 956
FreeBSD committer       | BSD since 4.3-tahoe
Never attribute to malice what can adequately be explained by incompetence.

---

From: Mark Nottingham <[email-masked]>
Date: Mon, 7 Dec 2015 11:25:47 +1100

IANA,

The following entry in the well-known URI registry <https://www.iana.org/assignments/well-known-uris/well-known-uris.xhtml> is approved:

* URI Suffix: time
* Change Controller: Poul-Henning Kamp <[email-masked]>
* Reference: http://phk.freebsd.dk/time/20151129.html
* Related Information:

Cheers,

> On 2 Dec 2015, at 11:24 pm, Poul-Henning Kamp <[email-masked]> wrote:
> 
> Hi,
> 
> _______________________________________________
> wellknown-uri-review mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/wellknown-uri-review

--
Mark Nottingham   https://www.mnot.net/