Subject: Request for well-known URI: ashrae

From: Dave Robin <[email-masked]>
Date: Mon, 18 Jan 2016 18:58:42 -0500

Greetings, 

As part of our on-going development of standard protocols for building automation, we are requesting a /.well-known suffix. (We have already registered the needed Content-Types mentioned in the referenced document)

URI suffix:  "ashrae"

Change controller:  American Society of Heating, Refrigeration, and Air-conditioning Engineers (ASHRAE) www.ashrae.org

Specification document(s):  http://www.bacnet.org/Addenda/Add-135-2012am-ppr3-draft-17_chair_approved.pdf

Related information:  The referenced document is a new version of BACnet/WS (Building Automation and Control network / Web Services). BACnet (ANSI/ASHRAE Standard 135 and ISO Standard 16484-5) is the dominant protocol for commercial, industrial, and institutional building automation and control.  The primary protocol is based on binary encoded ASN.1 data structures.  This is a RESTful JSON and XML versions of that, plus numerous web-services-only features.  Initially, we need a way to discover URI prefixes for the resources on a given BACnet/WS server.  However, this /.well-known is being requested for "ashrae", rather than just "bacnet", so that other uses by the ASHRAE engineering society can be defined in the future.
 
Thank you for your consideration,
Dave Robin
Editor, BACnet Web Services

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 19 Jan 2016 16:02:08 +1100

Hi Dave,

Looks good. Do you mind if we omit the 'related information' in the registry entry?

Cheers, 

> On 19 Jan 2016, at 10:58 am, Dave Robin <[email-masked]> wrote:
> 
> Greetings, 
> 
> _______________________________________________
> wellknown-uri-review mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/wellknown-uri-review

--
Mark Nottingham   https://www.mnot.net/

---

From: Dave Robin <[email-masked]>
Date: Tue, 19 Jan 2016 01:39:26 -0500

> Looks good. Do you mind if we omit the 'related information' in the registry entry?

Not at all.  That was for your benefit. I didn't intend that to be part of the registry.  My mistake.

One issue... a bit of a chicken and egg, actually.  Since we are a overly-careful publicly-reviewed ANSI and ISO standard, some folks did not want to publish the standard until the postfix was registered, but if the registration contains a "Specification Document" that points to pre-publication public review version of our standard, they don't like that either!  dueling dependencies!

You see, that link I included is to bacnet.org <http://bacnet.org/>, which is a kind of a staging area for what will eventually be published at ashrae.org. 

So, the questions are: 
after registration...
1) what is the procedure to update the "Specification Document" when we get a fully published version?
2) can we list *two* specification documents?  (some folks might prefer to get the ISO standard rather then the ANSI/ASHRAE one).

Thanks!
Dave

---

From: Mark Nottingham <[email-masked]>
Date: Tue, 19 Jan 2016 17:41:44 +1100

> On 19 Jan 2016, at 5:39 pm, Dave Robin <[email-masked]> wrote:
> 

No worries.

> You see, that link I included is to bacnet.org, which is a kind of a staging area for what will eventually be published at ashrae.org. 
> 
> So, the questions are: 
> after registration...

Just send another e-mail, updates aren't an issue.

> 2) can we list *two* specification documents?  (some folks might prefer to get the ISO standard rather then the ANSI/ASHRAE one).

Hmm. We can ask IANA to do that, and if it's not possible, to put the second one in the "related information" field. If the latter happens, do you have a preference for which goes there?

Cheers,