Subject: Re: Request for well-known URI: matrix

From: Mark Nottingham <[email-masked]>
Date: Mon, 8 Apr 2019 10:55:22 +1000

Hello,

Apologies for the delay; I was waiting for RFC5785 to be approved before moving forward on some registrations.

This request looks good, but I wonder if you could provide a more stable URI for the specification document? If not, you'll need to make a request to update the entry each time it changes.

Tell me what you think and we'll get this registered.

Cheers,

> On 8 Mar 2019, at 8:37 pm, J. Ryan Stinnett <[email-masked]> wrote:
> 
> Registry experts -
> 
> The Matrix protocol defines a set of open APIs for decentralised communication. As part of that protocol, we have begun using URLs of the format "https://<server>/.well-known/matrix/*" to allow a server to indicate that it delegates Matrix communication to a separate server. We'd like to add this to the .well-known registry as described in RFC 5785.
> 
> URI suffix: matrix
> Change controller:
>   The Matrix.org Foundation C.I.C.
>   <https://matrix.org>
> Specification document(s):
>   Matrix Client-Server API
>   <https://matrix.org/docs/spec/client_server/r0.4.0.html#well-known-uri>
>   Matrix Server-Server API
>   <https://matrix.org/docs/spec/server_server/r0.1.1.html#get-well-known-matrix-server>
> 
> Thanks,
> J. Ryan Stinnett
> _______________________________________________
> wellknown-uri-review mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/wellknown-uri-review

--
Mark Nottingham   https://www.mnot.net/

---

From: "J. Ryan Stinnett" <[email-masked]>
Date: Tue, 9 Apr 2019 10:46:03 +0100

> On 8 Apr 2019, at 01:55, Mark Nottingham <[email-masked]> wrote:
> 

Thanks for the initial review and feedback. I agree a stable URI does sound simpler. Let's go with the following then:

URI suffix: matrix
Change controller:
  The Matrix.org Foundation C.I.C.
  https://matrix.org
Specification document(s):
  Matrix Client-Server API
  https://matrix.org/docs/spec/client_server/latest.html#well-known-uri
  Matrix Server-Server API
  https://matrix.org/docs/spec/server_server/latest.html#get-well-known-matrix-server

The "latest.html" path points to the latest versioned release of each spec document, so that seems like a better fit for the .well-known registry.

Thanks,
J. Ryan Stinnett

---

From: Mark Nottingham <[email-masked]>
Date: Wed, 10 Apr 2019 10:07:12 +1000

Sounds good. 

There's a new field in the template that needs to be filled - "status" (added by RFC5785bis, currently approved and at the RFC Editor).

My inclination here is to make it "permanent". 5785bis requires consultation with the community for that (since AFAICT matrix.org is not recognised by the IETF as an Open Standards body, in the sense of RFC2026). I've copied [email-masked] here to see if anyone has an issue with that. 

If we don't hear pushback over the next few days, we'll get IANA to register it.

Cheers,

> On 9 Apr 2019, at 7:46 pm, J. Ryan Stinnett <[email-masked]> wrote:
> 
>

---

From: Mark Nottingham <[email-masked]>
Date: Sat, 13 Apr 2019 13:12:54 +1000

IANA,

Please make the registration below in the Well Known URIs registry, with a status of permanent.

Regards,

---

From: Mark Nottingham <[email-masked]>
Date: Sat, 13 Apr 2019 13:29:12 +1000

This time CC:ing IANA.

> On 13 Apr 2019, at 1:12 pm, Mark Nottingham <[email-masked]> wrote:
> 
> IANA,
>