Subject: RE: WG charter update technology (Re: area directors at risk)

From: Jonathan Rosenberg <[email-masked]>
Date: Sun, 25 Nov 2001 16:11:44 -0500

> -----Original Message-----
> From: Henning Schulzrinne [mailto:[email-masked]]
> Sent: Thursday, November 22, 2001 10:12 AM
> To: Alain Durand
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: Re: WG charter update technology (Re: area directors at risk)
> 
> 
> Two large protocol projects I'm involved with has used 
> mozilla to track
> comments and "bug reports" in the working group, and could 
> presumably be
> used for the IESG comments as well. That way, it is easy to 
> see whether
> the comment has been addressed and whether anything has fallen through
> the cracks. This is probably not appropriate for 2-page documents, but
> maybe the IETF could set up a mozilla (or similar system) for general
> use, as a service to working groups. This is no substitute 
> for diligence
> of the authors and chairs, but it does seem to help avoiding 
> raising the
> same issue again and again.

Just to help clarify, the tool we've been using on the SIP spec is the
mozilla bug tracking tool, called bugzilla. Its worked really well,
especially with a document that has multiple editors that are actively
working on different sections. It also helps to keep track of threads on the
list; threads are often titled "open issue #23" which refers to a bug in the
system, so that its easy to reference back to the original issue and what
changes have been made to resolve it.

You can get bugzilla for free from:
http://www.mozilla.org/projects/bugzilla/

-Jonathan R.
---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com

---

From: Marc Blanchet <[email-masked]>
Date: Sun, 25 Nov 2001 16:40:43 -0500

- while I don't want to start a debate on tools
- and I know tools are there to help humans, not the inverse,
- engineers often resolve human process by software tools, which sometimes 
helps, sometimes not.

In this case, it could help, but could not resolve all.

so on the same line of "tools",
one suggestion could be to install the sourceforge.net software on one ietf 
"server". This handle projects (which in our case could be working groups 
as well as areas) and have all the necessary tools: project tasks, bug 
reporting, mailing lists, ...
cost: one PC, open source software, some sysadmin time. some customization, 
but should be used as is...

Marc.

-- dimanche, novembre 25, 2001 16:11:44 -0500 Jonathan Rosenberg 
<[email-masked]> wrote/a écrit:

> working on different sections. It also helps to keep track of threads on
> the list; threads are often titled "open issue #23" which refers to a bug
> in the system, so that its easy to reference back to the original issue
> and what changes have been made to resolve it.
>

------------------------------------------
Marc Blanchet
Viagénie
tel: +1-418-656-9254x225

------------------------------------------
http://www.freenet6.net: IPv6 connectivity
------------------------------------------
http://www.normos.org: IETF(RFC,draft),
  IANA,W3C,... standards.
------------------------------------------