Subject: RE: Number of authors on RFCs

From: "Natale, Robert C (Bob)" <[email-masked]>
Date: Tue, 26 Mar 2002 10:28:55 -0500

Hi,

> From: George Swallow [mailto:[email-masked]]
...
> 1. List just the editor on the cover.  The editor serves as a single
>    point of contact for the RFC-editor and the IESG review.

Yes.

> 2. Note in the abstract and/or introduction that the document was the
>    collaboration of an extensive number of people.

Intro.  *Not* in the Abstract.
> 
> 3. List all of the authors in the author section.
> 
> I've been told that this will not fly.

Sounds good to me.

Cordially,

BobN

---

From: [email-masked]
Date: Tue, 26 Mar 2002 11:42:06 -0500

George, I think you idea looks like it would "fly" as you say.  With so 
many authors, it gets really hard to contact people afterwards - many move 
onto other things.  I know that is what the method reviewer is supposed to 
handle - but still, if you have 6 or more authors, it becomes too 
cumbersome for everyone, especially the AD's.  I vote for your idea!

---

From: Thomas Hardjono <[email-masked]>
Date: Tue, 26 Mar 2002 11:47:43 -0500

Hi,

In my experience, the names listed on a draft may not correspond
to the actual people doing the work.

Also, often a long list of names on a draft is motivated by the need
of these names (or their companies) to indicate (political) support for
the work being proposed.  Sales people often need to mention loosely
to their customers that their company's proposal is "an RFC" in the IETF.

Regardless of the motivation or circumstances, I think the current
approach of listing names on the front cover seems to satisfactory
for 95% of the drafts.

If a list of authors gets too long, well most readers will guess
that those names are there to indicate support, not necessarily
work done.  Also, if its ridiculously long, then the authors will
need to decide whether their reputation is on the line.

Perhaps of more concern is whether the presence of an individual's name
indicates his/her support or their company's support.
If I'm not mistaken, the formal stand of the IETF is that individuals
make-up participation in the IETF (not companies).  However,
the long list of names on a draft is evidence that the perception
out there does not coincide with the IETF's stand.

Another option is to have a list of authors in the front cover,
and a list of supporting individuals/companies at the end-cover.

thomas
------

---

From: "Ong, Lyndon" <[email-masked]>
Date: Tue, 26 Mar 2002 09:29:05 -0800

Hi Thomas!

You're certainly right about politics often
playing a part in this.  In fairness to the 
MPLS/GMPLS drafts, though,
some tend to be pretty hefty and were worked
on over a lengthy period, so it's natural that
the list of people who did meaningfully
contribute may get to be pretty long.

Ran's suggestion sounds reasonable to me,
for documents with this issue.  People who
contributed will be recognized, and there is
still one or a small number of editors listed
as point of contact.

Cheers,

Lyndon

-----Original Message-----
From: Thomas Hardjono [mailto:[email-masked]]
Sent: Tuesday, March 26, 2002 8:48 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: Number of authors on RFCs

Hi,

thomas
------

---

From: "Tom-PT Taylor"<[email-masked]>
Date: Tue, 26 Mar 2002 12:39:47 -0500

I have a similar problem with Megaco.  In the first place, we built on MGCP,
so we inherited their authors.  Then we had major contributions from a pile
of people.  Thanks to our cooperation with the ITU-T, we had two official
editors.

For Megaco v2 I'm restricting the author's list to the Editor and putting
everyone else into Acknowledgements.

-----Original Message-----
From: Ong, Lyndon [mailto:[email-masked]]
Sent: Tuesday, March 26, 2002 12:29 PM
To: 'Thomas Hardjono'; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: Number of authors on RFCs

Hi Thomas!

Cheers,

Lyndon

-----Original Message-----
From: Thomas Hardjono [mailto:[email-masked]]
Sent: Tuesday, March 26, 2002 8:48 AM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: RE: Number of authors on RFCs

Hi,

thomas
------

---

From: "Pat R. Calhoun" <[email-masked]>
Date: Tue, 26 Mar 2002 13:21:50 -0800

> 	In the vast majority of cases, one's original personal I-D
> benefits from the  inputs/ideas of many many folks in the WG. Also,
> having EDITOR for WG documents is not  inconsistent with the way
> things work in other fora (e.g. IEEE 802, ITU-T), so ought not  be
> a total shock to folks.

Right, but IEEE documents contain a complete list of folks that
attended the meeting during the standardization process... at the
beginning. The issue I have with this proposal is that it occurs that
someone has a great idea, writes it up, and then during the rather
long standardization process, must fall off the map for one reason or
another. This individual contributed major text to the document, but
is not recognized.

PatC

---

From: "Kastenholz, Frank" <[email-masked]>
Date: Tue, 26 Mar 2002 16:29:29 -0500

At 11:18 AM 3/26/02 -0800, James Kempf wrote:

>The problem is that many
>people involved in the IETF are evaluated by their employers based on
>their authorship of Internet drafts 

This is behavior for which we should apply negative, not
positive, feedback. 

Frank Kastenholz

==================================================
My preferrred signature is:
        This information is for the sole use of 
        whoever receives it and may contain confusing,
        enlightening, enraging, entertaining,
        irritating, or just plain stupid information,
        including without limitation, double-secret-
        probation information belonging to [CENSORED 
        BY THE NSA/FBI/MOUSE]. Any unauthorized review,
        use, disclosure, or distribution outside of an
        establishment serving alchohol is prohibited on
        days that do not end in Y.
But our ******'d lawyers would rather have:

======================================= 
This email message is for the sole use of the intended recipient (s) and may
contain confidential and privileged information, including without
limitation, Confidential and/or Proprietary Information belonging to
Unisphere Networks, Inc. Any unauthorized review, use, disclosure or
distribution is prohibited. If you are not the intended recipient, please
contact the sender by reply email and destroy all copies of the original
message.

---

From: Eastlake III Donald-LDE008 <[email-masked]>
Date: Tue, 26 Mar 2002 16:30:47 -0500

There needs to be a way to make exceptions when called for but a rule, even
if somewhat arbitrary, would make it easier for WG Chairs to tell people
there name has to be moved down to an acknowledgements section even though
they were one of the middle tier contributors to one of the document merged
into a draft or whatever.

Donald

-----Original Message-----
From: Dean Willis [mailto:[email-masked]]
Sent: Tuesday, March 26, 2002 4:09 PM
To: 'Eastlake III Donald-LDE008'; 'George Swallow'; [email-masked]
Cc: [email-masked]
Subject: RE: Number of authors on RFCs

> I think it would be beneficial to have a statement that, 
> while all significant contributors should be acknowledged, by 
> "author" of an RFC is meant "editor" (that's how I have tried 
> to treat it, not always successfully). As a result, the most 
> plausible number of editors is one although there may 
> occasionally be cases where two people actually co-edited, or 
> one person did most of the editing and a second person 
> finished up a document, or one author contributed the 
> overwhelming majority of a document even though they didn't 
> edit it, where two or even three names were justified. 
> Whenever I see more than three authors on an RFC, I am 
> inclined to think that something funny is going on and 
> probably most of them were not editors of the document.

I would like to point out that the latest SIP RFC actually DID have a
large number of editors (7, as I recall). They literally carved the TeX
source up into separate files, checked it into CVS, and checked it in
and out of CVS as it was updated. We tracked open issues and editorial
assignments in bugzilla, and there were something like 600 of them in
the final phase.

--
Dean

---

From: Melinda Shore <[email-masked]>
Date: Tue, 26 Mar 2002 17:00:15 -0500

At 10:06 PM 3/26/02 +0100, Lars-Erik Jonsson (EPL) wrote:
>The significant difference is that in those bodies one is contributing
>on behalf of his/her employer, while in the IETF we are contributing as
>individuals. In the telco bodies, there is no individual interest, so
>participation is not affected by the lack of acknowledgement for good
>individual work. This is the IETF, not a telco-body.

That last sentence is certainly debatable - like it or no,
the IETF is currently developing telecomm standards.  I'm not
sure what bearing that has on this discussion, though.

Also, I've been finding in my working group that if you completely
disregard institutional issues you can end up with a mess, 
particularly when it comes to choosing one proposal from among
many, most of which have IPR claims.  I think this is related to
Radia's talk on Thursday - where does bad behavior come from?  In
part it comes from a conflict between people who are trying to
do what's good for the internet and people who are trying to do
what's good for their company, and I don't think that there's any
question that there's greater personal gain to be had from aligning
yourself with the latter interest than with the former, especially
in this economy.  If authorship issues are contributing to bad
behavior in the IETF it wouldn't hurt to rethink how authorship
is handled, even if we end up right back where we are now.

Melinda

---

From: [email-masked] (Sean Doran)
Date: Tue, 26 Mar 2002 22:39:35 +0000 (GMT)

| ... I get contacted periodically concerning RFCs I have authored

SPAM address harvesters remind you you're alive?

More seriously, is there a strong need to initiate suggestions / debate things
and so forth one-on-one rather than in a public forum when it comes to
the STD series of RFCs?  (There is probably no hope of keeping
such interesting discussion public...)

Also, would we drown in a sea of "who do I contact about STD-xx?" messages
to the IETF list or RFC Editor if the author information wasn't in
the Requirements For Compliance itself, *and* kept current there?

(And is it stupid to suggest [email-masked] as a permanent
way of contacting the authors, for the reasons Don mentions?)

| I don't see what the problem with [residential addresses in RFCs] 
| is supposed to be.

If you had been a stripper like Vint Cerf, or were otherwise likely
to have problems with stalkers, kidnappers, UNABOMers, and so forth, 
you would certainly object to having your home address very publically
available on a widely-circulated technical document.

| I don't think that any change is needed.

IMHO, requiring a residential postal address would be a more serious change than
using indirection ("please see http://rfc.ietf.org/author-info/rfc-xxx.html").

	Sean.