Subject: Chatroom feedback in a WG session?

From: Harald Alvestrand <[email-masked]>
Date: Sun, 29 Sep 2002 07:16:52 +0200

Folks,

last IETF, I talked with the multicast folks about feedback from remote 
attendees to a WG meeting.

In recent years, we've never had successful multicast-based audio feedback, 
so we've stopped trying to provide for it.

One thing we wanted to try, though, is to see whether a chat-based feedback 
could work.
This could take one or two (out of many) forms:

- A chatroom where the meeting chair has it up on his screen, and reads 
comments aloud when they seem particularly relevant to the discussion

- A chatroom that is permanently displayed on an alternate projector

We'd like you to think about whether your WG would like to be a "victim" 
for such an experiment, and how you would prefer to execute it (chat 
technology, security setup, choice among the choices above, other 
considerations).

If successful, we might consider making it part of the standard setup for 
the multicast rooms.

Thoughts?

                  Harald

---

From: Randy Bush <[email-masked]>
Date: Sat, 28 Sep 2002 22:21:03 -0700

chatroom requires software, technology, chair/catcher to be using
the same IM environment as the person wanting to chat, ...

why place barriers?

how about starting with something brutal and simple such as email
to the chair or, considering a chair tends to be busy, someone
appointed to catch a mail alias?

randy

---

From: Melinda Shore <[email-masked]>
Date: Sun, 29 Sep 2002 08:39:15 -0400

I recently spoke in a videoconferenced conference session (I
was remote, too), and I thought it was a great experience.
The only real drawback, and it was a big one, was that
participants needed either a hardware videoconferencing
setup or a Windows client.  If there were some way to do
this in a platform-independent way, or if, at least, there
were support for a multiplicity of platforms, I'd be very
interested.

Melinda

---

From: Marshall Rose <[email-masked]>
Date: Sun, 29 Sep 2002 08:56:41 -0700

>> melinda:

well, the obvious solution is to use jabber, since it supports conferences, is a software-only solution running on all platforms, and there are servers out there that will host your conference rooms for free.

you need one person in the room with with wifi and a jabber client. ideally, you can get the speakers to have their presentations available via http:// before the meeting, so the person doing the loose transcription can type in the url into the conference room. (that's how a lot of other organizations do this stuff now.)

of course, we're in the process of deciding whether or not to have a post-jabber wg, so this might create a political problem for some.

>> randy:
> > "- A chatroom that is permanently displayed on an alternate
> > projector"
> > Unmonitored?  This represents a potential distraction to the WG
> > as a whole.
> 
> i.e., it better simulates the remote participant being there in
> person.  fair is fair <g>.

err, that's not entirely true. in a physical meeting, it's usually the case that people will behave themselves and not go running up to the mic every 3 words and start speaking over the person at the front of the room...

however, setting aside the cost of a second projector, i like the idea. but, my question to you is whether you could live with "someone with the manners of a jim fleming" being a remote participant...

/mtr

---

From: Randy Bush <[email-masked]>
Date: Sun, 29 Sep 2002 10:46:06 -0700

it is non-trivial to set up a secure jabber client in an ideal
(i.e. bsd:-) environment.  folk are having hell setting it up
in windoze and other environments.

again, we are trying to deal with the difficulties folk seem to
be having participating using a decade+ old technology, multicast.
perhaps we should not get too deeply enamoured of high-tech and
just go with email.

randy

---

From: Rohan Mahy <[email-masked]>
Date: Sun, 29 Sep 2002 10:43:50 -0700

Marshall,

I know that some have complained about poor security in jabber, and 
that was a motivating factor for forming an XMPP WG. I don't know the 
details but I would be concerned about revealing plain text passwords 
on a shared media. Are jabber passwords transmitted in clear text? If 
so, I would be hesitant to use it, otherwise I have no objection.

thanks,
-rohan

On Sunday, September 29, 2002, at 08:56 AM, Marshall Rose wrote:

> well, the obvious solution is to use jabber, since it supports 
> conferences, is a software-only solution running on all platforms, and 
> there are servers out there that will host your conference rooms for 
> free.
>
> you need one person in the room with with wifi and a jabber client. 
> ideally, you can get the speakers to have their presentations 
> available via http:// before the meeting, so the person doing the 
> loose transcription can type in the url into the conference room. 
> (that's how a lot of other organizations do this stuff now.)
>
> of course, we're in the process of deciding whether or not to have a 
> post-jabber wg, so this might create a political problem for some.
>
>>> randy:
> err, that's not entirely true. in a physical meeting, it's usually the 
> case that people will behave themselves and not go running up to the 
> mic every 3 words and start speaking over the person at the front of 
> the room...
>
> however, setting aside the cost of a second projector, i like the 
> idea. but, my question to you is whether you could live with "someone 
> with the manners of a jim fleming" being a remote participant...
>
> /mtr

---

From: Jaap Akkerhuis <[email-masked]>
Date: Sun, 29 Sep 2002 21:36:34 +0200

Thoughts?

At the ICANN public forum, there is always a chat session active.
I haven't seen a lot of input via that channel.

Don't we give a wrong message which such an idea? We always pretend
that the IETF WG sessions are not the places where decisions are
made/consensus is reached, but on the mailing lists.

	jaap

---

From: Marshall Rose <[email-masked]>
Date: Sun, 29 Sep 2002 15:40:13 -0700

> perhaps we should not get too deeply enamoured of high-tech and

randy - i think that both im and em have their places, but the time constraints and tools pretty much dictate an im-based solution over an em-based solution.

however, here's a suggestion: let's run an experiment and do both. not in the same wg (of course), but why not try to have 5 or so wgs that meet in atlanta use im and another 5 use em. then we can compare experiences...

/mtr

---

From: Marshall Rose <[email-masked]>
Date: Sun, 29 Sep 2002 15:43:08 -0700

> so, I would be hesitant to use it, otherwise I have no objection.

with the vast majority of deployments, you get three choices: plaintext, one-time, and plaintext-over-ssl. i use the third choice because it also lets me know if someone is trying to hijack the connection...

you're right though: going through and augmenting jabber's security stuff is an important motivation for the proposed working group. (i hesitate to call it broken in that it's presently as good as or slightly better than what i get with email today.)

/mtr

---

From: Randy Bush <[email-masked]>
Date: Mon, 30 Sep 2002 05:18:28 -0700

> But I sure have heard a number of comments that "it would be much more 
> interesting to watch the realtime mcast if we could talk back somehow".

i think no one tries.  it should work.  it did as late as '98 or
'99.  has anyone asked the tech crew why it is not working or is
not being used?

randy

---

From: Harald Alvestrand <[email-masked]>
Date: Mon, 30 Sep 2002 14:10:59 +0200

--On mandag, september 30, 2002 08:13:25 -0400 Frank Kastenholz 
<[email-masked]> wrote:

>
> how many people have actually complained to the i*
> saying "i tried to send feedback via mcast and could not"?
>
> has anyone actually asked for this?
>
> in other words, is there a real problem that needs solving,
> or do you have a solution looking for a problem?

the last time I tried to speak back to a multicasted WG was in 1994.
I was listening to the proceedings, and going "hey, but you forgot that..."
Didn't work at the time, and I don't think it has worked since - if nobody 
EXPECTS it to be able to, they won't ask for it either.

So I think of this as an experiment to see if there is any demand.
If nobody shows up on the other end, we'll have gained a hint that there is 
no problem to be solved.

                   Harald

---

From: Randy Bush <[email-masked]>
Date: Mon, 30 Sep 2002 05:27:09 -0700

> no wires from the mcast boxes to the input side of the room's sound
> system.

boo hiss.  why don't we just do it?  shall i prep the tech crew?

> I didn't like the disembodied-voice-from-on-high feeling I got the few 
> times I have heard it used either.

no, but it's better than no voice.  when i was just out of hospital,
i participated in a few conferences (not ietf) from home via mbone.
it worked, not as well as being there in person, but it worked.

randy

---

From: Harald Alvestrand <[email-masked]>
Date: Mon, 30 Sep 2002 14:23:18 +0200

> '99.  has anyone asked the tech crew why it is not working or is

[private - waiting for others' voices]
no wires from the mcast boxes to the input side of the room's sound system.

not wired because there was no demand. circular dependency.

                   Harald

---

From: Marshall Rose <[email-masked]>
Date: Mon, 30 Sep 2002 06:23:28 -0700

> For a relatively small investment, and a volunteer to operate the machinery, one 
> could could install a KVM switch in front of the projector, switching back and 
> forth during the presentation as well. This is more of a simulation of a user 
> walking up to the mic, giving the remote participant the "floor" and the 
> associated flaming if the comment is a waste of everyone's time.
> 
> For active and unmoderated discussion about the WG session, though not 
> necessarily for interaction *with* the WG session, we could advertise a separate 
> "whispering in the back of the room" chatroom that is not projected.

++

/mtr

---

From: Harald Alvestrand <[email-masked]>
Date: Mon, 30 Sep 2002 16:00:53 +0200

--On mandag, september 30, 2002 09:56:50 -0400 Edward Lewis 
<[email-masked]> wrote:

> I realize the question here is how to get feedback from the Mcast. Is
> there a real demand for Mcast?  I'd be pleased if there is, I've just
> gotten discouraged over the years.

actually, Real has offered to unicast the Atlanta meeting for us (using 
newly developed multicast-to-unicast reflectors).
So people off the MBONE should also be able to watch.

                Harald

---

From: Edward Lewis <[email-masked]>
Date: Mon, 30 Sep 2002 09:56:50 -0400

>'99.  has anyone asked the tech crew why it is not working or is

I made an effort at the Salt Lake meetings (Dec 2001) to get Mcast 
feedback - it was requested by some members.  During the meeting I 
walked over to the techs and asked if there was any activity at all 
(or even any listeners) and they said, basically, "the network is 
down" [0] for the mcast feed.  I should have asked on the mailing 
list if anyone was shut out by this - I thought I had, but the 
archives show I didn't ask.

At my previous employer we did make use of the MBone IETF feed over 
the years.  More so during my first years there (96-98) than in the 
past few, partly because we could no longer see the session 
advertisements.  Our general MBone experience got us to the point of 
locally considering the MBone dead.  When we did the last update of 
some machines before I left, I knowingly didn't even bother to set 
them up for MBone.

When it came to teleconferencing, we also gave up on the audio tools 
altogether - we used the video sessions and the company conference 
phones for internal meetings.  Such an arrangement wouldn't work for 
the IETF.

I realize the question here is how to get feedback from the Mcast. 
Is there a real demand for Mcast?  I'd be pleased if there is, I've 
just gotten discouraged over the years.

[0] I forget the exact technical reason, but "it was broken."
-- 
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Edward Lewis                                          +1-703-227-9854
ARIN Research Engineer

---

From: Derek Atkins <[email-masked]>
Date: 30 Sep 2002 11:06:57 -0400

Harald Alvestrand <[email-masked]> writes:

> actually, Real has offered to unicast the Atlanta meeting for us
> (using newly developed multicast-to-unicast reflectors).

Oooh, that would be cool...  Although it would only be
uni-directional, but that's ok for most cases.

A number of years ago I did watch the multicasts from
a workstation at MIT, at least when I was awake and when
I saw the announcements.  Even with the great connectivity
MIT had, the video was choppy and the audio sometimes dropped
in and out.  At the time I was impressed that it was working,
but in retrospect I don't think I was able to learn much
from the experience.

>                 Harald

-derek

-- 
       Derek Atkins
       Computer and Internet Security Consultant
       [email-masked]             www.ihtfp.com

---

From: Frank Kastenholz <[email-masked]>
Date: Mon, 30 Sep 2002 08:13:25 -0400

At 07:16 AM 9/29/02 +0200, Harald Alvestrand wrote:
>Folks,
>
>last IETF, I talked with the multicast folks about feedback from remote attendees to a WG meeting.
>
>In recent years, we've never had successful multicast-based audio feedback, so we've stopped trying to provide for it.
>
>One thing we wanted to try, though, is to see whether a chat-based feedback could work.
>- A chatroom where the meeting chair has it up on his screen, and reads comments aloud when they seem particularly relevant to the discussion
>
>We'd like you to think about whether your WG would like to be a "victim" for such an experiment, and how you would prefer to execute it (chat technology, security setup, choice among the choices above, other considerations).
>
>If successful, we might consider making it part of the standard setup for the multicast rooms.
>
>Thoughts?
>
>                 Harald

---

From: "W. Mark Townsley" <[email-masked]>
Date: Mon, 30 Sep 2002 09:07:47 +0200

Marshall Rose wrote:
 >>> melinda:
 >>
 >>
 >> i.e., it better simulates the remote participant being there in person.
 >> fair is fair <g>.
 >
 >
 > err, that's not entirely true. in a physical meeting, it's usually the case
 > that people will behave themselves and not go running up to the mic every 3
 > words and start speaking over the person at the front of the room...
 >
 > however, setting aside the cost of a second projector, i like the idea. but,
 > my question to you is whether you could live with "someone with the manners
 > of a jim fleming" being a remote participant...

To get around the multiple projector problem, as well as the obvious distraction
of a chatroom operating alongside the presenter, one could switch over to chat
room on display during the "Q&A" period of a presentation. Presumably, the
remote users are also watching via multicast, so the interaction would be remote
participant -> live event via text, and voice/video back. I like the idea of
yelling at the video camera and getting a typed answer on the screen back.

- Mark

---

From: Colin Perkins <[email-masked]>
Date: Mon, 30 Sep 2002 11:59:53 -0400

I've seen a couple of cases where questions have been mailed to the list by
someone watching the multicast. Having a chat server present might make this
more immediate, but I've also seen those questions lead to discussion on the
list, including other non-local participants, which might be limited if a
chatroom is used.

Colin

--> Frank Kastenholz writes:
>>- A chatroom where the meeting chair has it up on his screen, and reads comments aloud when they 
>seem particularly relevant to the discussion
>>
>>We'd like you to think about whether your WG would like to be a "victim" for such an experiment, 
>and how you would prefer to execute it (chat technology, security setup, choice among the choices 
>above, other considerations).
>>

---

From: "Dean Willis" <[email-masked]>
Date: Mon, 30 Sep 2002 14:30:06 -0500

> This could take one or two (out of many) forms:

At the SIMPLE BOF some years ago, we set up an early SIMPLE server and
handed out Java-based SIMPLE clients. A significant number of people in
the room participated in chat using SIMPLE during the meetings.
Admittedly, we were more playing with the technology than using it to
run the meeting, but the concept was readily understood.

On a related note: In 3GPP SA-1 meetings there are commonly two chat
channels -- one for side conversations, and one for administration of
the meeting such as adjusting the agenda, assigning document numers, and
the like. This seems to work fairly well. The chair will generally
monitor the "official" channel. These meetings are generally small, with
about 40 people attending and no "remote attendees".

--
Dean

---

From: Harald Alvestrand <[email-masked]>
Date: Tue, 01 Oct 2002 00:53:15 +0200

--On mandag, september 30, 2002 14:50:48 -0400 Frank Kastenholz 
<[email-masked]> wrote:

> Right now there is no commercial interest in transmitting
> IETF meetings. As soon as one service/technology starts
> doing it, won't others? What will our policy be on that?

applause?
I don't think we will have much sale of the IETF on pay-per-view....

> What will our policy be on the editorial control of the
> broadcasts? Will they be limited to just the working
> groups we specify or will they be able to broadcast
> everything?

we feed the signal to the world. people can take it from there.

if people want to set up extra cameras and extra networking gear, we might 
have a different discussion.

                        Harald