Subject: RE: Introducing the ID tracker

From: "Putzolu, David" <[email-masked]>
Date: Wed, 30 Oct 2002 16:02:47 -0800

I agree - I took it for a spin and it is great - 
thank you IESG and secretariat!

Are there plans to make this even better, and if so,
any guidelines on the best place/way to provide suggestions?
Is there a wish list etc.?

Cheers,
David

> -----Original Message-----
> From: Pat R. Calhoun [mailto:[email-masked]] 
> Sent: Wednesday, October 30, 2002 3:46 PM
> To: Harald Tveit Alvestrand; [email-masked]
> Subject: RE: Introducing the ID tracker
> 
> 
> Wow. What a great tool.
> 
> Thanks for making this available - it will certainly make my 
> life easier.
> 
> PatC
> -----Original Message-----
> From: Harald Tveit Alvestrand [mailto:[email-masked]] 
> Sent: Wednesday, October 30, 2002 3:10 PM
> To: [email-masked]
> Subject: Introducing the ID tracker
> 
> 
> Hello,
> 
> The IESG is always trying to work better.
> We have gotten a number of comments from the community that 
> it is sometimes 
> very hard to find out what the IESG is doing to documents, 
> why documents
> 
> take a long time to process, who makes comments, what the 
> comments are and 
> so on, and that this is a significant source of frustration for the 
> community.
> 
> For the last year or so, the secretariat has been working on 
> a tool to help 
> us keep track of what documents are on our plate, what state 
> they are in
> 
> and who is responsible for them; we call it the "ID tracker". 
> It's been in 
> use for about 6 months now, and has definitely improved our 
> ability to keep 
> track.
> 
> For several months, the "status of items" pages on the IESG 
> web pages have 
> been generated from this tool, showing the high-order bit of 
> who we think 
> is responsible.
> 
> In order to help you know more about what we are doing, we've 
> decided to
> 
> open up a public view of the ID tracker itself.
> 
> This will allow you to search for the documents you want to 
> look at, and
> 
> for each document see:
> 
> - What its current state is
> - What the history of IESG processing is
> - AD and IESG comments on the document
> - For documents in IESG consideration for standards track, what the 
> individual ADs have indicated as their opinion on the 
> document, and if they 
> think there are problems with it, what the comments are.
> 
> The last point is a revision of previous IESG policy, based 
> on the feedback 
> from the Yokohama plenary; we are now telling you the names 
> that go with
> 
> each comment from the IESG members.
> 
> The system is far from perfect - you can tell from the 
> history of documents 
> that we've been changing this as we go along - but we hope 
> that it will be 
> a useful tool for people to figure out what the IESG is doing 
> with their
> 
> documents, and for them to have an easier time talking to the 
> relevant ADs 
> in order to get what we all want out of the process - relevant, high 
> quality standards for the Internet.
> 
> The tool and its documentation is found at
> 
https://datatracker.ietf.org/public/pidtracker.cgi

The link to it will be placed on the IESG web page before the public 
announcement is sent (which will happen on Monday if we don't find really 
serious problems with it).

Welcome!

              The IESG

---

From: Thomas Narten <[email-masked]>
Date: Wed, 30 Oct 2002 20:47:51 -0500

> Is there a wish list etc.?

There are lots of plans (but also limited resources). Note that the
tool has taken many months to get where it is, but we have a lot of
other ideas. For one thing, we'd like to automate a lot more of the
tasks that take place as documents go from one state to another. For
example, if a new ID is needed, it would be nice if the tool
automatically learned when a new revision appeared, perhaps resulting
in a mail ping to the AD to go followup. Or, when a document is ready
for IETF Last Call, it would be nice if an AD could just use the tool
to make it happen. Right now, the actual steps involve sending mail to
the Secretariat, having them do some things, and then having them send
out the mail. Even now, the way we actually process Evaluations (i.e.,
the ones you can now see via ID Tracker) involves mailing them around,
having the secretariate cut-and-paste them into files, etc. It would
be nice to automate more of this.

So, yes, the potential list is almost endless. :-) (And don't take the
above as any sort of priority list. There are many "smaller" things
too, like getting the fonts better and the HTML that it generates to
be more standards-oriented so that it works better with different
broswers).

In terms of sending suggestions for improvements, it might be best in
the long term to set up a separate list for that. Stay tuned.

Thomas

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Thu, 31 Oct 2002 09:14:04 +0800

> Is there a wish list etc.?

Yes, definitely.

we've been fussing with it far too much over the last few weeks - by this 
time I'd like to use it for a while, let us gain some experience with a 
stable system and so on.

We're going to send out the same announcement that you got to the 
ietf-announce list on Monday, so that the whole community knows about it.

Once the developer (Michael Lee at the secretariat) gets back to the 
office, we'll figure out how to handle bugs, requests and suggestions - 
there will certainly be quite a few of them!

(and for things that aren't listed in the state you think they have, the 
responsible AD is of course the person to pester.....)

                       Harald