Subject: RE: Where's the code (was: Input solicited: IETF problem pinpoint ing at the plenary?)

From: "Glenn Parsons" <[email-masked]>
Date: Wed, 30 Oct 2002 15:31:28 -0500

While we are on the topic of standards track documents I am concerned about
the non-standards track.  That is, mostly the Informational documents that
can be progressed either through WGs (these are currently mostly
requirements and framework) and those that are not.  There is no distinction
between those that have been approved by a WG/IESG and those that have not.
(The fact that these are 'marketed' as IETF standards to the unwashed is
another problem...)

And then we get those documents that have not gone through a WG spawn a
plethora of work that tells me the effort should have gone through a WG in
the first place.  Take, for example, 2547 that was just mentioned...

Glenn.

> ----------
> From: 	Spencer Dawkins
> Sent: 	Wednesday, October 30, 2002 3:02 PM
> To: 	[email-masked]
> Subject: 	RE: Where's the code (was: Input solicited: IETF problem
> pinpointing at the plenary?) 
> 
> Now, Melinda has raised an interesting question... whether we're using the
> Proposed/Draft/Standard mechanism to our advantage.
> 
> There are a heckuva lot of Proposed Standards that we couldn't run the
> Internet without - my personal favorite is "TCP Congestion Control", but
> you can find your own favorites at
> http://www.rfc-editor.org/rfcxx00.html#Proposed.
> 
> Conversely, while looking further up the page, I note that we have not
> published a full standard since September, 2000, (the highest RFC number
> is 2920) and have only published about 20-25 full standards since RFC
> 1122/1123.
> 
> So I'm wondering about a "standards-track compression" - instead of really
> advancing standards to full standard status, we approve them as Proposed
> Standards, and they park there for a while. (There are a number of
> Proposed Standards from 1975-1980 at the bottom of the list - mostly for
> Telnet options.)
> 
> So, I guess I'd like to talk (perhaps at our cool party in Atlanta?) about
> whether we're really using the three-stage Standard approval process, or
> doing something else?
> 
> Spencer
> 
> -----Original Message-----
> From: Melinda Shore [mailto:[email-masked]]
> Sent: Wednesday, October 30, 2002 1:16 PM
> To: Kurt D. Zeilenga
> Cc: Harald Tveit Alvestrand; [email-masked]
> Subject: Re: Where's the code (was: Input solicited: IETF problem
> pinpointing at the plenary?) 
> 
> 
> > I wonder if anyone else has noticed the growing lack of
> > "running code" associated with works being progressed on
> > the Standard Track.
> 
> Of course: "rough consensus and running code" doesn't
> describe the current process very well on either count.
> Part of this is because of a shift towards starting from
> scratch (no protocol), developing requirements and a
> framework and then proceeding from that.  (In several
> working groups I've been involved with the process has been
> subverted somewhat, so that the framework and requirements
> are reverse-engineered from an existing protocol, which I
> think is a problem of a different kind.)  We also seem to
> have a lot of participants who don't write code - technical
> marketing-type folks, etc.
> 
> I don't really see it as a problem, or at least one that can
> be solved without moving away from the requirements/
> framework process - it's still the case that a document
> can't proceed to Draft Standard without two interoperable
> implementations.
> 
> Melinda
> 
>

---

From: "James Kempf" <[email-masked]>
Date: Wed, 30 Oct 2002 14:14:38 -0800

Code is important, but sometimes it isn't enough. It's hard to get any idea
about scalability and deployability from prototype implementations, for example.
Simulations can help here, as long as the WG doesn't get into the "dualing
simulations" mode.

            jak