Subject: RE: Where's the code (was: Input solicited: IETF problem pinpointing at the plenary?)

From: "Eric Burger" <[email-masked]>
Date: Sun, 3 Nov 2002 10:17:56 -0500

The thing that is driving me batty is the number of drafts that are of the vein, "wouldn't it be neat if".  It seems to me that some people see the IETF as a place to publish unrefereed articles.  When I ask for working code, it's usually because the proposal is exploring the solution space.  That's a polite way of saying it's a "fishing expedition".

Part of the problem is that it takes so long to progress a document (that's another thread) that I-D's start to appear to have the force of a standard.  Yes, we are all admonished that I-D's have NO force as a standard.  However, when there is a vacuum for a standard, I-D's are getting used for that purpose.

I've seen commercial requests for proposals that list I-D's as requirements.  Some of those I-D's that get listed have 0 implementations.

Before you say, "too bad for them", I would like to point out trouble in our own back yard.  New I-D's need to be in the format specified by draft-rfc-editor-rfc2223bis-02.txt.  Too bad that's an I-D, and not an RFC :-)

> -----Original Message-----
> From: Melinda Shore [mailto:[email-masked]]
> Sent: Wednesday, October 30, 2002 2:16 PM
> To: Kurt D. Zeilenga
> Cc: Harald Tveit Alvestrand; [email-masked]
> Subject: Re: Where's the code (was: Input solicited: IETF problem
> pinpointing at the plenary?) 
> 
> 
> > I wonder if anyone else has noticed the growing lack of
> > "running code" associated with works being progressed on
> > the Standard Track.
> 
> Of course: "rough consensus and running code" doesn't
> describe the current process very well on either count.
> Part of this is because of a shift towards starting from
> scratch (no protocol), developing requirements and a
> framework and then proceeding from that.  (In several
> working groups I've been involved with the process has been
> subverted somewhat, so that the framework and requirements
> are reverse-engineered from an existing protocol, which I
> think is a problem of a different kind.)  We also seem to
> have a lot of participants who don't write code - technical
> marketing-type folks, etc.
> 
> I don't really see it as a problem, or at least one that can
> be solved without moving away from the requirements/
> framework process - it's still the case that a document
> can't proceed to Draft Standard without two interoperable
> implementations.
> 
> Melinda
>

---

From: Edward Lewis <[email-masked]>
Date: Mon, 4 Nov 2002 10:25:13 -0500

I too have been concerned about the lack of software to back up 
documents[0].  But on the other hand, there have been problems with 
vendors implementing to I-D's which have resulted in a WG being 
shackled to a subpar design[1].

As the (financial) stakes get higher docs get before code, (design 
before implementation, strategy before tactics).  Additionally, doing 
what it takes to make reliable (reviewed, quality assured) code is 
harder - perhaps too hard for an open source effort.  I've been 
worried that the IETF is creeping towards the dreaded formalized 
world, such as ISO/OSI as the stakes have risen.

[0] - Case in point:
http://ops.ietf.org/lists/namedroppers/namedroppers.2002/msg01661.html

[1] - Clearest case I can think of involves DHCP about the time of 
the Oslo meeting in 1999.  MS Windows had implemented an I-D version 
and distributed the code widely.  I mean not to pick on MS (again), I 
guess you could say they *were trying* to get new technology out 
there.

-- 
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Edward Lewis                                          +1-703-227-9854
ARIN Research Engineer

---

From: Randy Bush <[email-masked]>
Date: Sun, 03 Nov 2002 07:32:52 -0800

> The thing that is driving me batty is the number of drafts that
> are of the vein, "wouldn't it be neat if".  It seems to me that
> some people see the IETF as a place to publish unrefereed
> articles.  When I ask for working code, it's usually because the
> proposal is exploring the solution space.  That's a polite way of
> saying it's a "fishing expedition".

It's perfectly appropriate to be upset.  I thought of it in a
slightly different way--like a space that we were exploring and, in
the early days, we figured out this consistent path through the
space: IP, TCP, and so on.  What's been happening over the last few
years is that the IETF is filling the rest of the space with every
alternative approach, not necessarily any better.  Every possible
alternative is now being written down.  And it's not useful.
-- Jon Postel