Subject: Re: Gauging Global Impact (was: Input solicited: IETF problem pinpointing at the plenary?)

From: Brian E Carpenter <[email-masked]>
Date: Fri, 01 Nov 2002 09:59:49 +0100

Melinda Shore wrote:

> > as well as I would like.  For example, when the IAB circulated the
> > UNSAF considerations ID, several folks who participate in the MIDCOM
> > working group made comments, but there was no *discussion* from the WG
> > or the IAB.  I think there was a fair amount of apathy all around.
> 
> What I've run into in several working groups, including
> midcom, is that the problem isn't just apathy but
> additionally some level of antipathy.  I've particularly run
> into this in discussions of interactions between routing and
> "other stuff," for example QoS or middlebox location/
> discovery.  The IAB considerations documents have proven to
> be enormously useful and are welcomed by a subset of the
> community, but there's another subset that considers it
> irrelevant meddling ...

Many standards bodies have a much more rigid approach to
architecture - if you don't conform to the general architecture,
you're history. People who think that the IAB is "meddling"
are probably in the wrong place.

...
> I tend to think that architecture BOFs would suffer from the
> same problem and that people not involved with the area
> being discussed would tend not to show up.  As I've said
> before I'm not much of a fan of introducing more layers of
> hierarchy, but perhaps something like the equivalent of a
> directorate under the IAB might help.

Not sure. I trailed the idea of an Architecture WG operating
as a fuzzy cloud around the IAB a few years ago, but nobody
seemed to think it would help.

I think we just have to make this a very explicit WG Chair
responsibility: we *are* responsible for coherency with work
done in other WGs and we *are* obliged to be responsive to
architectural input from the IAB and IESG.

I'd also like to see a few roadmap documents that cover
multiple WGs, not just a single WG.

  Brian

---

From: Melinda Shore <[email-masked]>
Date: Fri, 01 Nov 2002 08:25:00 -0500

> you're history. 

It's somewhat different, in that 1) their architecture is
generally something along the lines of our framework
documents (less thorough and less carefully executed, in
many cases) and that 2) it tends to be the same people who
evaluate the architecture for "correctness" that do the
requirements, etc.

In the IETF the architectural issues we're typically butting
up against are different, in that the addressing
architecture and routing architecture of the base protocol
(IP) provide some constraints on what's reasonable to do,
and I think it's those constraints that chafe in the cases
we're talking about.  <insert name of standards body here>
would not feel so constrained, but would just add another
layer to the architecture.

> architectural input from the IAB and IESG.

Works for me.

Melinda

---

From: Margaret Wasserman <[email-masked]>
Date: Fri, 01 Nov 2002 11:17:29 -0500

>multiple WGs, not just a single WG.

This would be _extremely_ helpful in some cases.  What would
be the best way to get something like this to happen?

Margaret

---

From: Avri Doria <[email-masked]>
Date: Fri, 01 Nov 2002 18:27:41 +0100

This seems like it would be a good activity for the Area Directorates.
Though some of the road maps, might be cross area.

a.

---

From: Edward Lewis <[email-masked]>
Date: Mon, 4 Nov 2002 09:14:59 -0500

Unsarcastically, a WG chair party, at say, Atlanta. ;)

Just getting chairs together in one room might start conversations 
that don't fit any particular list.

-- 
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Edward Lewis                                          +1-703-227-9854
ARIN Research Engineer

---

From: Margaret Wasserman <[email-masked]>
Date: Mon, 04 Nov 2002 09:36:52 -0500

>Unsarcastically, a WG chair party, at say, Atlanta. ;)

Say, that's a good idea.  Why doesn't someone hold one?  :-)

Margaret

---

From: avri doria <[email-masked]>
Date: Fri, 01 Nov 2002 17:36:34 +0100

This seems like it would be a good activity for the Area Directorates.
Though some of the roadmaps, might be cross area.

a.

---

From: avri doria <[email-masked]>
Date: Fri, 01 Nov 2002 11:00:21 +0100

> seemed to think it would help.

Might be worth floating the idea again.  Perhaps
something in the General area.

> architectural input from the IAB and IESG.

But isn't it the IAB part of the approval chain for WGs?
This being they case, they can require that the architectural
implications be made explicit in the first round of milestones
and only approve the milestone change for the actual
work after the implications are known and understood. Unless of
course a BoF does the work first and presents it to the I* when
applying for the charter approval.

I don't think the entire burden can be on the WG.

> multiple WGs, not just a single WG.

Sounds like a great task for the AD's directorates.

-- 
Avri Doria
http://www.sm.luth.se/~avri/

---

From: Frank Kastenholz <[email-masked]>
Date: Tue, 12 Nov 2002 16:00:20 -0500

>something in the General area.

If the IAB is doing a fine job of architecture, then
we don't need this working group.
If the IAB is not doing a fine job of architecture,
then what makes us believe that this working group
will (and, conversely, why not just put the WG members
on the IAB and be done with it).

Resident Grump

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Wed, 13 Nov 2002 12:37:20 +0100

> on the IAB and be done with it).

one issue raised was that it's hard to know where to go to discuss 
architecture with the IAB.

quotes:

> It's hard to get a discussion going when the IAB works on architectural
> considerations (Rohan Mahy)
>
> Documents that bypass the WG process sometimes have huge impact on the
> work we have to do (Glenn Parsons)
>
> Some consider IAB architectural guidelines/question to be "meddling" by
> "outsiders" (Melinda Shore)

note that IAB documents are one example of docs that bypass the WG process.

letting my problem focus slip slightly.....I think we might need objects in 
the IETF space that are neither steering groups (which have closed 
membership and fixed selection process) nor working groups (which are open, 
but have focused charters and bounded lifetimes).

IRTF WGs are one example of "other things" - there may be other types of 
things that could be useful.
For the solutions workout....

                  Harald

---

From: Edward Lewis <[email-masked]>
Date: Wed, 13 Nov 2002 09:15:42 -0500

At the risk of being Yet Another Resident Grump, an Architecture WG 
breaks a lot of WG rules.  No defined scope, to begin with.

WGs should be more disposable, and starting one shouldn't be so hard.

Harking back to my earliest IETF experience, the thought that "got me 
in" was that this organization had implemented technological 
darwinism.  By the mere fact that ID's time out, any idea may come 
along, but only the good ones prosper.  We've maintained that in the 
documents, but I think the concept has been lost when thinking about 
WG's.

Sorry to derail.  Post meeting enthusiasm and all, I guess.

---

From: Frank Kastenholz <[email-masked]>
Date: Wed, 13 Nov 2002 09:48:40 -0500

At 12:37 PM 11/13/2002 +0100, Harald Tveit Alvestrand wrote:

>--On tirsdag, november 12, 2002 16:00:20 -0500 Frank Kastenholz <[email-masked]> wrote:
>
>one issue raised was that it's hard to know where to go to discuss architecture with the IAB.

It would seem to me that this is an action item
for the IAB to take. Yes? I mean, how would we feel
if the IAB came around and said "We think there are
problems with the working group chairs, so we've created
a new set of chairs"

>note that IAB documents are one example of docs that bypass the WG process.

IAB documents also do not have the force of being a standard.
(Except for the marketroids and professional-standards-goers and
panda watchers who believe that every RFC is a standard and every
ID is an RFC -- but they are idiots and I do not see why we
should pander to their lack of intelligence.)

IAB documents are more or less like individual submissions in so far
as The Sacred And Holy Process is concerned. People are free to heed
them or ignore them as they wish.

>IRTF WGs are one example of "other things" - there may be other types of things that could be useful.

IRTF working groups are not in the IETF.

Frank Kastenholz

---

From: Leslie Daigle <[email-masked]>
Date: Wed, 13 Nov 2002 10:39:09 -0500

So, I'm perfectly open, as part of revisiting IETF process, to 
revisit & revise IAB activities as necessary.

Let me say that the IAB is still living under the Kobe Cloud --
very conscious of what it ought not do, but less certain of
where its input will be appreciated.  

What we've been doing to work around that, increasingly, is
to work with the IESG:  identifying hotspots and attempting
to provide usable architectural insight.  Something like the
UNSAF considerations, for example, was put together to try
to communicate what are the percieved issues in the space of
working around NATs to guess addresses.  In itself, the
document has no force of law.  But, it is provided as a tool
for the IESG and for WGs -- the IESG can push back on 
some ideas by pointing to it.  It's intended as technical
transparency (hopefully reducing the appearance of technical
dogma by providing a written statement of issues).

That's not developing a "proactive" architectural picture.
But it is attempting to write down what is currently understood
in teh way of shared architectural principles.  That may
be the best we can do for now.

Other ideas welcome.

Leslie.

-- 

-------------------------------------------------------------------
"An essential element of a successful journey
    is recognizing when you have arrived."
       -- ThinkingCat (c.1983 - 2002)

Leslie Daigle
[email-masked]
-------------------------------------------------------------------

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Wed, 13 Nov 2002 08:07:07 -0800

>them or ignore them as they wish.

RFCs produced by Individuals have the same standing as those
documents produced by WGs (within a particular track/status).
That is, people are free to heed or ignore WG documents as they
wish.

Kurt

---

From: "James Kempf" <[email-masked]>
Date: Wed, 13 Nov 2002 12:02:41 -0800

Frank,

The IESG controls the technical agenda for the IETF. That includes architecture.
All the many documents with "framework" in their title are examples of
architecture. These go through the normal working group process, so the only way
the IAB ever gets anything to say about these is as WG members or WG chairs. The
IAB does not have the Jedi Power of the IESG, whereby they can say "either you
take this out (or put that in) or we are not going to make it an RFC". So other
WG members and chairs are free to ignore them, quibble with them, or take their
input seriously, all of which they do.

The high profile cases, such as OPES, seem to occur when the IESG doesn't really
have an opinion (or would rather not give one), the IETF as a community is
split, and there is some need for a statement about what is consistent with the
Internet architecture, as it has historically been known. That this is perceived
as "meddling" by the WGs is not suprising, it is in fact exactly that. But it is
meddling with a purpose: to try to forge some concensus when the community (and
even the IESG) might be split about what the right solution is. As you state,
the WGs are free to ignore the IAB opinion or not, just as anybody is free to
ignore important Internet architectural principles. More importantly, however,
although the IESG can ignore the opinion, they do so at their peril, because a)
they asked for it (typically)  and b) more than likely, they were consulted
deeply on the opinion while it was being formed. So the enforcement of the IAB
opinion on a particular architectural issue works, as with all technical matters
in the IETF, through the IESG. Thus, in the end, the WGs are going to have to
conform to the opinion if they want their drafts to become RFCs.

Whether or not this round about way of getting architectural input is working or
not is difficult to say. It does tend to make the process slower when there are
highly controversial architectural issues where the IETF as a whole is split,
but, on the other hand, it also tends to provide the IETF with some reflective
input on such issues, which is difficult for them to generate because they have
too many drafts to read and not enough time.

My feeling is that the real problems with architecture in the IETF stem from
getting the "small" architectures done by individual WGs to fit together. Turf
conflicts, lack of knowledge about what other WGs are doing, and increasing
complexity are all working against us here. Unfortunately, I've got no stock
answer about how to fix this problem.

            jak

----- Original Message -----
From: "Frank Kastenholz" <[email-masked]>
To: "Harald Tveit Alvestrand" <[email-masked]>; "avri doria"
<[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, November 13, 2002 6:48 AM
Subject: Re: Gauging Global Impact (was: Input solicited: IETF problem
pinpointing at the plenary?)