Subject: Re: Where's the code (was: Input solicited: IETF problem pinpointing at the plenary?)

From: "James V. Luciani" <[email-masked]>
Date: Wed, 30 Oct 2002 23:27:09 -0500

Don't know if this is clawing back up or not but...
Seems most folks think Internet Draft to draft standard transition does not
require implementation (certainly that is how things are written
now).  However, if some folks feel sufficiently strongly that there is a
bug in this then perhaps alternative designation for when the draft is
"unstable" versus when it is in "tweaking" mode (not subject to substantive
change but flawed and yet fixable) is what is needed.  We could overload
yet another set of semantics and delineate this difference as occurring
when a doc goes from individual submission to WG doc or come up with some
completely different designation altogether.  At any rate,  you need to
give vendors a shot at knowing that the spec they are developing to is
moderately stable (for some "#define moderate" and some "#define stable").

At 06:51 AM 10/31/02 +0800, Harald Tveit Alvestrand wrote:
>this particular thread is probably a rathole, and we should claw back to
>the higher levels.....the identified problem is, I think, that we think
>there are cases where things go to Proposed Standard specifying things
>that can't work.
>One way to avoid that is to insist that someone try it before submission.
>
>Fair summary? Let's put that on the problem list.
>
>--On 30. oktober 2002 14:32 -0500 James Luciani
><[email-masked]> wrote:
>
>>
>>The thought that you need running code before draft standard is one of
>>those things where someone wants their cake and eat it too...  When
>>packet formats change from rev to rev in a internet draft in an
>>incompatible way, the theory is that it is no big deal because "if you
>>are implementing a draft then caveat emptor... get over it!"  I certainly
>>have heard this MANY times before...  what I am hearing here is a
>>proposal for running code prior to being draft standard,i.e.,when the
>>protocol is an internet draft.....  Hmmm....
>
>having tried to claw up, I can't resist the temptation to dig the rathole
>a bit deeper..... I remember in particular my experience from the MIXER wg
>(X.400/SMTP interworking), where we made a great number of things go into
>the standard without coding them first - but we knew, with a very large
>degree of certainty, that they were *implementable*, because they were
>really of the kind "if this field is 5, put "high" in that field" - it's
>obvious by inspection that you can do it, but it just takes quite a few
>man-hours to go through them all, and you don't want to use that until the
>document is stable.
>
>OTOH, someone should REALLY have tried to code the notification conversion
>routines before submitting for Proposed, because they were more than a
>little convoluted, and might have been done differently.
>
>I wouldn't want to insist that all the paper sizes in the IPP protocol be
>implemented in running code before submission either - but would very much
>like to see that someone had made a secure operation using the security
>primitives defined. (I think that someone did - Carl?)
>
>So "running code" is different for different specs, and even for parts of
>the spec - no "one size fits all" rule seems to be right here.
>
>My contribution to the rathole...
>
>                     Harald

---

From: Liming Wei <[email-masked]>
Date: Wed, 30 Oct 2002 11:59:06 -0800 (PST)

If a protocol is so unstable prior to being a draft standard,
something is wrong with the standardization process.

Has the time changed that the IETF now moves forward protocols based on
time schedule, instead of the specification's maturity ?

-Liming
---------
> From: "James Luciani" <[email-masked]>
>
> RE: Where's the code (was: Input solicited: IETF problem pinpointing at =
> the plenary?)The thought that you need running code before draft =
> standard is one of those things where someone wants their cake and eat =
> it too...  When packet formats change from rev to rev in a internet =
> draft in an incompatible way, the theory is that it is no big deal =
> because "if you are implementing a draft then caveat emptor... get over =
> it!"  I certainly have heard this MANY times before...  what I am =
> hearing here is a proposal for running code prior to being draft =
> standard,i.e.,when the protocol is an internet draft.....  Hmmm....
>
> ----- Original Message -----=20
>   From: Harrington, David=20
>   To: 'Kurt D. Zeilenga' ; Harald Tveit Alvestrand=20
>   Cc: [email-masked]=20
>   Sent: Wednesday, October 30, 2002 2:20 PM
>   Subject: RE: Where's the code (was: Input solicited: IETF problem =
> pinpointing at the plenary?)
>
>
>   Hi,=20
>
>   If the WG needs to show interoperable implementations to progress from =
> Proposed to Draft Standard, I don't see how a submission can advance =
> without running code. Did you have some specific examples of =
> standards-track advancement without running code?
>
>   Are you suggesting that running code be a requirement to be met before =
> a document can be submitted to become a Proposed Standard? That would =
> require running code based in internet-drafts, and I wouldn't like that. =
> The Proposed Standard level was designed to provide a relatively stable =
> specification (WG agrees spec is acceptable) for implementation to =
> develop running code.
>
>   dbh=20
>   ---=20
>   David Harrington           =20
>   [email-masked]          =20
>   co-chair, IETF SNMPv3 WG=20
>
>
>
>   > -----Original Message-----=20
>   > From: Kurt D. Zeilenga [mailto:[email-masked]]=20
>   > Sent: Wednesday, October 30, 2002 1:38 PM=20
>   > To: Harald Tveit Alvestrand=20
>   > Cc: [email-masked]=20
>   > Subject: Where's the code (was: Input solicited: IETF problem=20
>   > pinpointing at the plenary?)=20
>   >=20
>   >=20
>   > I wonder if anyone else has noticed the growing lack of=20
>   > "running code" associated with works being progressed on=20
>   > the Standard Track.  For every standard track submission,=20
>   > we need to ask "where's the code?" and, when the answer=20
>   > is "none (yet)", seriously doubt the appropriateness of=20
>   > progressing the work on the Standard Track.=20
>   >=20
>   > Kurt=20
>   >=20
>
>
> ------=_NextPart_000_0179_01C28021.2B916460
> Content-Type: text/html;
> 	charset="iso-8859-1"
> Content-Transfer-Encoding: quoted-printable
>
> <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
> <HTML><HEAD><TITLE>RE: Where's the code (was: Input solicited: IETF =
> problem pinpointing at the plenary?)</TITLE>
> <META content=3D"text/html; charset=3Diso-8859-1" =
> http-equiv=3DContent-Type>
> <META content=3D"MSHTML 5.00.3504.2500" name=3DGENERATOR>
> <STYLE></STYLE>
> </HEAD>
> <BODY bgColor=3D#ffffff>
> <DIV><FONT face=3DArial size=3D2>The thought that you need running code =
> before draft=20
> standard is one of those things where someone wants their cake and eat =
> it=20
> too...&nbsp; When packet formats change from rev to rev in&nbsp;a =
> internet draft=20
> in an incompatible way, the theory is that it is no big deal because "if =
> you are=20
> implementing a draft then caveat emptor... get over it!"&nbsp; I =
> certainly have=20
> heard this MANY times before...&nbsp; what I am hearing here is&nbsp;a =
> proposal=20
> for running code prior to being draft standard,i.e.,when the protocol is =
> an=20
> internet draft.....&nbsp; Hmmm....</FONT></DIV>
> <DIV>&nbsp;</DIV>
> <DIV>----- Original Message ----- </DIV>
> <BLOCKQUOTE=20
> style=3D"BORDER-LEFT: #000000 2px solid; MARGIN-LEFT: 5px; MARGIN-RIGHT: =
> 0px; PADDING-LEFT: 5px; PADDING-RIGHT: 0px">
>   <DIV=20
>   style=3D"BACKGROUND: #e4e4e4; FONT: 10pt arial; font-color: =
> black"><B>From:</B>=20
>   <A href=3D"mailto:[email-masked]" =
> title=[email-masked]>Harrington,=20
>   David</A> </DIV>
>   <DIV style=3D"FONT: 10pt arial"><B>To:</B> <A =
> href=3D"mailto:[email-masked]"=20
>   title=[email-masked]>'Kurt D. Zeilenga'</A> ; <A=20
>   href=3D"mailto:[email-masked]" =
> title=[email-masked]>Harald Tveit=20
>   Alvestrand</A> </DIV>
>   <DIV style=3D"FONT: 10pt arial"><B>Cc:</B> <A =
> href=3D"mailto:[email-masked]"=20
>   title=[email-masked]>[email-masked]</A> </DIV>
>   <DIV style=3D"FONT: 10pt arial"><B>Sent:</B> Wednesday, October 30, =
> 2002 2:20=20
>   PM</DIV>
>   <DIV style=3D"FONT: 10pt arial"><B>Subject:</B> RE: Where's the code =
> (was: Input=20
>   solicited: IETF problem pinpointing at the plenary?)</DIV>
>   <DIV><BR></DIV>
>   <P><FONT size=3D2>Hi,</FONT> </P>
>   <P><FONT size=3D2>If the WG needs to show interoperable =
> implementations to=20
>   progress from Proposed to Draft Standard, I don't see how a submission =
> can=20
>   advance without running code. Did you have some specific examples of=20
>   standards-track advancement without running code?</FONT></P>
>   <P><FONT size=3D2>Are you suggesting that running code be a =
> requirement to be=20
>   met before a document can be submitted to become a Proposed Standard? =
> That=20
>   would require running code based in internet-drafts, and I wouldn't =
> like that.=20
>   The Proposed Standard level was designed to provide a relatively =
> stable=20
>   specification (WG agrees spec is acceptable) for implementation to =
> develop=20
>   running code.</FONT></P>
>   <P><FONT size=3D2>dbh</FONT> <BR><FONT size=3D2>---</FONT> <BR><FONT =
> size=3D2>David=20
>   =
> Harrington&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nb=
> sp;=20
>   </FONT><BR><FONT=20
>   =
> size=3D2>[email-masked]&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp=
> ;&nbsp;&nbsp;=20
>   </FONT><BR><FONT size=3D2>co-chair, IETF SNMPv3 WG</FONT> </P><BR>
>   <P><FONT size=3D2>&gt; -----Original Message-----</FONT> <BR><FONT =
> size=3D2>&gt;=20
>   From: Kurt D. Zeilenga [<A=20
>   href=3D"mailto:[email-masked]">mailto:[email-masked]</A>]</FONT> =
> <BR><FONT=20
>   size=3D2>&gt; Sent: Wednesday, October 30, 2002 1:38 PM</FONT> =
> <BR><FONT=20
>   size=3D2>&gt; To: Harald Tveit Alvestrand</FONT> <BR><FONT =
> size=3D2>&gt; Cc:=20
>   [email-masked]</FONT> <BR><FONT size=3D2>&gt; Subject: Where's the =
> code (was:=20
>   Input solicited: IETF problem</FONT> <BR><FONT size=3D2>&gt; =
> pinpointing at the=20
>   plenary?)</FONT> <BR><FONT size=3D2>&gt; </FONT><BR><FONT =
> size=3D2>&gt;=20
>   </FONT><BR><FONT size=3D2>&gt; I wonder if anyone else has noticed the =
> growing=20
>   lack of</FONT> <BR><FONT size=3D2>&gt; "running code" associated with =
> works=20
>   being progressed on</FONT> <BR><FONT size=3D2>&gt; the Standard =
> Track.&nbsp; For=20
>   every standard track submission,</FONT> <BR><FONT size=3D2>&gt; we =
> need to ask=20
>   "where's the code?" and, when the answer</FONT> <BR><FONT =
> size=3D2>&gt; is "none=20
>   (yet)", seriously doubt the appropriateness of</FONT> <BR><FONT =
> size=3D2>&gt;=20
>   progressing the work on the Standard Track.</FONT> <BR><FONT =
> size=3D2>&gt;=20
>   </FONT><BR><FONT size=3D2>&gt; Kurt</FONT> <BR><FONT size=3D2>&gt;=20
> </FONT></P></BLOCKQUOTE></BODY></HTML>
>
> ------=_NextPart_000_0179_01C28021.2B916460--
>

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Thu, 31 Oct 2002 23:03:39 +0800

--On 31. oktober 2002 08:59 -0500 Frank Kastenholz
<[email-masked]> wrote:

> At 06:51 AM 10/31/2002 +0800, Harald Tveit Alvestrand wrote:
>> that can't work. One way to avoid that is to insist that someone try it
>> before submission.
>
> How many instances have there been of a proposed standard specifying
> things that can't work? Can you cite drafts?
>
> I'm not saying that this isn't a problem. I am saying that I don't know
> if it's a problem or how big the problem is, so I'd like some numbers.

I have a number, but it has the value 1.....

one of the things I remember was RFC 1327 (X.400 to SMTP mapping) assigning
and using the object identifier 0.9.2342.234219200300

Once someone tried to implement that, they discovered that they had an
OID-handling library that could not handle OID elements larger than 32 bits.
The element was removed in RFC 2156.

                   Harald

---

From: Harald Tveit Alvestrand <[email-masked]>
Date: Thu, 31 Oct 2002 23:03:39 +0800

Harald

---

From: Frank Kastenholz <[email-masked]>
Date: Tue, 12 Nov 2002 16:05:37 -0500

>moderately stable (for some "#define moderate" and some "#define stable").

won't that simply shift the problem?
i mean, we now say that only RFCs are "stable" or
even "moderately stable". so vendors implement
to internet-drafts that are not stable. if we
say that "this" ID is moderately stable, then
vendors will simply start implementing to some
rev of the ID before the moderately stable one.

also, i have seen Internet Drafts that had gone
through all the stages and were on the IESG's
plate when the WG had A Brilliant Idea and pulled
the ID back and made major changes to things. This
completely shatters the notion of "stable".
Of course, we could say that once it's marked as
"stable" then these sorts of changes can't be made.
So what's the difference between a "stable ID" and
an RFC then?